aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.qt.mk2
-rw-r--r--databases/qt4-odbc-plugin/files/Makefile.bsd2
-rw-r--r--devel/qmake4/Makefile4
-rw-r--r--devel/qmake4/files/Makefile.bsd5
-rw-r--r--devel/qmake4/pkg-plist3
-rw-r--r--devel/qt4-script/files/patch-src-3rdparty-javascriptcore-JavaScriptCore-wtf-Platform.h11
-rw-r--r--devel/qt4/Makefile14
-rw-r--r--devel/qt4/distinfo6
-rw-r--r--misc/qt4-doc/pkg-plist3
-rw-r--r--misc/qt4-l10n/pkg-plist7
-rw-r--r--misc/qt4-qtdemo/pkg-plist64
-rw-r--r--multimedia/qt4-multimedia/pkg-plist1
12 files changed, 94 insertions, 28 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 6715cc303a27..0b6dca5184fe 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -115,7 +115,7 @@ QTCGFLIBS?=
# QT4 version
# Don't forget to update ${PORTSDIR}/devel/qt4/files/patch-configure !
#
-QT4_VERSION?= 4.6.2
+QT4_VERSION?= 4.6.3
_QT_COMPONENTS_ALL= accessible assistant assistant-adp assistantclient \
clucene codecs-cn codecs-jp codecs-kr codecs-tw corelib \
diff --git a/databases/qt4-odbc-plugin/files/Makefile.bsd b/databases/qt4-odbc-plugin/files/Makefile.bsd
index 0c73245937a5..d28e1142dd8e 100644
--- a/databases/qt4-odbc-plugin/files/Makefile.bsd
+++ b/databases/qt4-odbc-plugin/files/Makefile.bsd
@@ -9,7 +9,7 @@ CXXFLAGS+= -I${DRIVER} \
-I${LOCALBASE}/include \
${PTHREAD_CFLAGS} -DQT_NO_CAST_TO_ASCII -DQT_NO_CAST_FROM_ASCII \
-DQT_PLUGIN -DQT_SQL_LIB -DQT_CORE_LIB -D_LARGEFILE64_SOURCE \
- -D_LARGEFILE_SOURCE -DQT_SHARED
+ -D_LARGEFILE_SOURCE -DQT_SHARED -DUNICODE
LDADD= -L${QT_LIBDIR} -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lQtSql -lodbc
MOC?= ${LOCALBASE}/bin/moc-qt4
SRCS= main.cpp qsql_${DB}.cpp moc_qsql_${DB}.cpp
diff --git a/devel/qmake4/Makefile b/devel/qmake4/Makefile
index 56ae69a69427..913a6e81417a 100644
--- a/devel/qmake4/Makefile
+++ b/devel/qmake4/Makefile
@@ -36,7 +36,9 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
'${DISTNAME}/src/corelib/xml' \
'${DISTNAME}/src/3rdparty/md4' \
'${DISTNAME}/src/3rdparty/md5' \
- '${DISTNAME}/src/3rdparty/sha1'
+ '${DISTNAME}/src/3rdparty/sha1' \
+ '${DISTNAME}/tools/shared/symbian' \
+ '${DISTNAME}/tools/shared/windows'
post-patch:
@${REINPLACE_CMD} -e 's|-O2|${CXXFLAGS}|' \
diff --git a/devel/qmake4/files/Makefile.bsd b/devel/qmake4/files/Makefile.bsd
index 9d6eac70db42..481fb4a429b7 100644
--- a/devel/qmake4/files/Makefile.bsd
+++ b/devel/qmake4/files/Makefile.bsd
@@ -11,14 +11,15 @@ NO_MAN= true # qmake.1 anyone?
${.CURDIR:H}/src/corelib/global ${.CURDIR:H}/src/corelib/plugin \
${.CURDIR:H}/src/corelib/kernel ${.CURDIR:H}/src/corelib/codecs \
${.CURDIR:H}/src/corelib/xml ${.CURDIR:H}/src/3rdparty/md4 \
- ${.CURDIR:H}/src/3rdparty/md5 ${.CURDIR:H}/src/3rdparty/sha1
+ ${.CURDIR:H}/src/3rdparty/md5 ${.CURDIR:H}/src/3rdparty/sha1 \
+ ${.CURDIR:H}/tools/shared/symbian ${.CURDIR:H}/tools/shared/windows
CXXFLAGS+=-I${.CURDIR:H}/mkspecs/freebsd-g++
.for s in src/corelib/arch/generic src/corelib/global src/corelib/tools \
src/corelib/kernel src/corelib/codecs \
src/3rdparty/md5 src/3rdparty/md4 src/3rdparty/sha1 \
- include/QtCore include
+ tools/shared include/QtCore include
CXXFLAGS+=-I${.CURDIR:H}/$s
.endfor
diff --git a/devel/qmake4/pkg-plist b/devel/qmake4/pkg-plist
index 7a750191ac72..a8ac1e1930eb 100644
--- a/devel/qmake4/pkg-plist
+++ b/devel/qmake4/pkg-plist
@@ -69,6 +69,7 @@ share/qt4/mkspecs/features/silent.prf
share/qt4/mkspecs/features/static.prf
share/qt4/mkspecs/features/static_and_shared.prf
share/qt4/mkspecs/features/staticlib.prf
+share/qt4/mkspecs/features/symbian/add_mmp_rules.prf
share/qt4/mkspecs/features/symbian/application_icon.prf
share/qt4/mkspecs/features/symbian/armcc_warnings.prf
share/qt4/mkspecs/features/symbian/data_caging_paths.prf
@@ -274,12 +275,14 @@ share/qt4/mkspecs/solaris-g++-64/qplatformdefs.h
share/qt4/mkspecs/solaris-g++/qmake.conf
share/qt4/mkspecs/solaris-g++/qplatformdefs.h
share/qt4/mkspecs/symbian-abld/qmake.conf
+share/qt4/mkspecs/symbian-abld/qplatformdefs.h
share/qt4/mkspecs/symbian-sbsv2/flm/qt/qmake_emulator_deployment.flm
share/qt4/mkspecs/symbian-sbsv2/flm/qt/qmake_extra_pre_targetdep.flm
share/qt4/mkspecs/symbian-sbsv2/flm/qt/qmake_post_link.flm
share/qt4/mkspecs/symbian-sbsv2/flm/qt/qmake_store_build.flm
share/qt4/mkspecs/symbian-sbsv2/flm/qt/qt.xml
share/qt4/mkspecs/symbian-sbsv2/qmake.conf
+share/qt4/mkspecs/symbian-sbsv2/qplatformdefs.h
share/qt4/mkspecs/tru64-cxx/qmake.conf
share/qt4/mkspecs/tru64-cxx/qplatformdefs.h
share/qt4/mkspecs/tru64-g++/qmake.conf
diff --git a/devel/qt4-script/files/patch-src-3rdparty-javascriptcore-JavaScriptCore-wtf-Platform.h b/devel/qt4-script/files/patch-src-3rdparty-javascriptcore-JavaScriptCore-wtf-Platform.h
index 4107f95ac743..8fe1023f35f4 100644
--- a/devel/qt4-script/files/patch-src-3rdparty-javascriptcore-JavaScriptCore-wtf-Platform.h
+++ b/devel/qt4-script/files/patch-src-3rdparty-javascriptcore-JavaScriptCore-wtf-Platform.h
@@ -1,14 +1,11 @@
---- src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h 2009-10-20 20:13:33.000000000 +1100
-+++ src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h 2009-10-16 16:01:06.000000000 +1100
-@@ -700,9 +700,9 @@
+--- ./src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h.orig 2010-06-02 06:03:12.000000000 +0400
++++ ./src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h 2010-06-09 01:21:29.281286595 +0400
+@@ -723,7 +723,7 @@
#endif
#if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
-#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX) || PLATFORM(SOLARIS) || PLATFORM(HPUX))
+#if (PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX) || PLATFORM(FREEBSD) || PLATFORM(SOLARIS) || PLATFORM(HPUX)))
#define WTF_USE_JSVALUE64 1
--#elif (PLATFORM(IA64) && !PLATFORM(IA64_32)) || PLATFORM(SPARC64)
-+#elif (PLATFORM(IA64) && !PLATFORM(IA64_32)) || PLATFORM(SPARC64) || PLATFORM(ALPHA)
+ #elif (PLATFORM(IA64) && !PLATFORM(IA64_32)) || PLATFORM(SPARC64) || PLATFORM(ALPHA)
#define WTF_USE_JSVALUE64 1
- #elif PLATFORM(ARM) || PLATFORM(PPC64)
- #define WTF_USE_JSVALUE32 1
diff --git a/devel/qt4/Makefile b/devel/qt4/Makefile
index 544a028c1e49..41a3efa8329d 100644
--- a/devel/qt4/Makefile
+++ b/devel/qt4/Makefile
@@ -16,8 +16,6 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Multiplatform C++ application framework (metaport)
OPTIONS= CODECS "Enable support for CN, JP, KR, TW" off \
- PHONON "Phonon support" off \
- QTCONFIG "Qt configuration (depends on PHONON)" off \
SQL_PLUGINS "Database connectivity plugins for QtSql" off \
TOOLS "Install Qt tools (qmake, moc, etc.)" off \
DEMO "Install demonstration and example programs" off
@@ -26,8 +24,8 @@ USE_QT_VER= 4
QT_COMPONENTS= accessible assistant assistant-adp assistantclient \
clucene corelib dbus designer doc help gui iconengines \
imageformats inputmethods multimedia network opengl \
- qdbusviewer qt3support qtestlib qvfb script scripttools \
- sql svg webkit xml xmlpatterns xmlpatterns-tool
+ qdbusviewer qt3support qtconfig qtestlib qvfb script \
+ scripttools sql svg webkit xml xmlpatterns xmlpatterns-tool
NO_BUILD= yes
@@ -42,14 +40,6 @@ QT_COMPONENTS+= help-tools linguist makeqpf moc pixeltool \
porting qmake rcc uic uic3 qdoc3
.endif
-.if defined(WITH_QTCONFIG)
-QT_COMPONENTS+= qtconfig
-.endif
-
-.if defined(WITH_PHONON)
-QT_COMPONENTS+= phonon phonon-gst
-.endif
-
.if defined(WITH_CODECS)
QT_COMPONENTS+= codecs-cn codecs-jp codecs-kr codecs-tw
.endif
diff --git a/devel/qt4/distinfo b/devel/qt4/distinfo
index 312ec0de93d7..aab5d042edc8 100644
--- a/devel/qt4/distinfo
+++ b/devel/qt4/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-everywhere-opensource-src-4.6.2.tar.gz) = eb651ee4b157c01696aa56777fc6e0e5
-SHA256 (KDE/qt-everywhere-opensource-src-4.6.2.tar.gz) = 176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae
-SIZE (KDE/qt-everywhere-opensource-src-4.6.2.tar.gz) = 160601949
+MD5 (KDE/qt-everywhere-opensource-src-4.6.3.tar.gz) = 5c69f16d452b0bb3d44bc3c10556c072
+SHA256 (KDE/qt-everywhere-opensource-src-4.6.3.tar.gz) = f4e0ada8d4d516bbb8600a3ee7d9046c9c79e38cd781df9ffc46d8f16acd1768
+SIZE (KDE/qt-everywhere-opensource-src-4.6.3.tar.gz) = 160993454
diff --git a/misc/qt4-doc/pkg-plist b/misc/qt4-doc/pkg-plist
index 96bd4485ca79..51d0e14600a2 100644
--- a/misc/qt4-doc/pkg-plist
+++ b/misc/qt4-doc/pkg-plist
@@ -4579,6 +4579,7 @@
%%DOCSDIR%%/html/qpolygonf-members.html
%%DOCSDIR%%/html/qpolygonf.html
%%DOCSDIR%%/html/qprintdialog-members.html
+%%DOCSDIR%%/html/qprintdialog-qt3.html
%%DOCSDIR%%/html/qprintdialog.html
%%DOCSDIR%%/html/qprintengine-members.html
%%DOCSDIR%%/html/qprintengine.html
@@ -4664,6 +4665,8 @@
%%DOCSDIR%%/html/qs60maindocument.html
%%DOCSDIR%%/html/qs60style-members.html
%%DOCSDIR%%/html/qs60style.html
+%%DOCSDIR%%/html/qscopedarraypointer-members.html
+%%DOCSDIR%%/html/qscopedarraypointer.html
%%DOCSDIR%%/html/qscopedpointer-members.html
%%DOCSDIR%%/html/qscopedpointer.html
%%DOCSDIR%%/html/qscreen-members.html
diff --git a/misc/qt4-l10n/pkg-plist b/misc/qt4-l10n/pkg-plist
index ce1cb00668ba..cae3be840bdf 100644
--- a/misc/qt4-l10n/pkg-plist
+++ b/misc/qt4-l10n/pkg-plist
@@ -4,6 +4,7 @@ share/qt4/translations/assistant_adp_pl.qm
share/qt4/translations/assistant_adp_ru.qm
share/qt4/translations/assistant_adp_zh_CN.qm
share/qt4/translations/assistant_adp_zh_TW.qm
+share/qt4/translations/assistant_cs.qm
share/qt4/translations/assistant_da.qm
share/qt4/translations/assistant_de.qm
share/qt4/translations/assistant_fr.qm
@@ -12,6 +13,7 @@ share/qt4/translations/assistant_pl.qm
share/qt4/translations/assistant_ru.qm
share/qt4/translations/assistant_zh_CN.qm
share/qt4/translations/assistant_zh_TW.qm
+share/qt4/translations/designer_cs.qm
share/qt4/translations/designer_de.qm
share/qt4/translations/designer_fr.qm
share/qt4/translations/designer_ja.qm
@@ -20,6 +22,7 @@ share/qt4/translations/designer_ru.qm
share/qt4/translations/designer_sl.qm
share/qt4/translations/designer_zh_CN.qm
share/qt4/translations/designer_zh_TW.qm
+share/qt4/translations/linguist_cs.qm
share/qt4/translations/linguist_de.qm
share/qt4/translations/linguist_fr.qm
share/qt4/translations/linguist_ja.qm
@@ -28,10 +31,13 @@ share/qt4/translations/linguist_ru.qm
share/qt4/translations/linguist_zh_CN.qm
share/qt4/translations/linguist_zh_TW.qm
share/qt4/translations/qt_ar.qm
+share/qt4/translations/qt_cs.qm
share/qt4/translations/qt_da.qm
share/qt4/translations/qt_de.qm
share/qt4/translations/qt_es.qm
share/qt4/translations/qt_fr.qm
+share/qt4/translations/qt_he.qm
+share/qt4/translations/qt_help_cs.qm
share/qt4/translations/qt_help_da.qm
share/qt4/translations/qt_help_de.qm
share/qt4/translations/qt_help_fr.qm
@@ -40,7 +46,6 @@ share/qt4/translations/qt_help_pl.qm
share/qt4/translations/qt_help_ru.qm
share/qt4/translations/qt_help_zh_CN.qm
share/qt4/translations/qt_help_zh_TW.qm
-share/qt4/translations/qt_iw.qm
share/qt4/translations/qt_ja_JP.qm
share/qt4/translations/qt_pl.qm
share/qt4/translations/qt_pt.qm
diff --git a/misc/qt4-qtdemo/pkg-plist b/misc/qt4-qtdemo/pkg-plist
index ee416bf16bff..0a0e9f55f12e 100644
--- a/misc/qt4-qtdemo/pkg-plist
+++ b/misc/qt4-qtdemo/pkg-plist
@@ -358,6 +358,65 @@ share/examples/qt4/demos/shared/libdemo_shared.prl
share/examples/qt4/demos/shared/shared.pri
share/examples/qt4/demos/shared/shared.pro
share/examples/qt4/demos/shared/shared.qrc
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/Array.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/Array.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/DynArray.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/DynArray.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealFixLen.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealFixLen.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealFixLenParam.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealPassDirect.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealPassDirect.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealPassInverse.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealPassInverse.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealSelect.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealSelect.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealUseTrigo.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/FFTRealUseTrigo.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/OscSinCos.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/OscSinCos.hpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/def.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/fftreal.pro
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/fftreal_wrapper.cpp
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/fftreal_wrapper.h
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/license.txt
+share/examples/qt4/demos/spectrum/3rdparty/fftreal/readme.txt
+share/examples/qt4/demos/spectrum/README.txt
+share/examples/qt4/demos/spectrum/TODO.txt
+share/examples/qt4/demos/spectrum/app/app.pro
+share/examples/qt4/demos/spectrum/app/engine.cpp
+share/examples/qt4/demos/spectrum/app/engine.h
+share/examples/qt4/demos/spectrum/app/frequencyspectrum.cpp
+share/examples/qt4/demos/spectrum/app/frequencyspectrum.h
+share/examples/qt4/demos/spectrum/app/images/record.png
+share/examples/qt4/demos/spectrum/app/images/settings.png
+share/examples/qt4/demos/spectrum/app/levelmeter.cpp
+share/examples/qt4/demos/spectrum/app/levelmeter.h
+share/examples/qt4/demos/spectrum/app/main.cpp
+share/examples/qt4/demos/spectrum/app/mainwidget.cpp
+share/examples/qt4/demos/spectrum/app/mainwidget.h
+share/examples/qt4/demos/spectrum/app/progressbar.cpp
+share/examples/qt4/demos/spectrum/app/progressbar.h
+share/examples/qt4/demos/spectrum/app/settingsdialog.cpp
+share/examples/qt4/demos/spectrum/app/settingsdialog.h
+share/examples/qt4/demos/spectrum/app/spectrograph.cpp
+share/examples/qt4/demos/spectrum/app/spectrograph.h
+share/examples/qt4/demos/spectrum/app/spectrum.h
+share/examples/qt4/demos/spectrum/app/spectrum.qrc
+share/examples/qt4/demos/spectrum/app/spectrumanalyser.cpp
+share/examples/qt4/demos/spectrum/app/spectrumanalyser.h
+share/examples/qt4/demos/spectrum/app/tonegenerator.cpp
+share/examples/qt4/demos/spectrum/app/tonegenerator.h
+share/examples/qt4/demos/spectrum/app/tonegeneratordialog.cpp
+share/examples/qt4/demos/spectrum/app/tonegeneratordialog.h
+share/examples/qt4/demos/spectrum/app/utils.cpp
+share/examples/qt4/demos/spectrum/app/utils.h
+share/examples/qt4/demos/spectrum/app/waveform.cpp
+share/examples/qt4/demos/spectrum/app/waveform.h
+share/examples/qt4/demos/spectrum/app/wavfile.cpp
+share/examples/qt4/demos/spectrum/app/wavfile.h
+share/examples/qt4/demos/spectrum/spectrum.pri
+share/examples/qt4/demos/spectrum/spectrum.pro
share/examples/qt4/demos/spreadsheet/images/interview.png
share/examples/qt4/demos/spreadsheet/main.cpp
share/examples/qt4/demos/spreadsheet/printview.cpp
@@ -3269,6 +3328,11 @@ share/examples/qt4/examples/xmlpatterns/xquery/xquery.pro
@dirrm share/examples/qt4/demos/sqlbrowser
@dirrm share/examples/qt4/demos/spreadsheet/images
@dirrm share/examples/qt4/demos/spreadsheet
+@dirrm share/examples/qt4/demos/spectrum/app/images
+@dirrm share/examples/qt4/demos/spectrum/app
+@dirrm share/examples/qt4/demos/spectrum/3rdparty/fftreal
+@dirrm share/examples/qt4/demos/spectrum/3rdparty
+@dirrm share/examples/qt4/demos/spectrum
@dirrm share/examples/qt4/demos/shared/images
@dirrm share/examples/qt4/demos/shared
@dirrm share/examples/qt4/demos/qtdemo/xml
diff --git a/multimedia/qt4-multimedia/pkg-plist b/multimedia/qt4-multimedia/pkg-plist
index dbaa07b895b6..e86d13f95448 100644
--- a/multimedia/qt4-multimedia/pkg-plist
+++ b/multimedia/qt4-multimedia/pkg-plist
@@ -15,6 +15,7 @@ include/qt4/QtMultimedia/QAbstractAudioInput
include/qt4/QtMultimedia/QAbstractAudioOutput
include/qt4/QtMultimedia/QAbstractVideoBuffer
include/qt4/QtMultimedia/QAbstractVideoSurface
+include/qt4/QtMultimedia/QAudio
include/qt4/QtMultimedia/QAudioDeviceInfo
include/qt4/QtMultimedia/QAudioEngineFactoryInterface
include/qt4/QtMultimedia/QAudioEnginePlugin