aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/gtk--2/Makefile3
-rw-r--r--x11-toolkits/gtk--2/files/patch-configure28
-rw-r--r--x11-toolkits/gtkmm20/Makefile3
-rw-r--r--x11-toolkits/gtkmm20/files/patch-configure28
-rw-r--r--x11-toolkits/gtkmm24/Makefile3
-rw-r--r--x11-toolkits/gtkmm24/files/patch-configure28
-rw-r--r--x11-toolkits/gtkmm30/Makefile3
-rw-r--r--x11-toolkits/gtkmm30/files/patch-configure28
8 files changed, 88 insertions, 36 deletions
diff --git a/x11-toolkits/gtk--2/Makefile b/x11-toolkits/gtk--2/Makefile
index 6b20db228aff..ad2bb84ff2c4 100644
--- a/x11-toolkits/gtk--2/Makefile
+++ b/x11-toolkits/gtk--2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkmm
PORTVERSION= 2.2.10
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME} \
${MASTER_SITE_SOURCEFORGE}
@@ -27,7 +28,7 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gtk20
+USE_GNOME= gnomehack lthack gtk20
CONFIGURE_ARGS= --enable-static=yes \
--with-sigc-prefix=${LOCALBASE}
diff --git a/x11-toolkits/gtk--2/files/patch-configure b/x11-toolkits/gtk--2/files/patch-configure
index c14c5d93483a..166267ae5b9d 100644
--- a/x11-toolkits/gtk--2/files/patch-configure
+++ b/x11-toolkits/gtk--2/files/patch-configure
@@ -1,10 +1,22 @@
---- configure.orig Sat Oct 12 00:36:53 2002
-+++ configure Sat Oct 12 00:37:15 2002
-@@ -6823,6 +6823,7 @@
+--- configure.orig Wed Mar 24 14:29:14 2004
++++ configure Wed Mar 24 14:37:06 2004
+@@ -21358,10 +21358,6 @@
+ std::cout << "Traits<Foo<const int >> --> "
+ << cfit.whoami() << std::endl;
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+- return 0;
+- }
+-
+- ;
+ return 0;
+ }
+ _ACEOF
+@@ -21404,7 +21400,7 @@
+ if test "x${gtkmm_cv_cxx_can_disambiguate_const_template_specializations}" = "xyes"; then
+ {
+ cat >>confdefs.h <<\_ACEOF
+-#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1, Defined if the compiler does not find it ambiguous to have both const and non-const template specializations
++#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1
+ _ACEOF
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+ }
diff --git a/x11-toolkits/gtkmm20/Makefile b/x11-toolkits/gtkmm20/Makefile
index 6b20db228aff..ad2bb84ff2c4 100644
--- a/x11-toolkits/gtkmm20/Makefile
+++ b/x11-toolkits/gtkmm20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkmm
PORTVERSION= 2.2.10
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME} \
${MASTER_SITE_SOURCEFORGE}
@@ -27,7 +28,7 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gtk20
+USE_GNOME= gnomehack lthack gtk20
CONFIGURE_ARGS= --enable-static=yes \
--with-sigc-prefix=${LOCALBASE}
diff --git a/x11-toolkits/gtkmm20/files/patch-configure b/x11-toolkits/gtkmm20/files/patch-configure
index c14c5d93483a..166267ae5b9d 100644
--- a/x11-toolkits/gtkmm20/files/patch-configure
+++ b/x11-toolkits/gtkmm20/files/patch-configure
@@ -1,10 +1,22 @@
---- configure.orig Sat Oct 12 00:36:53 2002
-+++ configure Sat Oct 12 00:37:15 2002
-@@ -6823,6 +6823,7 @@
+--- configure.orig Wed Mar 24 14:29:14 2004
++++ configure Wed Mar 24 14:37:06 2004
+@@ -21358,10 +21358,6 @@
+ std::cout << "Traits<Foo<const int >> --> "
+ << cfit.whoami() << std::endl;
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+- return 0;
+- }
+-
+- ;
+ return 0;
+ }
+ _ACEOF
+@@ -21404,7 +21400,7 @@
+ if test "x${gtkmm_cv_cxx_can_disambiguate_const_template_specializations}" = "xyes"; then
+ {
+ cat >>confdefs.h <<\_ACEOF
+-#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1, Defined if the compiler does not find it ambiguous to have both const and non-const template specializations
++#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1
+ _ACEOF
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+ }
diff --git a/x11-toolkits/gtkmm24/Makefile b/x11-toolkits/gtkmm24/Makefile
index 6b20db228aff..ad2bb84ff2c4 100644
--- a/x11-toolkits/gtkmm24/Makefile
+++ b/x11-toolkits/gtkmm24/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkmm
PORTVERSION= 2.2.10
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME} \
${MASTER_SITE_SOURCEFORGE}
@@ -27,7 +28,7 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gtk20
+USE_GNOME= gnomehack lthack gtk20
CONFIGURE_ARGS= --enable-static=yes \
--with-sigc-prefix=${LOCALBASE}
diff --git a/x11-toolkits/gtkmm24/files/patch-configure b/x11-toolkits/gtkmm24/files/patch-configure
index c14c5d93483a..166267ae5b9d 100644
--- a/x11-toolkits/gtkmm24/files/patch-configure
+++ b/x11-toolkits/gtkmm24/files/patch-configure
@@ -1,10 +1,22 @@
---- configure.orig Sat Oct 12 00:36:53 2002
-+++ configure Sat Oct 12 00:37:15 2002
-@@ -6823,6 +6823,7 @@
+--- configure.orig Wed Mar 24 14:29:14 2004
++++ configure Wed Mar 24 14:37:06 2004
+@@ -21358,10 +21358,6 @@
+ std::cout << "Traits<Foo<const int >> --> "
+ << cfit.whoami() << std::endl;
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+- return 0;
+- }
+-
+- ;
+ return 0;
+ }
+ _ACEOF
+@@ -21404,7 +21400,7 @@
+ if test "x${gtkmm_cv_cxx_can_disambiguate_const_template_specializations}" = "xyes"; then
+ {
+ cat >>confdefs.h <<\_ACEOF
+-#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1, Defined if the compiler does not find it ambiguous to have both const and non-const template specializations
++#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1
+ _ACEOF
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+ }
diff --git a/x11-toolkits/gtkmm30/Makefile b/x11-toolkits/gtkmm30/Makefile
index 6b20db228aff..ad2bb84ff2c4 100644
--- a/x11-toolkits/gtkmm30/Makefile
+++ b/x11-toolkits/gtkmm30/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkmm
PORTVERSION= 2.2.10
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME} \
${MASTER_SITE_SOURCEFORGE}
@@ -27,7 +28,7 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gtk20
+USE_GNOME= gnomehack lthack gtk20
CONFIGURE_ARGS= --enable-static=yes \
--with-sigc-prefix=${LOCALBASE}
diff --git a/x11-toolkits/gtkmm30/files/patch-configure b/x11-toolkits/gtkmm30/files/patch-configure
index c14c5d93483a..166267ae5b9d 100644
--- a/x11-toolkits/gtkmm30/files/patch-configure
+++ b/x11-toolkits/gtkmm30/files/patch-configure
@@ -1,10 +1,22 @@
---- configure.orig Sat Oct 12 00:36:53 2002
-+++ configure Sat Oct 12 00:37:15 2002
-@@ -6823,6 +6823,7 @@
+--- configure.orig Wed Mar 24 14:29:14 2004
++++ configure Wed Mar 24 14:37:06 2004
+@@ -21358,10 +21358,6 @@
+ std::cout << "Traits<Foo<const int >> --> "
+ << cfit.whoami() << std::endl;
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+- return 0;
+- }
+-
+- ;
+ return 0;
+ }
+ _ACEOF
+@@ -21404,7 +21400,7 @@
+ if test "x${gtkmm_cv_cxx_can_disambiguate_const_template_specializations}" = "xyes"; then
+ {
+ cat >>confdefs.h <<\_ACEOF
+-#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1, Defined if the compiler does not find it ambiguous to have both const and non-const template specializations
++#define GLIBMM_HAVE_DISAMBIGUOUS_CONST_TEMPLATE_SPECIALIZATIONS 1
+ _ACEOF
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+ }