aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wmmenu/Makefile37
-rw-r--r--x11/wmmenu/distinfo1
-rw-r--r--x11/wmmenu/files/patch-aa11
-rw-r--r--x11/wmmenu/files/patch-ab11
-rw-r--r--x11/wmmenu/files/patch-ac13
-rw-r--r--x11/wmmenu/pkg-comment1
-rw-r--r--x11/wmmenu/pkg-descr9
-rw-r--r--x11/wmmenu/pkg-message1
-rw-r--r--x11/wmmenu/pkg-plist6
10 files changed, 91 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 2cbd946b0d93..71cedd634373 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -68,6 +68,7 @@
SUBDIR += wdm
SUBDIR += wmbutton
SUBDIR += wmmatrix
+ SUBDIR += wmmenu
SUBDIR += wrapper
SUBDIR += wterm
SUBDIR += x3270
diff --git a/x11/wmmenu/Makefile b/x11/wmmenu/Makefile
new file mode 100644
index 000000000000..20c315dc325e
--- /dev/null
+++ b/x11/wmmenu/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: wmmenu
+# Date created: 16 November 2000
+# Whom: Jeremy <karlj000@unbc.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmmenu
+PORTVERSION= 0.3
+CATEGORIES= x11
+MASTER_SITES= http://www.fcoutant.freesurf.fr/download/
+
+MAINTAINER= karlj000@unbc.ca
+
+LIB_DEPENDS= dockapp.1:${PORTSDIR}/x11-wm/libdockapp:install
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+post-patch:
+ @ ${MV} ${WRKSRC}/example/defaults ${WRKSRC}/example/defaults.presed
+ @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#' ${WRKSRC}/example/defaults.presed \
+ > ${WRKSRC}/example/defaults
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmmenu ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/doc/wmmenu
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/wmmenu
+ ${MKDIR} ${PREFIX}/share/doc/wmmenu/example
+ ${INSTALL_DATA} ${WRKSRC}/example/apps ${PREFIX}/share/doc/wmmenu/example
+ ${INSTALL_DATA} ${WRKSRC}/example/defaults ${PREFIX}/share/doc/wmmenu/example
+
+post-install:
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11/wmmenu/distinfo b/x11/wmmenu/distinfo
new file mode 100644
index 000000000000..577bf9b0654e
--- /dev/null
+++ b/x11/wmmenu/distinfo
@@ -0,0 +1 @@
+MD5 (wmmenu-0.3.tar.gz) = 4e94c4caec8238652d4a918d09e65b09
diff --git a/x11/wmmenu/files/patch-aa b/x11/wmmenu/files/patch-aa
new file mode 100644
index 000000000000..7b0743152c6f
--- /dev/null
+++ b/x11/wmmenu/files/patch-aa
@@ -0,0 +1,11 @@
+--- options.c.BACKUP Thu Nov 16 21:11:16 2000
++++ options.c Thu Nov 16 21:11:25 2000
+@@ -4,7 +4,7 @@
+ #include <string.h>
+ #include <assert.h>
+ /* POSIX */
+-#include <getopt.h>
++#include <unistd.h>
+
+ #include "options.h"
+ #include "version.h"
diff --git a/x11/wmmenu/files/patch-ab b/x11/wmmenu/files/patch-ab
new file mode 100644
index 000000000000..a13d5a43a897
--- /dev/null
+++ b/x11/wmmenu/files/patch-ab
@@ -0,0 +1,11 @@
+--- example/apps.Dist Sat Aug 5 00:40:31 2000
++++ example/apps Sun Nov 19 18:32:02 2000
+@@ -4,8 +4,6 @@
+
+ "GNUstep.xpm" Menu title
+ "linuxterm.xpm" xterm -T Terminal -name terminal -geometry 80x50 &
+-"HomeNeighborOpen.xpm" xterm -T "Login terminal" -name loginxterm -e bin/rloginsession &
+-"FileManager.xpm" xterm -T "Midnight Commander" -name mc -geometry 100x50 -sl 1000 -e mc -c &
+ "mixer.xpm" gaumix &
+ "HP-16C-48.xpm" kcalc &
+
diff --git a/x11/wmmenu/files/patch-ac b/x11/wmmenu/files/patch-ac
new file mode 100644
index 000000000000..0c675beff9cc
--- /dev/null
+++ b/x11/wmmenu/files/patch-ac
@@ -0,0 +1,13 @@
+--- example/defaults.Dist Sat Aug 5 00:40:06 2000
++++ example/defaults Sun Nov 19 18:28:53 2000
+@@ -12,4 +12,10 @@
+
+ xpmpath /usr/local/share/WindowMaker/Icons
+ xpmpath /usr/local/share/pixmaps
++
++xpmpath %%PREFIX%%/share/WindowMaker/Backgrounds
++xpmpath %%PREFIX%%/share/WindowMaker/Icons
++xpmpath %%PREFIX%%/share/WindowMaker/Pixmaps
++xpmpath %%PREFIX%%/include/X11/pixmaps
++
+ tile tile2.xpm
diff --git a/x11/wmmenu/pkg-comment b/x11/wmmenu/pkg-comment
new file mode 100644
index 000000000000..6296e582a393
--- /dev/null
+++ b/x11/wmmenu/pkg-comment
@@ -0,0 +1 @@
+A popup menu of icons that launch programs for the WindowMaker dock
diff --git a/x11/wmmenu/pkg-descr b/x11/wmmenu/pkg-descr
new file mode 100644
index 000000000000..eea0a7f32f2a
--- /dev/null
+++ b/x11/wmmenu/pkg-descr
@@ -0,0 +1,9 @@
+A dockapp for WindowMaker that provides a popup menu of icons that launch
+applications, like in AfterStep. The program can be run more than once at
+the same time, which allows many different menus, each one described in a
+seperate file.
+
+WWW: http://www.fcoutant.freesurf.fr/wmmenu.html
+
+Jeremy
+karlj000@unbc.ca
diff --git a/x11/wmmenu/pkg-message b/x11/wmmenu/pkg-message
new file mode 100644
index 000000000000..55ac39729fff
--- /dev/null
+++ b/x11/wmmenu/pkg-message
@@ -0,0 +1 @@
+Read %%PREFIX%%/share/doc/wmmenu/README for info on configuring this dockapp.
diff --git a/x11/wmmenu/pkg-plist b/x11/wmmenu/pkg-plist
new file mode 100644
index 000000000000..22b4e5bc3588
--- /dev/null
+++ b/x11/wmmenu/pkg-plist
@@ -0,0 +1,6 @@
+bin/wmmenu
+share/doc/wmmenu/example/apps
+share/doc/wmmenu/example/defaults
+share/doc/wmmenu/README
+@dirrm share/doc/wmmenu/example
+@dirrm share/doc/wmmenu