aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/ngrep-lib/Makefile20
-rw-r--r--net/ngrep-lib/distinfo1
-rw-r--r--net/ngrep-lib/pkg-comment1
-rw-r--r--net/ngrep-lib/pkg-descr11
-rw-r--r--net/ngrep-lib/pkg-plist3
6 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c1fede28c9d0..dc6c7e00c0bf 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -227,6 +227,7 @@
SUBDIR += netsed
SUBDIR += nettest
SUBDIR += ngrep
+ SUBDIR += ngrep-lib
SUBDIR += nocol
SUBDIR += ns
SUBDIR += nsc
diff --git a/net/ngrep-lib/Makefile b/net/ngrep-lib/Makefile
new file mode 100644
index 000000000000..b1ca76177a71
--- /dev/null
+++ b/net/ngrep-lib/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ngrep-lib
+# Date created: 28 August 2001
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ngrep-lib
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.mavetju.org/download/
+
+MAINTAINER= edwin@mavetju.org
+
+MAN3= ngrep-lib.3
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/net/ngrep-lib/distinfo b/net/ngrep-lib/distinfo
new file mode 100644
index 000000000000..9cbb911a1755
--- /dev/null
+++ b/net/ngrep-lib/distinfo
@@ -0,0 +1 @@
+MD5 (ngrep-lib-1.0.tar.gz) = e0957e79588a3cc6ffef3be8de5e580b
diff --git a/net/ngrep-lib/pkg-comment b/net/ngrep-lib/pkg-comment
new file mode 100644
index 000000000000..fdfa696db45e
--- /dev/null
+++ b/net/ngrep-lib/pkg-comment
@@ -0,0 +1 @@
+Easy packet filtering library based on ngrep
diff --git a/net/ngrep-lib/pkg-descr b/net/ngrep-lib/pkg-descr
new file mode 100644
index 000000000000..113716000c27
--- /dev/null
+++ b/net/ngrep-lib/pkg-descr
@@ -0,0 +1,11 @@
+Easy packet filtering in your programs.
+
+This library is based on ngrep. Instead of having
+to worry about the pcap, the options, the syntax, the processing
+of the IP packets et al, you now have an easy interface:
+Initialize and run. Let the callback functions handle the rest.
+
+Edwin Groothuis
+edwin@mavetju.org
+
+WWW: http://www.mavetju.org
diff --git a/net/ngrep-lib/pkg-plist b/net/ngrep-lib/pkg-plist
new file mode 100644
index 000000000000..20beb25f13c3
--- /dev/null
+++ b/net/ngrep-lib/pkg-plist
@@ -0,0 +1,3 @@
+lib/libngrep.so.1
+lib/libngrep.so
+include/ngrep-lib.h