aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/lynx-current/Makefile6
-rw-r--r--japanese/lynx-current/distinfo2
-rw-r--r--japanese/lynx-current/files/patch-aa73
-rw-r--r--japanese/lynx-current/files/patch-ai24
-rw-r--r--japanese/lynx-current/pkg-plist74
5 files changed, 82 insertions, 97 deletions
diff --git a/japanese/lynx-current/Makefile b/japanese/lynx-current/Makefile
index 204e51745099..643310264555 100644
--- a/japanese/lynx-current/Makefile
+++ b/japanese/lynx-current/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= ${VERSION}.${MINOR_VERSION:S/.//}
CATEGORIES= japanese www
MASTER_SITES= ${MASTER_SITE_PORTS_JP} \
${MASTER_SITE_LOCAL} \
- http://sol.slcc.edu/lynx/current/
+ http://lynx.isc.org/current/
MASTER_SITE_SUBDIR= shige
DISTNAME= ${PORTNAME}${VERSION}${MINOR_VERSION}
@@ -19,8 +19,8 @@ MAINTAINER= shige@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}${VERSION:S/./-/g}
-VERSION= 2.8.4
-MINOR_VERSION= dev.4
+VERSION= 2.8.5
+MINOR_VERSION= dev.7
USE_BZIP2= YES
NO_LATEST_LINK= YES
diff --git a/japanese/lynx-current/distinfo b/japanese/lynx-current/distinfo
index ffa1782dec5a..f2f7cbe75b33 100644
--- a/japanese/lynx-current/distinfo
+++ b/japanese/lynx-current/distinfo
@@ -1 +1 @@
-MD5 (lynx2.8.4dev.4.tar.bz2) = ce6fbf3f89bab22f1936a8c1f2e4c961
+MD5 (lynx2.8.5dev.7.tar.bz2) = 2b325d9b17a43c72ec1be3bad4996978
diff --git a/japanese/lynx-current/files/patch-aa b/japanese/lynx-current/files/patch-aa
index 1cd1e8cf8612..7485493e67d4 100644
--- a/japanese/lynx-current/files/patch-aa
+++ b/japanese/lynx-current/files/patch-aa
@@ -1,42 +1,41 @@
---- makefile.in.orig Thu Nov 18 13:08:08 1999
-+++ makefile.in Sat Dec 11 01:35:28 1999
-@@ -310,7 +310,7 @@
- @echo "Use $(MAKE) install-doc to install extra documentation files"
- @echo
-
--install-full: install install-help install-doc
-+install-full: install install-doc install-help
- @echo Full installation complete.
-
- install-bin: $(BINDIR) lynx$x
-@@ -326,7 +326,7 @@
- (cd $(srcdir) && tar cf - C[HO]* PROBLEMS README samples test ) | \
- ( cd $(DOCDIR) && tar xf - )
- $(SHELL) -c 'for name in COPYING COPYHEADER; do \
-- cd $(HELPDIR) && ( $(LN_S) $(DOCDIR)/$$name . || cp $(DOCDIR)/$$name . );\
-+ cd $(HELPDIR) && cp $(DOCDIR)/$$name . ;\
- done'
-
- # HPUX 'sed' does not seem to like '=' as pattern delimiter.
-@@ -366,10 +366,9 @@
- -rm -f $(HELPDIR)/help_files.sed
- @echo Updating $(libdir)/lynx.cfg
- $(SHELL) -c 'if test -f $(LIBDIR)/lynx.cfg ; then \
+--- makefile.in.orig Wed Jan 2 10:30:08 2002
++++ makefile.in Wed Jan 23 02:32:35 2002
+@@ -350,22 +350,19 @@
+ if test "$(COMPRESS_PROG)" != "" ; then \
+ (cd $(HELPDIR) && $(COMPRESS_PROG) $$files ) \
+ fi'
+- @echo Updating $(libdir)/lynx.cfg
+- $(SHELL) -c 'if test -f $(LIBDIR)/lynx.cfg ; then \
- mv $(LIBDIR)/lynx.cfg $(LIBDIR)/lynx.tmp ; \
- else \
- cp $(srcdir)/lynx.cfg $(LIBDIR)/lynx.tmp ; \
-+ mv $(LIBDIR)/lynx.cfg $(LIBDIR)/lynx.oldcfg ; \
- fi'
-+ @cp $(srcdir)/lynx.cfg $(LIBDIR)/lynx.tmp
- @echo Updating $(libdir)/lynx.cfg to point to installed help-files
- @ECHO_CC@sed -e '/^HELPFILE:http/s@^@#@' \
- -e '/^#HELPFILE:file/s@#@@' \
-@@ -380,6 +379,8 @@
- $(LIBDIR)/lynx.tmp >$(LIBDIR)/lynx.cfg
- chmod 644 $(LIBDIR)/lynx.cfg
+- fi'
+- @echo Updating $(libdir)/lynx.cfg to point to installed help-files
++ @echo Updating $(libdir)/lynx.cfg.default
++ cp $(srcdir)/lynx.cfg $(LIBDIR)/lynx.tmp
++ @echo Updating $(libdir)/lynx.cfg.default to point to installed help-files
+ @ECHO_CC@sed -e '/^HELPFILE:http/s!^!#!' \
+ -e '/^#HELPFILE:file/s!#!!' \
+ -e '/^HELPFILE:file/s!PATH_TO/lynx_help!$(helpdir1)!' \
+ -e '/^[A-Z_]*:/s!PATH_TO/lynx_doc!$(docdir1)!' \
+ -e '/^HELPFILE:file/s!$$!$(COMPRESS_EXT)!' \
+ -e '/^HELPFILE:file/s!$(COMPRESS_EXT)$(COMPRESS_EXT)$$!$(COMPRESS_EXT)!' \
+- $(LIBDIR)/lynx.tmp >$(LIBDIR)/lynx.cfg
+- chmod 644 $(LIBDIR)/lynx.cfg
++ $(LIBDIR)/lynx.tmp >$(LIBDIR)/lynx.cfg.default
++ chmod 644 $(LIBDIR)/lynx.cfg.default
-rm -f $(LIBDIR)/lynx.tmp
-+ -[ ! -f $(LIBDIR)/lynx.cfg.sample ] && $(INSTALL_DATA) $(LIBDIR)/lynx.cfg $(LIBDIR)/lynx.cfg.sample
-+
++ -[ ! -f $(LIBDIR)/lynx.cfg ] && $(INSTALL_DATA) $(LIBDIR)/lynx.cfg.default $(LIBDIR)/lynx.cfg
+
+ LYHelp.h : help_files.sed LYHelp.hin
+ @echo Creating $@
+@@ -387,8 +384,7 @@
+ $(SHELL) -c '$(srcdir)/cfg_defs.sh $(srcdir)'
+
+ install-cfg : $(LIBDIR)
+- -mv -f $(LIBDIR)/lynx.cfg $(LIBDIR)/lynx.oldcfg
+- $(INSTALL_DATA) $(srcdir)/lynx.cfg $(LIBDIR)/lynx.cfg
++ $(INSTALL_DATA) $(srcdir)/lynx.cfg $(LIBDIR)/lynx.cfg.default
- LYHelp.h : LYHelp.hin
- @echo Constructing sed-script
+ install-lss : $(LIBDIR)
+ -mv -f $(LIBDIR)/lynx.lss $(LIBDIR)/lynx.oldlss
diff --git a/japanese/lynx-current/files/patch-ai b/japanese/lynx-current/files/patch-ai
deleted file mode 100644
index ea260ad471a2..000000000000
--- a/japanese/lynx-current/files/patch-ai
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/LYCurses.c.orig Wed Nov 11 11:11:52 1998
-+++ src/LYCurses.c Wed Nov 11 11:10:32 1998
-@@ -1679,6 +1679,13 @@
-
- PUBLIC void lynx_force_repaint NOARGS
- {
-+/*
-+ * This code is harmful to display bold links.
-+ * Already set COLOR attributes?
-+ * Therefore I think that we do not need this code.
-+ * --- by shige@FreeBSD.org
-+ */
-+#if 0 /* do not need */
- #if defined(COLOR_CURSES)
- chtype a;
- #ifndef USE_COLOR_STYLE
-@@ -1693,6 +1700,7 @@
- #endif
- attrset(a);
- #endif /* COLOR_CURSES */
-+#endif /* do not need */
- clearok(curscr, TRUE);
- }
-
diff --git a/japanese/lynx-current/pkg-plist b/japanese/lynx-current/pkg-plist
index 31452b48f35d..207f56529e89 100644
--- a/japanese/lynx-current/pkg-plist
+++ b/japanese/lynx-current/pkg-plist
@@ -1,6 +1,6 @@
bin/lynx
%%LYNX_LIB%%/lynx.cfg
-%%LYNX_LIB%%/lynx.cfg.sample
+%%LYNX_LIB%%/lynx.cfg.default
%%LYNX_HELP%%/Lynx_users_guide.html
%%LYNX_HELP%%/about_lynx.html
%%LYNX_HELP%%/keystrokes/alt_edit_help.html
@@ -25,36 +25,46 @@ bin/lynx
%%LYNX_HELP%%/lynx-dev.html
%%LYNX_HELP%%/lynx_help_main.html
%%LYNX_HELP%%/lynx_url_support.html
-%%LYNX_DOC%%/CHANGES
-%%LYNX_DOC%%/COPYHEADER
-%%LYNX_DOC%%/COPYING
-%%LYNX_DOC%%/PROBLEMS
-%%LYNX_DOC%%/README
-%%LYNX_DOC%%/samples/blue-background.lss
-%%LYNX_DOC%%/samples/cernrules.txt
-%%LYNX_DOC%%/samples/installdirs.html
-%%LYNX_DOC%%/samples/jumpsUnix.html
-%%LYNX_DOC%%/samples/jumpsVMS.html
-%%LYNX_DOC%%/samples/lynx-keymaps
-%%LYNX_DOC%%/samples/lynx.com
-%%LYNX_DOC%%/samples/lynx.lss
-%%LYNX_DOC%%/samples/mailcap
-%%LYNX_DOC%%/samples/mild-colors.lss
-%%LYNX_DOC%%/samples/mime.types
-%%LYNX_DOC%%/test/ALT88592.html
-%%LYNX_DOC%%/test/ISO_LATIN1_test.html
-%%LYNX_DOC%%/test/README.txt
-%%LYNX_DOC%%/test/TestComment.html
-%%LYNX_DOC%%/test/c1.html
-%%LYNX_DOC%%/test/iso8859-1.html
-%%LYNX_DOC%%/test/iso88592.html
-%%LYNX_DOC%%/test/raw8bit.html
-%%LYNX_DOC%%/test/sgml.html
-%%LYNX_DOC%%/test/spaces.html
-%%LYNX_DOC%%/test/tabtest.html
-%%LYNX_DOC%%/test/unicode.html
-@dirrm %%LYNX_DOC%%/test
-@dirrm %%LYNX_DOC%%/samples
-@dirrm %%LYNX_DOC%%
+@unexec rm -rf %D/%%LYNX_HELP%%/COPYHEADER
+@unexec rm -rf %D/%%LYNX_HELP%%/COPYING
+%%PORTDOCS%%%%LYNX_DOC%%/CHANGES
+%%PORTDOCS%%%%LYNX_DOC%%/COPYHEADER
+%%PORTDOCS%%@exec ln -sf %D/%F %D/%%LYNX_HELP%%/%f
+%%PORTDOCS%%%%LYNX_DOC%%/COPYING
+%%PORTDOCS%%@exec ln -sf %D/%F %D/%%LYNX_HELP%%/%f
+%%PORTDOCS%%%%LYNX_DOC%%/PROBLEMS
+%%PORTDOCS%%%%LYNX_DOC%%/README
+%%PORTDOCS%%%%LYNX_DOC%%/samples/blue-background.lss
+%%PORTDOCS%%%%LYNX_DOC%%/samples/bright-blue.lss
+%%PORTDOCS%%%%LYNX_DOC%%/samples/cernrules.txt
+%%PORTDOCS%%%%LYNX_DOC%%/samples/installdirs.html
+%%PORTDOCS%%%%LYNX_DOC%%/samples/jumpsUnix.html
+%%PORTDOCS%%%%LYNX_DOC%%/samples/jumpsVMS.html
+%%PORTDOCS%%%%LYNX_DOC%%/samples/keepviewer
+%%PORTDOCS%%%%LYNX_DOC%%/samples/lynxdump
+%%PORTDOCS%%%%LYNX_DOC%%/samples/lynx-keymaps
+%%PORTDOCS%%%%LYNX_DOC%%/samples/lynx.com
+%%PORTDOCS%%%%LYNX_DOC%%/samples/lynx.lss
+%%PORTDOCS%%%%LYNX_DOC%%/samples/mailcap
+%%PORTDOCS%%%%LYNX_DOC%%/samples/mailto-form.pl
+%%PORTDOCS%%%%LYNX_DOC%%/samples/mild-colors.lss
+%%PORTDOCS%%%%LYNX_DOC%%/samples/mime.types
+%%PORTDOCS%%%%LYNX_DOC%%/test/ALT88592.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/ISO_LATIN1_test.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/README.txt
+%%PORTDOCS%%%%LYNX_DOC%%/test/TestComment.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/c1.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/iso8859-1.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/iso88592.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/quickbrown.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/raw8bit.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/sgml.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/spaces.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/tabtest.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/unicode.html
+%%PORTDOCS%%%%LYNX_DOC%%/test/utf-8-demo.html
+%%PORTDOCS%%@dirrm %%LYNX_DOC%%/test
+%%PORTDOCS%%@dirrm %%LYNX_DOC%%/samples
+%%PORTDOCS%%@dirrm %%LYNX_DOC%%
@dirrm %%LYNX_HELP%%/keystrokes
@dirrm %%LYNX_HELP%%