aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/kon2-16dot/Makefile28
-rw-r--r--japanese/kon2-16dot/files/dotconfig3
-rw-r--r--japanese/kon2-16dot/pkg-plist4
3 files changed, 10 insertions, 25 deletions
diff --git a/japanese/kon2-16dot/Makefile b/japanese/kon2-16dot/Makefile
index 93307b219812..0c1476191053 100644
--- a/japanese/kon2-16dot/Makefile
+++ b/japanese/kon2-16dot/Makefile
@@ -3,42 +3,26 @@
# Date created: 7 June 1995
# Whom: Takashi Ogura <ogura@st.rim.or.jp>
#
-# $Id: Makefile,v 1.3 1995/08/01 22:10:14 ats Exp $
+# $Id: Makefile,v 1.4 1995/08/05 18:19:04 ats Exp $
#
DISTNAME= kon
PKGNAME= kon-0994e
CATEGORIES+= japanese
-MASTER_SITES= ftp://ftp.iij.ad.jp/pub/linux-j/JE-sources/JE/
-DISTFILES= kon-0.99.4e.tgz
+# note kon is only in first directory and fonts are only in second directory
+MASTER_SITES= ftp://ftp.iij.ad.jp/pub/linux-j/JE-sources/JE/ \
+ ftp://ftp.iij.ad.jp/pub/X/XFree86/XFree86/3.1.1/untarred/xc/fonts/bdf/misc/
+DISTFILES= kon-0.99.4e.tgz k14.bdf 7x14rk.bdf
EXTRACT_ONLY= kon-0.99.4e.tgz
-.if !defined(MASTER_SITE_OVERRIDE)
-FONT_SITE= ftp://ftp.iij.ad.jp/pub/X/XFree86/XFree86/3.1.1/untarred/xc/fonts/bdf/misc/
-FONTFILES= k14.bdf 7x14rk.bdf
-.else
-DISTFILES += k14.bdf 7x14rk.bdf
-.endif
-
MAINTAINER= asami@FreeBSD.ORG
USE_GMAKE= yes
-.if !defined(MASTER_SITE_OVERRIDE)
-pre-fetch:
- @(cd ${DISTDIR}; \
- for file in ${FONTFILES} ; do \
- if [ ! -f $$file ]; then \
- if ${NCFTP} ${NCFTPFLAGS} ${FONT_SITE}$$file; then \
- break; \
- fi \
- fi \
- done)
-.endif
-
post-configure:
sed -e 's%%CURDIR%%${.CURDIR}' \
-e 's%%PREFIX%%${PREFIX}' \
+ -e 's%%DISTDIR%%${DISTDIR}' \
files/dotconfig > ${WRKSRC}/.config
post-install:
diff --git a/japanese/kon2-16dot/files/dotconfig b/japanese/kon2-16dot/files/dotconfig
index 99bfcc67f3bb..089a0bc0ba6b 100644
--- a/japanese/kon2-16dot/files/dotconfig
+++ b/japanese/kon2-16dot/files/dotconfig
@@ -1,11 +1,12 @@
INCDIR = %%CURDIR%%/work/kon/include
LIB = %%CURDIR%%/work/kon/lib/libgon.a
+DISTDIR = %%DISTDIR%%
TOPDIR = %%PREFIX%%
BINDIR = $(TOPDIR)/bin
LIBDIR = $(TOPDIR)/etc
MANDIR = $(TOPDIR)/man/ja_JP.ujis/man1
-FONTDIR = $(TOPDIR)/fonts
+FONTDIR = $(TOPDIR)/lib/fonts
CONFIG_NAME = kon.cfg
OPTS = -DCONFIG_NAME=\"$(LIBDIR)/$(CONFIG_NAME)\" -I$(INCDIR)
CFLAGS = -O -Wall $(OPTS)
diff --git a/japanese/kon2-16dot/pkg-plist b/japanese/kon2-16dot/pkg-plist
index 777c901bcce2..813873f3411e 100644
--- a/japanese/kon2-16dot/pkg-plist
+++ b/japanese/kon2-16dot/pkg-plist
@@ -2,5 +2,5 @@ bin/kon
bin/fld
man/ja_JP.ujis/man1/kon.1.gz
etc/kon.cfg
-fonts/k14.bdf.gz
-fonts/7x14rk.bdf.gz
+lib/fonts/k14.bdf.gz
+lib/fonts/7x14rk.bdf.gz