aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python15/Makefile1
-rw-r--r--lang/python15/files/patch-Misc:Makefile.pre.in11
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/python15/Makefile b/lang/python15/Makefile
index 18472eedaff6..d9f2cb76af5e 100644
--- a/lang/python15/Makefile
+++ b/lang/python15/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ENV= OPT="${CFLAGS}"
INSTALL_TARGET= install
PLIST= ${WRKDIR}/PLIST
MAN1= python.1
+NO_LATEST_LINK= yes
#
# The standard setup file
diff --git a/lang/python15/files/patch-Misc:Makefile.pre.in b/lang/python15/files/patch-Misc:Makefile.pre.in
new file mode 100644
index 000000000000..2eaf2f04c91f
--- /dev/null
+++ b/lang/python15/files/patch-Misc:Makefile.pre.in
@@ -0,0 +1,11 @@
+--- Misc/Makefile.pre.in.orig Wed Dec 9 18:05:33 1998
++++ Misc/Makefile.pre.in Thu Sep 7 21:04:19 2000
+@@ -92,7 +92,7 @@
+ TARGET= python
+
+ # Installed python binary (used only by boot target)
+-PYTHON= python
++PYTHON?= python
+
+ # Add more -I and -D options here
+ CFLAGS= $(OPT) -I$(INCLUDEPY) -I$(EXECINCLUDEPY) $(DEFS)