aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/xchat-gnome/Makefile9
-rw-r--r--irc/xchat/Makefile9
-rw-r--r--irc/xchat1/Makefile9
-rw-r--r--irc/xchat2/Makefile9
-rw-r--r--japanese/xchat/Makefile3
5 files changed, 31 insertions, 8 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 9bc401a1ed4d..7f55005addb5 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -12,6 +12,9 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
http://xchat.linuxpower.org/files/source/1.4/
MAINTAINER= jim@FreeBSD.org
+# This port has a slave port japanese/xchat. Do not carelessly overwrite
+# the variables or the targets defined in it. When you need to, please
+# contact its maintainer.
USE_X_PREFIX= yes
USE_BZIP2= yes
@@ -20,11 +23,13 @@ USE_PERL5= yes
USE_IMLIB= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-python
+# Assign with `+=' for slave ports
+CONFIGURE_ARGS+=--disable-python
.include <bsd.port.pre.mk>
.if defined(WITH_SOCKS)
+# Assign with `+=' for slave ports
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+=--enable-socks
.endif
@@ -36,7 +41,7 @@ CONFIGURE_ARGS+=--enable-gnome --enable-panel --enable-gdk-pixbuf
CONFIGURE_ARGS+=--disable-gnome --disable-gdk-pixbuf
.endif
-pre-patch:
+post-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 9bc401a1ed4d..7f55005addb5 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -12,6 +12,9 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
http://xchat.linuxpower.org/files/source/1.4/
MAINTAINER= jim@FreeBSD.org
+# This port has a slave port japanese/xchat. Do not carelessly overwrite
+# the variables or the targets defined in it. When you need to, please
+# contact its maintainer.
USE_X_PREFIX= yes
USE_BZIP2= yes
@@ -20,11 +23,13 @@ USE_PERL5= yes
USE_IMLIB= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-python
+# Assign with `+=' for slave ports
+CONFIGURE_ARGS+=--disable-python
.include <bsd.port.pre.mk>
.if defined(WITH_SOCKS)
+# Assign with `+=' for slave ports
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+=--enable-socks
.endif
@@ -36,7 +41,7 @@ CONFIGURE_ARGS+=--enable-gnome --enable-panel --enable-gdk-pixbuf
CONFIGURE_ARGS+=--disable-gnome --disable-gdk-pixbuf
.endif
-pre-patch:
+post-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index 9bc401a1ed4d..7f55005addb5 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -12,6 +12,9 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
http://xchat.linuxpower.org/files/source/1.4/
MAINTAINER= jim@FreeBSD.org
+# This port has a slave port japanese/xchat. Do not carelessly overwrite
+# the variables or the targets defined in it. When you need to, please
+# contact its maintainer.
USE_X_PREFIX= yes
USE_BZIP2= yes
@@ -20,11 +23,13 @@ USE_PERL5= yes
USE_IMLIB= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-python
+# Assign with `+=' for slave ports
+CONFIGURE_ARGS+=--disable-python
.include <bsd.port.pre.mk>
.if defined(WITH_SOCKS)
+# Assign with `+=' for slave ports
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+=--enable-socks
.endif
@@ -36,7 +41,7 @@ CONFIGURE_ARGS+=--enable-gnome --enable-panel --enable-gdk-pixbuf
CONFIGURE_ARGS+=--disable-gnome --disable-gdk-pixbuf
.endif
-pre-patch:
+post-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 9bc401a1ed4d..7f55005addb5 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -12,6 +12,9 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
http://xchat.linuxpower.org/files/source/1.4/
MAINTAINER= jim@FreeBSD.org
+# This port has a slave port japanese/xchat. Do not carelessly overwrite
+# the variables or the targets defined in it. When you need to, please
+# contact its maintainer.
USE_X_PREFIX= yes
USE_BZIP2= yes
@@ -20,11 +23,13 @@ USE_PERL5= yes
USE_IMLIB= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-python
+# Assign with `+=' for slave ports
+CONFIGURE_ARGS+=--disable-python
.include <bsd.port.pre.mk>
.if defined(WITH_SOCKS)
+# Assign with `+=' for slave ports
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+=--enable-socks
.endif
@@ -36,7 +41,7 @@ CONFIGURE_ARGS+=--enable-gnome --enable-panel --enable-gdk-pixbuf
CONFIGURE_ARGS+=--disable-gnome --disable-gdk-pixbuf
.endif
-pre-patch:
+post-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
diff --git a/japanese/xchat/Makefile b/japanese/xchat/Makefile
index c27b9ab0a0cf..59a09e93289b 100644
--- a/japanese/xchat/Makefile
+++ b/japanese/xchat/Makefile
@@ -7,6 +7,7 @@
MASTERDIR= ${.CURDIR}/../../irc/xchat
+PORTREVISION= 1
CATEGORIES= japanese
PATCH_SITES= http://northeye.org/~takuo/xchat-ja/
PATCHFILES= ${PORTNAME}-${PORTVERSION}.ja.3.diff.gz
@@ -18,6 +19,8 @@ LIB_DEPENDS= iconv.1:${PORTSDIR}/converters/iconv
MD5_FILE= ${.CURDIR}/distinfo
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-japanese-conv # --enable-ipv6
MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv -lintl"