aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/xchat-devel/Makefile6
-rw-r--r--irc/xchat-devel/pkg-plist3
-rw-r--r--irc/xchat-gnome/Makefile6
-rw-r--r--irc/xchat-gnome/pkg-plist2
-rw-r--r--irc/xchat/Makefile6
-rw-r--r--irc/xchat/pkg-plist2
-rw-r--r--irc/xchat1/Makefile6
-rw-r--r--irc/xchat1/pkg-plist2
-rw-r--r--irc/xchat2/Makefile6
-rw-r--r--irc/xchat2/pkg-plist2
10 files changed, 21 insertions, 20 deletions
diff --git a/irc/xchat-devel/Makefile b/irc/xchat-devel/Makefile
index 34771531b212..731f7709791e 100644
--- a/irc/xchat-devel/Makefile
+++ b/irc/xchat-devel/Makefile
@@ -49,6 +49,7 @@ CONFIGURE_ARGS+= --enable-socks
.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
+PLIST_SUB+= GNOME:=""
.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
@@ -56,6 +57,7 @@ CONFIGURE_ARGS+= --disable-panel
.endif
.else
CONFIGURE_ARGS+= --disable-gnome
+PLIST_SUB+= GNOME:="@comment "
.endif
.if defined(WITH_GDK_PIXBUF)
@@ -70,10 +72,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GDK_PIXBUF_CONFIG="${GDK_PIXBUF_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
-.if defined(WITH_GNOME)
-PLIST= ${PKGDIR}/PLIST.gnome
-.endif
-
post-install:
@strip ${PREFIX}/bin/xchat
.if !defined(NOPORTDOCS)
diff --git a/irc/xchat-devel/pkg-plist b/irc/xchat-devel/pkg-plist
index bd70b7a88698..be3772ce93b3 100644
--- a/irc/xchat-devel/pkg-plist
+++ b/irc/xchat-devel/pkg-plist
@@ -14,6 +14,9 @@ share/doc/xchat/xchat-9.html
share/doc/xchat/xchat-10.html
share/doc/xchat/README
share/doc/xchat/ChangeLog
+%%GNOME:%%share/gnome/apps/Internet/xchat.desktop
+%%GNOME:%%share/gnome/pixmaps/xchat.png
+%%GNOME:%%share/gnome/pixmaps/xchat_wm.png
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 189bb833f294..f3428d49c118 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -45,6 +45,7 @@ CONFIGURE_ARGS+= --enable-socks
.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
+PLIST_SUB+= GNOME:=""
.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --disable-panel
.endif
.else
CONFIGURE_ARGS+= --disable-gnome
+PLIST_SUB+= GNOME:="@comment "
.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -59,10 +61,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
-.if defined(WITH_GNOME)
-PLIST= ${PKGDIR}/PLIST.gnome
-.endif
-
post-install:
@strip ${PREFIX}/bin/xchat
.if !defined(NOPORTDOCS)
diff --git a/irc/xchat-gnome/pkg-plist b/irc/xchat-gnome/pkg-plist
index cbb8fdb32a05..4927f119a67a 100644
--- a/irc/xchat-gnome/pkg-plist
+++ b/irc/xchat-gnome/pkg-plist
@@ -14,6 +14,8 @@ share/doc/xchat/xchat-9.html
share/doc/xchat/xchat-10.html
share/doc/xchat/README
share/doc/xchat/ChangeLog
+%%GNOME:%%share/gnome/apps/Internet/xchat.desktop
+%%GNOME:%%share/gnome/pixmaps/xchat.png
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 189bb833f294..f3428d49c118 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -45,6 +45,7 @@ CONFIGURE_ARGS+= --enable-socks
.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
+PLIST_SUB+= GNOME:=""
.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --disable-panel
.endif
.else
CONFIGURE_ARGS+= --disable-gnome
+PLIST_SUB+= GNOME:="@comment "
.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -59,10 +61,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
-.if defined(WITH_GNOME)
-PLIST= ${PKGDIR}/PLIST.gnome
-.endif
-
post-install:
@strip ${PREFIX}/bin/xchat
.if !defined(NOPORTDOCS)
diff --git a/irc/xchat/pkg-plist b/irc/xchat/pkg-plist
index cbb8fdb32a05..4927f119a67a 100644
--- a/irc/xchat/pkg-plist
+++ b/irc/xchat/pkg-plist
@@ -14,6 +14,8 @@ share/doc/xchat/xchat-9.html
share/doc/xchat/xchat-10.html
share/doc/xchat/README
share/doc/xchat/ChangeLog
+%%GNOME:%%share/gnome/apps/Internet/xchat.desktop
+%%GNOME:%%share/gnome/pixmaps/xchat.png
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index 189bb833f294..f3428d49c118 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -45,6 +45,7 @@ CONFIGURE_ARGS+= --enable-socks
.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
+PLIST_SUB+= GNOME:=""
.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --disable-panel
.endif
.else
CONFIGURE_ARGS+= --disable-gnome
+PLIST_SUB+= GNOME:="@comment "
.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -59,10 +61,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
-.if defined(WITH_GNOME)
-PLIST= ${PKGDIR}/PLIST.gnome
-.endif
-
post-install:
@strip ${PREFIX}/bin/xchat
.if !defined(NOPORTDOCS)
diff --git a/irc/xchat1/pkg-plist b/irc/xchat1/pkg-plist
index cbb8fdb32a05..4927f119a67a 100644
--- a/irc/xchat1/pkg-plist
+++ b/irc/xchat1/pkg-plist
@@ -14,6 +14,8 @@ share/doc/xchat/xchat-9.html
share/doc/xchat/xchat-10.html
share/doc/xchat/README
share/doc/xchat/ChangeLog
+%%GNOME:%%share/gnome/apps/Internet/xchat.desktop
+%%GNOME:%%share/gnome/pixmaps/xchat.png
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 189bb833f294..f3428d49c118 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -45,6 +45,7 @@ CONFIGURE_ARGS+= --enable-socks
.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
+PLIST_SUB+= GNOME:=""
.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --disable-panel
.endif
.else
CONFIGURE_ARGS+= --disable-gnome
+PLIST_SUB+= GNOME:="@comment "
.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -59,10 +61,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
-.if defined(WITH_GNOME)
-PLIST= ${PKGDIR}/PLIST.gnome
-.endif
-
post-install:
@strip ${PREFIX}/bin/xchat
.if !defined(NOPORTDOCS)
diff --git a/irc/xchat2/pkg-plist b/irc/xchat2/pkg-plist
index cbb8fdb32a05..4927f119a67a 100644
--- a/irc/xchat2/pkg-plist
+++ b/irc/xchat2/pkg-plist
@@ -14,6 +14,8 @@ share/doc/xchat/xchat-9.html
share/doc/xchat/xchat-10.html
share/doc/xchat/README
share/doc/xchat/ChangeLog
+%%GNOME:%%share/gnome/apps/Internet/xchat.desktop
+%%GNOME:%%share/gnome/pixmaps/xchat.png
share/locale/cs/LC_MESSAGES/xchat.mo
share/locale/da/LC_MESSAGES/xchat.mo
share/locale/de/LC_MESSAGES/xchat.mo