aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/qpopper/Makefile2
-rw-r--r--net/ntop/Makefile2
-rw-r--r--news/suck/Makefile2
-rw-r--r--security/fressh/Makefile2
-rw-r--r--security/hpn-ssh/Makefile2
-rw-r--r--security/openssh-portable/Makefile2
-rw-r--r--security/openssh/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index d7992137be66..d816afc0e1c3 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -132,7 +132,7 @@ CONFIGURE_ARGS+= --enable-standalone
.if exists(/usr/lib/libssl.a) && exists(/usr/lib/libcrypto.a)
CONFIGURE_ARGS+= --with-openssl=/usr
.elif exists(${LOCALBASE}/lib/libssl.a) && exists(${LOCALBASE}/lib/libcrypto.a)
-LIB_DEPENDS+= ssl.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
CONFIGURE_ARGS+= -with-includes=${LOCALBASE}/include/openssl --with-openssl=${LOCALBASE}
CONFIGURE_ENV+= RSAGLUE="${RSAGLUE}"
.if exists(${LOCALBASE}/lib/librsaref.a)
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index acc2c8210dd3..d1d6380731c5 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --enable-tcpwrap
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400014
-LIB_DEPENDS+= ssl.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
CONFIGURE_ARGS+= --with-ossl-root=${LOCALBASE}
.endif
diff --git a/news/suck/Makefile b/news/suck/Makefile
index 2faaa61d034d..8a3c01ebfad8 100644
--- a/news/suck/Makefile
+++ b/news/suck/Makefile
@@ -38,7 +38,7 @@ USE_OPENSSL= yes
.if ${OSVERSION} < 430000
OPENSSLBASE= /usr/local
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
.endif
diff --git a/security/fressh/Makefile b/security/fressh/Makefile
index bd9b170a8851..862568c0ca4d 100644
--- a/security/fressh/Makefile
+++ b/security/fressh/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
.if !exists(/usr/lib/libssl.a) || !exists(/usr/lib/libcrypto.a)
.if exists(${LOCALBASE}/lib/libssl.a) && exists(${LOCALBASE}/lib/libcrypto.a)
-LIB_DEPENDS+= ssl.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
MAKE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
RSAGLUE="${RSAGLUE}"
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index ca1133761e69..207cee2ee151 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -86,7 +86,7 @@ post-install:
.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index ca1133761e69..207cee2ee151 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -86,7 +86,7 @@ post-install:
.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index a449e9bb666d..5f7db3968b88 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -35,7 +35,7 @@ FIXME= lib/Makefile scp/Makefile sftp/Makefile sftp-server/Makefile \
.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \