aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/mgetty+sendfax/Makefile2
-rw-r--r--comms/mgetty+sendfax/scripts/configure2
-rw-r--r--games/jetpack/files/patch-ac73
-rw-r--r--games/jetpack/files/patch-ae9
-rw-r--r--games/jetpack/pkg-plist2
-rw-r--r--games/xmris/Makefile1
-rw-r--r--games/xmris/pkg-comment2
-rw-r--r--games/xmris/pkg-plist8
-rw-r--r--games/xmris/scripts/pre-configure2
9 files changed, 64 insertions, 37 deletions
diff --git a/comms/mgetty+sendfax/Makefile b/comms/mgetty+sendfax/Makefile
index ccc23cfb2cfd..f1988f801478 100644
--- a/comms/mgetty+sendfax/Makefile
+++ b/comms/mgetty+sendfax/Makefile
@@ -1,5 +1,5 @@
DISTNAME= mgetty-0.21
DISTFILES= mgetty021-Aug21.tar.gz
-MASTER_SITES= ftp://hpsystem2.informatik.tu-muenchen.de:/pub/comp/networking/communication/modem/mgetty/
+MASTER_SITES= ftp://hpsystem2.informatik.tu-muenchen.de/pub/comp/networking/communication/modem/mgetty/
MAKE_FLAGS= FAX_SPOOL=/var/spool/fax
.include <bsd.port.mk>
diff --git a/comms/mgetty+sendfax/scripts/configure b/comms/mgetty+sendfax/scripts/configure
index 801eb311c938..8fb0b13a4f35 100644
--- a/comms/mgetty+sendfax/scripts/configure
+++ b/comms/mgetty+sendfax/scripts/configure
@@ -140,7 +140,7 @@ cat <<END
END
wq "login file:" /etc/nologin.%s NOLOGIN_FILE
-ww LOCK \"/usr/spool/lock/LCK..%s\"
+ww LOCK \"/var/spool/lock/LCK..%s\"
cat <<END
Set this to "1" if your system uses binary lock files (i.e., the pid
diff --git a/games/jetpack/files/patch-ac b/games/jetpack/files/patch-ac
index 446b23711a8e..b8fd5e9bc2c4 100644
--- a/games/jetpack/files/patch-ac
+++ b/games/jetpack/files/patch-ac
@@ -1,9 +1,15 @@
*** Imakefile.orig Mon Nov 8 15:16:05 1993
---- Imakefile Wed Sep 21 00:55:52 1994
+--- Imakefile Thu Sep 22 16:30:18 1994
***************
-*** 7,22 ****
+*** 1,44 ****
+! SRCS = bitmap.c bonus.c collision.c demo.c draw.c erase.c events.c\
+ gameover.c initx.c main.c maze.c message.c normal.c quitx.c scores.c\
+ setinmaze.c setup.c special.c time.c update.c windowx.c
+! OBJS = bitmap.o bonus.o collision.o demo.o draw.o erase.o events.o\
+ gameover.o initx.o main.o maze.o message.o normal.o quitx.o scores.o\
+ setinmaze.o setup.o special.o time.o update.o windowx.o
- PROGRAMS = jetpack
+! PROGRAMS = jetpack
! DESTDIR = /usrd/s/m/meb2
@@ -15,28 +21,16 @@
! MANDIR = $(MANSOURCEPATH)1
! TOP_INCLUDES =
! DEPXLIB =
- EXTRA_LIBRARIES = $(XLIB)
+! EXTRA_LIBRARIES = $(XLIB)
# I like my programs optimized, stripped, and setuid. Do what you like.
---- 7,22 ----
+! INSTPGMFLAGS = $(INSTUIDFLAGS) -s
+! CDEBUGFLAGS = -O4
- PROGRAMS = jetpack
+ # Since my programs are setuid, I make the data files readable only by me.
+! INSTDATFLAGS = -m 0600
-! BINDIR = /usr/local/bin
-! LIBDIR = /usr/local/lib/jetpack
-! MANDIR = /usr/local/man/man6
-
- # These defines override the template defaults. Trash em if you want to
- # use the template locations
-! # LIBDIR = $(DESTDIR)/lib/jetpack
-! # BINDIR = $(DESTDIR)/bin
-! # MANPATH = $(DESTDIR)/man
-! # MANDIR = $(MANSOURCEPATH)1
- EXTRA_LIBRARIES = $(XLIB)
-
- # I like my programs optimized, stripped, and setuid. Do what you like.
-***************
-*** 30,44 ****
+ # These defines are needed by jetpack. Delete the -DBLIT if you don't want
# the game to do all the drawing to an offscreen pixmap. (This is good for
# machines that don't have hardware blitting -- if you have an xterm or a
# graphics workhorse, leave it in, there will be no flicker)
@@ -52,20 +46,49 @@
ComplexProgramTarget(jetpack)
---- 30,45 ----
+--- 1,45 ----
+! SRCS = bitmap.c bonus.c collision.c demo.c draw.c erase.c events.c\
+ gameover.c initx.c main.c maze.c message.c normal.c quitx.c scores.c\
+ setinmaze.c setup.c special.c time.c update.c windowx.c
+! OBJS = bitmap.o bonus.o collision.o demo.o draw.o erase.o events.o\
+ gameover.o initx.o main.o maze.o message.o normal.o quitx.o scores.o\
+ setinmaze.o setup.o special.o time.o update.o windowx.o
+
+! PROGRAMS = jetpack
+
+! BINDIR = /usr/local/bin
+! LIBDIR = /usr/local/lib/jetpack
+! MANDIR = /usr/local/man/man6
+
+ # These defines override the template defaults. Trash em if you want to
+ # use the template locations
+! # LIBDIR = $(DESTDIR)/lib/jetpack
+! # BINDIR = $(DESTDIR)/bin
+! # MANPATH = $(DESTDIR)/man
+! # MANDIR = $(MANSOURCEPATH)1
+! EXTRA_LIBRARIES = $(XLIB)
+
+ # I like my programs optimized, stripped, and setuid. Do what you like.
+! INSTPGMFLAGS = $(INSTUIDFLAGS) -s
+! CDEBUGFLAGS = -O4
+
+ # Since my programs are setuid, I make the data files readable only by me.
+! INSTDATFLAGS = -m 0600
+
+ # These defines are needed by jetpack. Delete the -DBLIT if you don't want
# the game to do all the drawing to an offscreen pixmap. (This is good for
# machines that don't have hardware blitting -- if you have an xterm or a
# graphics workhorse, leave it in, there will be no flicker)
! # DEFINES = -DBLIT -DSCOREPATH=\"$(SCOREFILE)\" -DLEVELPATH=\"$(LEVELFILE)\"
-! DEFINES = -DSCOREPATH=\"$(SCOREFILE)\" -DLEVELPATH=\"$(LEVELFILE)\"
+! DEFINES = -DSCOREPATH=\"$(SCOREFILE)\" -DLEVELPATH=\"$(LEVELFILE)\"
# The score file can be any name you like, just make sure the directory
# it's supposed to reside in exists, or jetpack will start creating score
# files in the directories it is run from. Same for the level files, only
# the filename you give here is only a prefix -- the complete filename has
# the level number appended to it.
-! SCOREFILE = $(LIBDIR)/jetpack.scores
-! LEVELFILE = $(LIBDIR)/jetpack.lev
+! SCOREFILE = $(LIBDIR)/jetpack.scores
+! LEVELFILE = $(LIBDIR)/jetpack.lev
ComplexProgramTarget(jetpack)
diff --git a/games/jetpack/files/patch-ae b/games/jetpack/files/patch-ae
index d0668ab98c94..9d8c69d61a53 100644
--- a/games/jetpack/files/patch-ae
+++ b/games/jetpack/files/patch-ae
@@ -1,10 +1,11 @@
-*** main.c.orig Wed Sep 21 00:33:35 1994
---- main.c Wed Sep 21 00:35:35 1994
+*** main.c.orig Mon Apr 6 12:59:32 1992
+--- main.c Thu Sep 22 13:07:12 1994
***************
*** 1,5 ****
---- 1,8 ----
+--- 1,9 ----
/* main.c : main loop of jetpack
*/
++ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
+
@@ -13,7 +14,7 @@
#include "defs.h"
***************
*** 18,23 ****
---- 21,29 ----
+--- 22,30 ----
int seed;
char lev[20];
register unsigned long timer;
diff --git a/games/jetpack/pkg-plist b/games/jetpack/pkg-plist
index 2a877d23d00d..17ad7e9aefb6 100644
--- a/games/jetpack/pkg-plist
+++ b/games/jetpack/pkg-plist
@@ -1,5 +1,5 @@
@cd /usr/local
-@mode u+rw,a+r
+@mode 644
man/man6/jetpack.6
lib/jetpack/jetpack.lev000
@owner bin
diff --git a/games/xmris/Makefile b/games/xmris/Makefile
index 188a2b2f4d3b..4f4abcab7457 100644
--- a/games/xmris/Makefile
+++ b/games/xmris/Makefile
@@ -1,5 +1,6 @@
DISTNAME= xmris.4.02
USE_IMAKE= yes
+USE_GMAKE= yes
MASTER_SITES= ftp://ftp.x.org/R5contrib/
pre-install:
diff --git a/games/xmris/pkg-comment b/games/xmris/pkg-comment
index ea7921ffe7f6..6f544cbe8fc9 100644
--- a/games/xmris/pkg-comment
+++ b/games/xmris/pkg-comment
@@ -1 +1 @@
-Xmris: a version of a popular video arcade game for the X Window System.
+Xmris: a version of the Mr Do video arcade game for the X Window System.
diff --git a/games/xmris/pkg-plist b/games/xmris/pkg-plist
index f2054858d79d..ae604bcaca73 100644
--- a/games/xmris/pkg-plist
+++ b/games/xmris/pkg-plist
@@ -1,7 +1,6 @@
@cd /usr/local
-@owner bin
@group bin
-@mode a+r
+@mode 444
man/man6/xmris.6
man/man6/xmsit.6
man/man6/xmred.6
@@ -11,8 +10,11 @@ bin/xmris
bin/xmsit
@mode 755
bin/xmred
+@exec mkdir -p %D/lib/xmris
+@exec chmod 775 %D/lib/xmris
+@unexec rm -rf %D/lib/xmris
@cd /usr/X386
-@mode a+r
+@mode 444
lib/X11/app-defaults/Xmris
lib/X11/app-defaults/xmris/alphabet.gdn
lib/X11/app-defaults/xmris/digits.gdn
diff --git a/games/xmris/scripts/pre-configure b/games/xmris/scripts/pre-configure
index 6c01b92f1e8c..8214f8999e32 100644
--- a/games/xmris/scripts/pre-configure
+++ b/games/xmris/scripts/pre-configure
@@ -1,7 +1,7 @@
#!/bin/sh
# X must be running when the scram program creates the bitmaps
-xwd -root >/dev/null
+xwd -root >/dev/null 2>&1
if [ $? != 0 ]; then
echo "X needs to be started to build xmris"
exit 1