aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/spell/Makefile25
-rw-r--r--textproc/spell/distinfo1
-rw-r--r--textproc/spell/files/patch-spell.texi14
-rw-r--r--textproc/spell/pkg-comment1
-rw-r--r--textproc/spell/pkg-descr7
-rw-r--r--textproc/spell/pkg-plist5
7 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8eb31722e277..9e7e3e7e5bf6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -275,6 +275,7 @@
SUBDIR += smartdoc
SUBDIR += source-highlight
SUBDIR += sp
+ SUBDIR += spell
SUBDIR += tclExpat
SUBDIR += tdtd.el
SUBDIR += tex2im
diff --git a/textproc/spell/Makefile b/textproc/spell/Makefile
new file mode 100644
index 000000000000..7e03edff1f41
--- /dev/null
+++ b/textproc/spell/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: spell-1.0
+# Date created: Wed Apr 24 10:17:36 EDT 2002
+# Whom: Brian Skrab <brian@quynh-and-brian.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spell
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ http://cottage.quynh-and-brian.org/freebsd/ports/distfiles/
+MASTER_SITE_SUBDIR= spell
+
+MAINTAINER= brian@quynh-and-brian.org
+
+RUN_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+post-install:
+ install-info ${PREFIX}/info/spell.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/textproc/spell/distinfo b/textproc/spell/distinfo
new file mode 100644
index 000000000000..d5f998d326fb
--- /dev/null
+++ b/textproc/spell/distinfo
@@ -0,0 +1 @@
+MD5 (spell-1.0.tar.gz) = 57e17cf64ca458baad606a9022794b6d
diff --git a/textproc/spell/files/patch-spell.texi b/textproc/spell/files/patch-spell.texi
new file mode 100644
index 000000000000..d9aa3b2d230d
--- /dev/null
+++ b/textproc/spell/files/patch-spell.texi
@@ -0,0 +1,14 @@
+--- spell.texi.orig Tue Apr 9 21:20:14 1996
++++ spell.texi Wed Apr 24 08:47:57 2002
+@@ -9,6 +9,11 @@
+ @set UPDATED April 6, 1996
+ @c %**end of header
+
++@dircategory GNU Packages
++@direntry
++* Spell: (spell). A GNU implementation of the UNIX spell utility using Ispell.
++@end direntry
++
+ @ifinfo
+ This file documents GNU Spell, a clone of Unix @code{spell}.
+
diff --git a/textproc/spell/pkg-comment b/textproc/spell/pkg-comment
new file mode 100644
index 000000000000..0dc64277397d
--- /dev/null
+++ b/textproc/spell/pkg-comment
@@ -0,0 +1 @@
+A GNU implementation of the UNIX spell utility using Ispell
diff --git a/textproc/spell/pkg-descr b/textproc/spell/pkg-descr
new file mode 100644
index 000000000000..c1cae986bd14
--- /dev/null
+++ b/textproc/spell/pkg-descr
@@ -0,0 +1,7 @@
+A GNU implementation of the UNIX spell utility using Ispell.
+
+Provides a flexible, non-interactive interface to the Ispell utility.
+
+WWW: http://www.gnu.org/
+
+brian@quynh-and-brian.org
diff --git a/textproc/spell/pkg-plist b/textproc/spell/pkg-plist
new file mode 100644
index 000000000000..6094b51121e9
--- /dev/null
+++ b/textproc/spell/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+bin/spell
+@unexec install-info --delete %D/info/spell.info %D/info/dir
+info/spell.info
+@exec install-info %D/info/spell.info %D/info/dir