aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/xgospel/Makefile35
-rw-r--r--games/xgospel/distinfo1
-rw-r--r--games/xgospel/pkg-comment1
-rw-r--r--games/xgospel/pkg-descr5
-rw-r--r--games/xgospel/pkg-plist9
6 files changed, 52 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index fceaa1e20869..f0b084b8d928 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -323,6 +323,7 @@
SUBDIR += xgalaga
SUBDIR += xgammon
SUBDIR += xgolgo
+ SUBDIR += xgospel
SUBDIR += xhexagons
SUBDIR += xhime
SUBDIR += xinfocom
diff --git a/games/xgospel/Makefile b/games/xgospel/Makefile
new file mode 100644
index 000000000000..0be9c6bedf37
--- /dev/null
+++ b/games/xgospel/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xgospel
+# Date created: 13 November 2001
+# Whom: Shao Zhang <shaoz@asia.com>
+#
+# $FreeBSD$
+
+PORTNAME= xgospel
+PORTVERSION= 1.12d
+CATEGORIES= games
+MASTER_SITES= http://www.teaser.fr/~jlgailly/
+
+MAINTAINER= shaoz@asia.com
+
+LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+
+USE_XLIB= yes
+USE_XPM= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --with-x --with-xpm --with-xaw3d
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/relay ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/rport ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/xgospel ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/board.xpm ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/pagoda.xpm ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/FAQ ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/xgospel/distinfo b/games/xgospel/distinfo
new file mode 100644
index 000000000000..7a3fdbb31609
--- /dev/null
+++ b/games/xgospel/distinfo
@@ -0,0 +1 @@
+MD5 (xgospel-1.12d.tar.gz) = edbfb454491dcb3a4115a98f6dc28d40
diff --git a/games/xgospel/pkg-comment b/games/xgospel/pkg-comment
new file mode 100644
index 000000000000..f686884728da
--- /dev/null
+++ b/games/xgospel/pkg-comment
@@ -0,0 +1 @@
+An X11 Go (weiqi, baduk) client for the Internet Go Server
diff --git a/games/xgospel/pkg-descr b/games/xgospel/pkg-descr
new file mode 100644
index 000000000000..d7e195cd5232
--- /dev/null
+++ b/games/xgospel/pkg-descr
@@ -0,0 +1,5 @@
+Xgospel is an X11 Go client for playing the game Go (weiqi, Baduk) on
+the IGS (Internet Go Server) or NNGS (No Name Go Server). For more
+information, see http://igs.joyjoy.net
+
+WWW: http://www.teaser.fr/~jlgailly/go.html
diff --git a/games/xgospel/pkg-plist b/games/xgospel/pkg-plist
new file mode 100644
index 000000000000..a38aee767df3
--- /dev/null
+++ b/games/xgospel/pkg-plist
@@ -0,0 +1,9 @@
+bin/relay
+bin/rport
+bin/xgospel
+%%PORTDOCS%%share/doc/xgospel/FAQ
+%%PORTDOCS%%share/doc/xgospel/README
+share/xgospel/board.xpm
+share/xgospel/pagoda.xpm
+@dirrm share/xgospel
+%%PORTDOCS%%@dirrm share/doc/xgospel