aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/tcl80/Makefile7
-rw-r--r--lang/tcl80/pkg-install.tclsh31
-rw-r--r--lang/tcl82/Makefile7
-rw-r--r--lang/tcl82/pkg-install.tclsh31
-rw-r--r--lang/tcl83/Makefile7
-rw-r--r--lang/tcl83/pkg-install.tclsh31
-rw-r--r--lang/tcl84/Makefile7
-rw-r--r--lang/tcl84/pkg-install.tclsh31
8 files changed, 148 insertions, 4 deletions
diff --git a/lang/tcl80/Makefile b/lang/tcl80/Makefile
index 6bc6fd35f089..e5ce84d0dfb1 100644
--- a/lang/tcl80/Makefile
+++ b/lang/tcl80/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.5 1998/03/18 00:56:08 jmz Exp $
+# $Id: Makefile,v 1.6 1998/07/03 23:06:48 steve Exp $
#
DISTNAME= tcl8.0p2
@@ -32,8 +32,13 @@ pre-build:
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PKGDIR}/INSTALL.tclsh)
+ ${SH} ${PKGDIR}/INSTALL.tclsh
+.endif
test:
cd ${WRKSRC} && ${MAKE} test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PKGDIR}/INSTALL.tclsh
diff --git a/lang/tcl80/pkg-install.tclsh b/lang/tcl80/pkg-install.tclsh
new file mode 100644
index 000000000000..244df90dfdba
--- /dev/null
+++ b/lang/tcl80/pkg-install.tclsh
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a tclsh they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/tclsh ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
+
+ cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, tclsh is named with a version number. This is because"
+echo "different versions of tclsh are not compatible with each other and"
+echo "they can not all be called \"tclsh\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, tclsh is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^tclsh[0-9]+\.[0-9]+([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No tclsh installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/tclsh
+fi
diff --git a/lang/tcl82/Makefile b/lang/tcl82/Makefile
index ec87b60f5440..e3651a2e407f 100644
--- a/lang/tcl82/Makefile
+++ b/lang/tcl82/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.8 1998/07/01 10:20:59 jseger Exp $
+# $Id: Makefile,v 1.9 1998/07/04 17:29:15 jdp Exp $
#
DISTNAME= tcl8.1a2
@@ -21,8 +21,13 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh)
+ ${SH} ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
+.endif
test:
cd ${WRKSRC} && ${MAKE} test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
diff --git a/lang/tcl82/pkg-install.tclsh b/lang/tcl82/pkg-install.tclsh
new file mode 100644
index 000000000000..244df90dfdba
--- /dev/null
+++ b/lang/tcl82/pkg-install.tclsh
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a tclsh they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/tclsh ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
+
+ cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, tclsh is named with a version number. This is because"
+echo "different versions of tclsh are not compatible with each other and"
+echo "they can not all be called \"tclsh\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, tclsh is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^tclsh[0-9]+\.[0-9]+([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No tclsh installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/tclsh
+fi
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index ec87b60f5440..e3651a2e407f 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.8 1998/07/01 10:20:59 jseger Exp $
+# $Id: Makefile,v 1.9 1998/07/04 17:29:15 jdp Exp $
#
DISTNAME= tcl8.1a2
@@ -21,8 +21,13 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh)
+ ${SH} ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
+.endif
test:
cd ${WRKSRC} && ${MAKE} test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
diff --git a/lang/tcl83/pkg-install.tclsh b/lang/tcl83/pkg-install.tclsh
new file mode 100644
index 000000000000..244df90dfdba
--- /dev/null
+++ b/lang/tcl83/pkg-install.tclsh
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a tclsh they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/tclsh ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
+
+ cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, tclsh is named with a version number. This is because"
+echo "different versions of tclsh are not compatible with each other and"
+echo "they can not all be called \"tclsh\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, tclsh is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^tclsh[0-9]+\.[0-9]+([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No tclsh installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/tclsh
+fi
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index ec87b60f5440..e3651a2e407f 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.8 1998/07/01 10:20:59 jseger Exp $
+# $Id: Makefile,v 1.9 1998/07/04 17:29:15 jdp Exp $
#
DISTNAME= tcl8.1a2
@@ -21,8 +21,13 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh)
+ ${SH} ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
+.endif
test:
cd ${WRKSRC} && ${MAKE} test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
diff --git a/lang/tcl84/pkg-install.tclsh b/lang/tcl84/pkg-install.tclsh
new file mode 100644
index 000000000000..244df90dfdba
--- /dev/null
+++ b/lang/tcl84/pkg-install.tclsh
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a tclsh they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/tclsh ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
+
+ cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, tclsh is named with a version number. This is because"
+echo "different versions of tclsh are not compatible with each other and"
+echo "they can not all be called \"tclsh\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, tclsh is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^tclsh[0-9]+\.[0-9]+([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No tclsh installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/tclsh
+fi