aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/fox/Makefile13
-rw-r--r--x11-toolkits/fox10/Makefile13
2 files changed, 24 insertions, 2 deletions
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index 0046bc81b46f..5e644c9a959d 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -133,4 +133,15 @@ pre-everything::
.endif
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+##
+## Port conflict management
+##
+.if exists(${LOCALBASE}/lib/libFOX-1.1.so)
+IGNORE= Conflict management: you have port fox-devel installed. The\
+ fox port is incompatible with fox-devel one. You have to\
+ uninstall fox-devel port if you really need the fox one
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
index 0046bc81b46f..5e644c9a959d 100644
--- a/x11-toolkits/fox10/Makefile
+++ b/x11-toolkits/fox10/Makefile
@@ -133,4 +133,15 @@ pre-everything::
.endif
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+##
+## Port conflict management
+##
+.if exists(${LOCALBASE}/lib/libFOX-1.1.so)
+IGNORE= Conflict management: you have port fox-devel installed. The\
+ fox port is incompatible with fox-devel one. You have to\
+ uninstall fox-devel port if you really need the fox one
+.endif
+
+.include <bsd.port.post.mk>