aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/sfront/Makefile27
-rw-r--r--audio/sfront/distinfo1
-rw-r--r--audio/sfront/pkg-comment1
-rw-r--r--audio/sfront/pkg-descr5
-rw-r--r--audio/sfront/pkg-plist1
6 files changed, 36 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 4322a23c09a0..831cdc08f71b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -179,6 +179,7 @@
SUBDIR += s3mod
SUBDIR += sbagen
SUBDIR += sdl_mixer
+ SUBDIR += sfront
SUBDIR += shntool
SUBDIR += shorten
SUBDIR += shout
diff --git a/audio/sfront/Makefile b/audio/sfront/Makefile
new file mode 100644
index 000000000000..0d345c679f19
--- /dev/null
+++ b/audio/sfront/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: sfront
+# Date created: Nov 4, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sfront
+PORTVERSION= 0.7.8
+CATEGORIES= audio
+MASTER_SITES= http://www.cs.berkeley.edu/~lazzaro/sa/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BISON= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+ALL_TARGET= # empty
+
+post-patch:
+ @${PERL} -pi -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/../bin/sfront ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/sfront/distinfo b/audio/sfront/distinfo
new file mode 100644
index 000000000000..da803bca90e2
--- /dev/null
+++ b/audio/sfront/distinfo
@@ -0,0 +1 @@
+MD5 (sfront.tar.gz) = d9b09b7991817cd5dec19caa464240f6
diff --git a/audio/sfront/pkg-comment b/audio/sfront/pkg-comment
new file mode 100644
index 000000000000..0e24e2176ba5
--- /dev/null
+++ b/audio/sfront/pkg-comment
@@ -0,0 +1 @@
+A translator that converts MP4-SA files into efficient C programs
diff --git a/audio/sfront/pkg-descr b/audio/sfront/pkg-descr
new file mode 100644
index 000000000000..19490ad16eaf
--- /dev/null
+++ b/audio/sfront/pkg-descr
@@ -0,0 +1,5 @@
+sfront is a translator that converts MP4-SA files into efficient C
+programs that generate audio for rendering, interactive and network
+applications.
+
+WWW: http://www.cs.berkeley.edu/~lazzaro/sa/
diff --git a/audio/sfront/pkg-plist b/audio/sfront/pkg-plist
new file mode 100644
index 000000000000..108561e3d144
--- /dev/null
+++ b/audio/sfront/pkg-plist
@@ -0,0 +1 @@
+bin/sfront