aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/peercast/Makefile16
-rw-r--r--net-p2p/peercast/distinfo4
-rw-r--r--net-p2p/peercast/files/peercast.sh.in (renamed from net-p2p/peercast/files/peercast.in)2
-rw-r--r--net/peercast/Makefile16
-rw-r--r--net/peercast/distinfo4
-rw-r--r--net/peercast/files/peercast.sh.in (renamed from net/peercast/files/peercast.in)2
6 files changed, 18 insertions, 26 deletions
diff --git a/net-p2p/peercast/Makefile b/net-p2p/peercast/Makefile
index 75acac22ab33..2886103c43d5 100644
--- a/net-p2p/peercast/Makefile
+++ b/net-p2p/peercast/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= peercast
-PORTVERSION= 0.1211
+PORTVERSION= 0.1212
CATEGORIES= net multimedia
MASTER_SITES= http://www.peercast.org/
DISTNAME= peercast-linux
@@ -15,25 +15,21 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jylefort@FreeBSD.org
COMMENT= A peer-to-peer network for broadcasting and listening to streams
-USE_LINUX?= yes
+USE_LINUX= yes
NO_WRKSUBDIR= yes
+NO_BUILD= yes
+STRIP= # empty: do not strip linux binaries
-do-build:
- ${SED} -e 's|@PREFIX@|${PREFIX}|g; s|@DATADIR@|${DATADIR}|g' \
- ${FILESDIR}/peercast.in > ${WRKSRC}/peercast.sh
+SUB_FILES= peercast.sh
do-install:
- ${MKDIR} ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/peercast.sh ${PREFIX}/bin/peercast
${INSTALL_PROGRAM} ${WRKSRC}/peercast ${PREFIX}/libexec
- # rebrand binary (INSTALL_PROGRAM has stripped it)
- ${BRANDELF} -t Linux ${PREFIX}/libexec/peercast
.for lang in de en fr ja
${MKDIR} ${DATADIR}/html/${lang}
${INSTALL_DATA} ${WRKSRC}/html/${lang}/*.* ${DATADIR}/html/${lang}
${MKDIR} ${DATADIR}/html/${lang}/images
${INSTALL_DATA} ${WRKSRC}/html/${lang}/images/*.* ${DATADIR}/html/${lang}/images
.endfor
- ${MKDIR} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/peercast.sh ${PREFIX}/bin/peercast
.include <bsd.port.mk>
diff --git a/net-p2p/peercast/distinfo b/net-p2p/peercast/distinfo
index ce5fb9648917..2de42ef6e234 100644
--- a/net-p2p/peercast/distinfo
+++ b/net-p2p/peercast/distinfo
@@ -1,2 +1,2 @@
-MD5 (peercast-linux.tgz) = 896a4201a2a2e90e06779654919e1cd4
-SIZE (peercast-linux.tgz) = 198726
+MD5 (peercast-linux.tgz) = 3ff5efb2710fe80ed9bc3e3290141ab9
+SIZE (peercast-linux.tgz) = 197079
diff --git a/net-p2p/peercast/files/peercast.in b/net-p2p/peercast/files/peercast.sh.in
index b0ec0996b36b..f92d6e3557b0 100644
--- a/net-p2p/peercast/files/peercast.in
+++ b/net-p2p/peercast/files/peercast.sh.in
@@ -2,7 +2,7 @@
if [ ! -d "$HOME/.peercast" ]; then
mkdir "$HOME/.peercast" || exit 1
- ln -s "@DATADIR@/html" "@PREFIX@/libexec/peercast" "$HOME/.peercast" || exit 1
+ ln -s "%%DATADIR%%/html" "%%PREFIX%%/libexec/peercast" "$HOME/.peercast" || exit 1
fi
cd "$HOME/.peercast" || exit 1
diff --git a/net/peercast/Makefile b/net/peercast/Makefile
index 75acac22ab33..2886103c43d5 100644
--- a/net/peercast/Makefile
+++ b/net/peercast/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= peercast
-PORTVERSION= 0.1211
+PORTVERSION= 0.1212
CATEGORIES= net multimedia
MASTER_SITES= http://www.peercast.org/
DISTNAME= peercast-linux
@@ -15,25 +15,21 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jylefort@FreeBSD.org
COMMENT= A peer-to-peer network for broadcasting and listening to streams
-USE_LINUX?= yes
+USE_LINUX= yes
NO_WRKSUBDIR= yes
+NO_BUILD= yes
+STRIP= # empty: do not strip linux binaries
-do-build:
- ${SED} -e 's|@PREFIX@|${PREFIX}|g; s|@DATADIR@|${DATADIR}|g' \
- ${FILESDIR}/peercast.in > ${WRKSRC}/peercast.sh
+SUB_FILES= peercast.sh
do-install:
- ${MKDIR} ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/peercast.sh ${PREFIX}/bin/peercast
${INSTALL_PROGRAM} ${WRKSRC}/peercast ${PREFIX}/libexec
- # rebrand binary (INSTALL_PROGRAM has stripped it)
- ${BRANDELF} -t Linux ${PREFIX}/libexec/peercast
.for lang in de en fr ja
${MKDIR} ${DATADIR}/html/${lang}
${INSTALL_DATA} ${WRKSRC}/html/${lang}/*.* ${DATADIR}/html/${lang}
${MKDIR} ${DATADIR}/html/${lang}/images
${INSTALL_DATA} ${WRKSRC}/html/${lang}/images/*.* ${DATADIR}/html/${lang}/images
.endfor
- ${MKDIR} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/peercast.sh ${PREFIX}/bin/peercast
.include <bsd.port.mk>
diff --git a/net/peercast/distinfo b/net/peercast/distinfo
index ce5fb9648917..2de42ef6e234 100644
--- a/net/peercast/distinfo
+++ b/net/peercast/distinfo
@@ -1,2 +1,2 @@
-MD5 (peercast-linux.tgz) = 896a4201a2a2e90e06779654919e1cd4
-SIZE (peercast-linux.tgz) = 198726
+MD5 (peercast-linux.tgz) = 3ff5efb2710fe80ed9bc3e3290141ab9
+SIZE (peercast-linux.tgz) = 197079
diff --git a/net/peercast/files/peercast.in b/net/peercast/files/peercast.sh.in
index b0ec0996b36b..f92d6e3557b0 100644
--- a/net/peercast/files/peercast.in
+++ b/net/peercast/files/peercast.sh.in
@@ -2,7 +2,7 @@
if [ ! -d "$HOME/.peercast" ]; then
mkdir "$HOME/.peercast" || exit 1
- ln -s "@DATADIR@/html" "@PREFIX@/libexec/peercast" "$HOME/.peercast" || exit 1
+ ln -s "%%DATADIR%%/html" "%%PREFIX%%/libexec/peercast" "$HOME/.peercast" || exit 1
fi
cd "$HOME/.peercast" || exit 1