aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--devel/libuta/Makefile61
-rw-r--r--devel/libuta/distinfo2
-rw-r--r--devel/libuta/files/patch-uta::blitters.cc46
-rw-r--r--devel/libuta/files/patch-uta::painter.cc10
-rw-r--r--devel/libuta/pkg-descr6
-rw-r--r--devel/libuta/pkg-plist54
-rw-r--r--devel/wftk/Makefile39
-rw-r--r--devel/wftk/distinfo4
-rw-r--r--devel/wftk/files/patch-uta::blitters.cc46
-rw-r--r--devel/wftk/files/patch-uta::painter.cc10
-rw-r--r--devel/wftk/files/patch-wftk::poll.h11
-rw-r--r--devel/wftk/files/patch-wftk::region.h11
-rw-r--r--devel/wftk/files/patch-wftk::timer.h11
-rw-r--r--devel/wftk/pkg-descr6
-rw-r--r--devel/wftk/pkg-plist122
16 files changed, 127 insertions, 313 deletions
diff --git a/MOVED b/MOVED
index 7c1d7f6adccf..83ddbb21d63d 100644
--- a/MOVED
+++ b/MOVED
@@ -1466,3 +1466,4 @@ www/mod_throttle||2005-05-07|author does not permit distribution of patch files
www/mod_watch||2005-05-07|author does not permit distribution of patch files
www/mod_watch4||2005-05-07|author does not permit distribution of patch files
japanese/postgresql7-man|japanese/postgresql74-man|2005-05-08|port renamed
+devel/libuta|devel/wftk|2005-05-11|wftk is a fork of libuta which is not any longer maintained
diff --git a/devel/libuta/Makefile b/devel/libuta/Makefile
deleted file mode 100644
index a9e0094ffd30..000000000000
--- a/devel/libuta/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-# New ports collection makefile for: libuta
-# Date created: 29 March 2001
-# Whom: Oliver Lehmann <lehmann@ans-netz.de>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libuta
-PORTVERSION= 0.4.4
-PORTREVISION= 4
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= oliver@FreeBSD.org
-COMMENT= A Graphical User Interface library for C++
-
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- sigc.1:${PORTSDIR}/devel/libsigc++
-
-OPTIONS= SDL_MIXER "music and sound support" off
-
-USE_FREETYPE= yes
-USE_INC_LIBTOOL_VER= 13
-USE_SDL= sdl
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
-
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-
-WANT_SDL= yes
-
-SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
- uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
- uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
- uta/surface.h uta/timer.cc
-
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_SDL:Mmixer}!=""
-WITH_SDL_MIXER= yes
-.endif
-
-.if defined(WITH_SDL_MIXER)
-USE_SDL+= mixer
-.endif
-
-post-patch:
-.for i in ${SDL11_FILES}
- @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
-.endfor
-
-pre-configure:
- @${REINPLACE_CMD} -e '\
- s|<freetype/freetype.h>|<freetype1/freetype/freetype.h>|g; \
- s|-lpthread||g; \
- s|-lc_r|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure ${WRKSRC}/uta/font.h
-
-.include <bsd.port.post.mk>
diff --git a/devel/libuta/distinfo b/devel/libuta/distinfo
deleted file mode 100644
index 1ec62e1a8c02..000000000000
--- a/devel/libuta/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (libuta-0.4.4.tar.gz) = 1326c9f4a9de768289b9cb5f18a54cdc
-SIZE (libuta-0.4.4.tar.gz) = 388720
diff --git a/devel/libuta/files/patch-uta::blitters.cc b/devel/libuta/files/patch-uta::blitters.cc
deleted file mode 100644
index 8aed5a1d7927..000000000000
--- a/devel/libuta/files/patch-uta::blitters.cc
+++ /dev/null
@@ -1,46 +0,0 @@
---- uta/blitters.cc.orig Sat Oct 12 23:11:07 2002
-+++ uta/blitters.cc Thu Aug 12 20:58:40 2004
-@@ -20,6 +20,7 @@
-
- #include "blitters.h"
- #include <painter.h>
-+#include <cassert>
-
- namespace uta {
-
-@@ -28,6 +29,8 @@
- #endif
- #if !defined(X86_ASSEMBLER)
-
-+using namespace std;
-+
- /** Apply const gamma value.
- Blit just copies alpha value of the source to the destination surface.
- */
-@@ -163,7 +166,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
-@@ -211,7 +214,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
-@@ -960,7 +963,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
diff --git a/devel/libuta/files/patch-uta::painter.cc b/devel/libuta/files/patch-uta::painter.cc
deleted file mode 100644
index 3f9f2390b022..000000000000
--- a/devel/libuta/files/patch-uta::painter.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- uta/painter.cc.orig Sat Jul 26 01:22:51 2003
-+++ uta/painter.cc Fri Jul 25 23:24:47 2003
-@@ -27,6 +27,7 @@
- #include "debug.h"
-
- #include <math.h>
-+#include <cassert>
-
- namespace uta {
-
diff --git a/devel/libuta/pkg-descr b/devel/libuta/pkg-descr
deleted file mode 100644
index 6333d6de5fb8..000000000000
--- a/devel/libuta/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-libuta is a Graphical User Interface library for C++ that uses SDL
-as its output layer. It allows application and game programmers to
-put together portable graphical applications easily. libuta has a
-range of already implemented widgets and uses libsigc++ as a signal
-dispatching system. It also performs resource management and has a
-sound system.
diff --git a/devel/libuta/pkg-plist b/devel/libuta/pkg-plist
deleted file mode 100644
index 7752b4e5a07f..000000000000
--- a/devel/libuta/pkg-plist
+++ /dev/null
@@ -1,54 +0,0 @@
-bin/uta-config
-lib/libuta.so
-lib/libuta-0.4.so.2
-lib/libuta.a
-include/uta/debug.h
-include/uta/color.h
-include/uta/point.h
-include/uta/rect.h
-include/uta/keysym.h
-include/uta/event.h
-include/uta/shared.h
-include/uta/pixelformat.h
-include/uta/painter.h
-include/uta/progressdialog.h
-include/uta/logo.h
-include/uta/logo_data.h
-include/uta/terminal.h
-include/uta/directsurface.h
-include/uta/mutex.h
-include/uta/version.h
-include/uta/uta.h
-include/uta/timer.h
-include/uta/dialogbox.h
-include/uta/messagebox.h
-include/uta/questionbox.h
-include/uta/blitters.h
-include/uta/mmx.h
-include/uta/application.h
-include/uta/button.h
-include/uta/dialog.h
-include/uta/focus.h
-include/uta/font.h
-include/uta/label.h
-include/uta/lineedit.h
-include/uta/listbox.h
-include/uta/mixer.h
-include/uta/mouse.h
-include/uta/mouse_data.h
-include/uta/movie.h
-include/uta/multilineedit.h
-include/uta/music.h
-include/uta/pushbutton.h
-include/uta/resources.h
-include/uta/rootwindow.h
-include/uta/sample.h
-include/uta/screensurface.h
-include/uta/slider.h
-include/uta/sound.h
-include/uta/soundmapper.h
-include/uta/surface.h
-include/uta/togglebutton.h
-include/uta/widget.h
-share/aclocal/uta.m4
-@dirrm include/uta
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index a9e0094ffd30..31a42f2dc11f 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -5,36 +5,42 @@
# $FreeBSD$
#
-PORTNAME= libuta
-PORTVERSION= 0.4.4
-PORTREVISION= 4
+PORTNAME= wftk
+PORTVERSION= 0.7.1
+PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ftp://ftp.worldforge.org/pub/worldforge/libs/wftk/
MAINTAINER= oliver@FreeBSD.org
COMMENT= A Graphical User Interface library for C++
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- sigc.1:${PORTSDIR}/devel/libsigc++
+ sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
-OPTIONS= SDL_MIXER "music and sound support" off
+OPTIONS= SDL_MIXER "music and sound support" off
USE_FREETYPE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
USE_SDL= sdl
GNU_CONFIGURE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
+CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE}
WANT_SDL= yes
-SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
- uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
- uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
- uta/surface.h uta/timer.cc
+SDL11_FILES= configure wftk/sge_blib.h wftk/sge_blib.cpp wftk/sge_draw.h \
+ wftk/sge_draw.cpp wftk/rotozoom.h wftk/surface.cpp \
+ wftk/surface_io.cpp wftk/screensurface.cpp wftk/timer.cpp \
+ wftk/poll.cpp wftk/sdlhandler.cpp wftk/rootwindow.cpp \
+ wftk/mouse.cpp wftk/joystick.cpp wftk/mixer.cpp wftk/color.h \
+ wftk/rect.h wftk/region.h wftk/keysym.h wftk/pixelformat.h \
+ wftk/surface.h wftk/refobj.h wftk/focus.h wftk/application.h \
+ wftk/mouse.h wftk/joystick.h wftk/sound.h wftk/mixer.h \
+ wftk/mutex.h wftk/timer.h wftk/poll.h wftk/sdlhandler.h
.include <bsd.port.pre.mk>
@@ -51,11 +57,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
.endfor
-pre-configure:
- @${REINPLACE_CMD} -e '\
- s|<freetype/freetype.h>|<freetype1/freetype/freetype.h>|g; \
- s|-lpthread||g; \
- s|-lc_r|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure ${WRKSRC}/uta/font.h
-
.include <bsd.port.post.mk>
diff --git a/devel/wftk/distinfo b/devel/wftk/distinfo
index 1ec62e1a8c02..247fcb0b064e 100644
--- a/devel/wftk/distinfo
+++ b/devel/wftk/distinfo
@@ -1,2 +1,2 @@
-MD5 (libuta-0.4.4.tar.gz) = 1326c9f4a9de768289b9cb5f18a54cdc
-SIZE (libuta-0.4.4.tar.gz) = 388720
+MD5 (wftk-0.7.1.tar.gz) = be936bef97a17a47292f0cfac5b7793a
+SIZE(wftk-0.7.1.tar.gz) = 877100
diff --git a/devel/wftk/files/patch-uta::blitters.cc b/devel/wftk/files/patch-uta::blitters.cc
deleted file mode 100644
index 8aed5a1d7927..000000000000
--- a/devel/wftk/files/patch-uta::blitters.cc
+++ /dev/null
@@ -1,46 +0,0 @@
---- uta/blitters.cc.orig Sat Oct 12 23:11:07 2002
-+++ uta/blitters.cc Thu Aug 12 20:58:40 2004
-@@ -20,6 +20,7 @@
-
- #include "blitters.h"
- #include <painter.h>
-+#include <cassert>
-
- namespace uta {
-
-@@ -28,6 +29,8 @@
- #endif
- #if !defined(X86_ASSEMBLER)
-
-+using namespace std;
-+
- /** Apply const gamma value.
- Blit just copies alpha value of the source to the destination surface.
- */
-@@ -163,7 +166,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
-@@ -211,7 +214,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
-@@ -960,7 +963,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
diff --git a/devel/wftk/files/patch-uta::painter.cc b/devel/wftk/files/patch-uta::painter.cc
deleted file mode 100644
index 3f9f2390b022..000000000000
--- a/devel/wftk/files/patch-uta::painter.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- uta/painter.cc.orig Sat Jul 26 01:22:51 2003
-+++ uta/painter.cc Fri Jul 25 23:24:47 2003
-@@ -27,6 +27,7 @@
- #include "debug.h"
-
- #include <math.h>
-+#include <cassert>
-
- namespace uta {
-
diff --git a/devel/wftk/files/patch-wftk::poll.h b/devel/wftk/files/patch-wftk::poll.h
new file mode 100644
index 000000000000..d161072a4683
--- /dev/null
+++ b/devel/wftk/files/patch-wftk::poll.h
@@ -0,0 +1,11 @@
+--- wftk/poll.h.orig Sun May 8 00:11:35 2005
++++ wftk/poll.h Sun May 8 00:11:51 2005
+@@ -115,7 +115,7 @@
+ virtual void event(int mask) = 0;
+
+ typedef Application::FloatingEvent<Poll> BaseEvent;
+- friend class BaseEvent;
++ friend class Application::FloatingEvent<Poll>;
+ class Event : public BaseEvent
+ {
+ public:
diff --git a/devel/wftk/files/patch-wftk::region.h b/devel/wftk/files/patch-wftk::region.h
new file mode 100644
index 000000000000..c1b6f280bdc6
--- /dev/null
+++ b/devel/wftk/files/patch-wftk::region.h
@@ -0,0 +1,11 @@
+--- wftk/region.h.orig Sat May 7 23:58:28 2005
++++ wftk/region.h Sun May 8 00:01:36 2005
+@@ -166,7 +166,7 @@
+ // const_iterator has to be declared after RegionBox
+
+ /// Iterator over points in the region
+- friend class const_iterator
++ class const_iterator
+ {
+ public:
+ const_iterator() : box_(0) {}
diff --git a/devel/wftk/files/patch-wftk::timer.h b/devel/wftk/files/patch-wftk::timer.h
new file mode 100644
index 000000000000..7fc5b055ba8d
--- /dev/null
+++ b/devel/wftk/files/patch-wftk::timer.h
@@ -0,0 +1,11 @@
+--- wftk/timer.h.orig Sat May 7 23:58:33 2005
++++ wftk/timer.h Sun May 8 00:03:52 2005
+@@ -184,7 +184,7 @@
+ static std::set<Timer*> runningTimers_;
+
+ typedef Application::FloatingEvent<Timer> BaseEvent;
+- friend class BaseEvent;
++ friend class Application::FloatingEvent<Timer>;
+ class Event : public BaseEvent
+ {
+ public:
diff --git a/devel/wftk/pkg-descr b/devel/wftk/pkg-descr
index 6333d6de5fb8..03621ec47631 100644
--- a/devel/wftk/pkg-descr
+++ b/devel/wftk/pkg-descr
@@ -1,6 +1,8 @@
-libuta is a Graphical User Interface library for C++ that uses SDL
+wftk is a Graphical User Interface library for C++ that uses SDL
as its output layer. It allows application and game programmers to
-put together portable graphical applications easily. libuta has a
+put together portable graphical applications easily. wftk has a
range of already implemented widgets and uses libsigc++ as a signal
dispatching system. It also performs resource management and has a
sound system.
+
+WWW: http://www.worldforge.org/dev/eng/libraries/wftk
diff --git a/devel/wftk/pkg-plist b/devel/wftk/pkg-plist
index 7752b4e5a07f..467a228cb29e 100644
--- a/devel/wftk/pkg-plist
+++ b/devel/wftk/pkg-plist
@@ -1,54 +1,68 @@
-bin/uta-config
-lib/libuta.so
-lib/libuta-0.4.so.2
-lib/libuta.a
-include/uta/debug.h
-include/uta/color.h
-include/uta/point.h
-include/uta/rect.h
-include/uta/keysym.h
-include/uta/event.h
-include/uta/shared.h
-include/uta/pixelformat.h
-include/uta/painter.h
-include/uta/progressdialog.h
-include/uta/logo.h
-include/uta/logo_data.h
-include/uta/terminal.h
-include/uta/directsurface.h
-include/uta/mutex.h
-include/uta/version.h
-include/uta/uta.h
-include/uta/timer.h
-include/uta/dialogbox.h
-include/uta/messagebox.h
-include/uta/questionbox.h
-include/uta/blitters.h
-include/uta/mmx.h
-include/uta/application.h
-include/uta/button.h
-include/uta/dialog.h
-include/uta/focus.h
-include/uta/font.h
-include/uta/label.h
-include/uta/lineedit.h
-include/uta/listbox.h
-include/uta/mixer.h
-include/uta/mouse.h
-include/uta/mouse_data.h
-include/uta/movie.h
-include/uta/multilineedit.h
-include/uta/music.h
-include/uta/pushbutton.h
-include/uta/resources.h
-include/uta/rootwindow.h
-include/uta/sample.h
-include/uta/screensurface.h
-include/uta/slider.h
-include/uta/sound.h
-include/uta/soundmapper.h
-include/uta/surface.h
-include/uta/togglebutton.h
-include/uta/widget.h
-share/aclocal/uta.m4
-@dirrm include/uta
+include/wftk-0.7/wftk/debug.h
+include/wftk-0.7/wftk/debug_timer.h
+include/wftk-0.7/wftk/color.h
+include/wftk-0.7/wftk/point.h
+include/wftk-0.7/wftk/rect.h
+include/wftk-0.7/wftk/region.h
+include/wftk-0.7/wftk/keysym.h
+include/wftk-0.7/wftk/pixelformat.h
+include/wftk-0.7/wftk/painter.h
+include/wftk-0.7/wftk/surface.h
+include/wftk-0.7/wftk/screensurface.h
+include/wftk-0.7/wftk/font.h
+include/wftk-0.7/wftk/ref_map.h
+include/wftk-0.7/wftk/refobj.h
+include/wftk-0.7/wftk/focus.h
+include/wftk-0.7/wftk/screenarea.h
+include/wftk-0.7/wftk/widget.h
+include/wftk-0.7/wftk/singlecontainer.h
+include/wftk-0.7/wftk/cornercontainer.h
+include/wftk-0.7/wftk/box.h
+include/wftk-0.7/wftk/table.h
+include/wftk-0.7/wftk/filler.h
+include/wftk-0.7/wftk/movie.h
+include/wftk-0.7/wftk/rootwindow.h
+include/wftk-0.7/wftk/application.h
+include/wftk-0.7/wftk/resources.h
+include/wftk-0.7/wftk/dialog.h
+include/wftk-0.7/wftk/bordereddialog.h
+include/wftk-0.7/wftk/mouse.h
+include/wftk-0.7/wftk/pointer.h
+include/wftk-0.7/wftk/joystick.h
+include/wftk-0.7/wftk/label.h
+include/wftk-0.7/wftk/button.h
+include/wftk-0.7/wftk/pushbutton.h
+include/wftk-0.7/wftk/togglebutton.h
+include/wftk-0.7/wftk/lineedit.h
+include/wftk-0.7/wftk/multilineedit.h
+include/wftk-0.7/wftk/slider.h
+include/wftk-0.7/wftk/listbox.h
+include/wftk-0.7/wftk/sound.h
+include/wftk-0.7/wftk/sample.h
+include/wftk-0.7/wftk/music.h
+include/wftk-0.7/wftk/mixer.h
+include/wftk-0.7/wftk/video.h
+include/wftk-0.7/wftk/videowidget.h
+include/wftk-0.7/wftk/progressdialog.h
+include/wftk-0.7/wftk/terminal.h
+include/wftk-0.7/wftk/mutex.h
+include/wftk-0.7/wftk/wftk.h
+include/wftk-0.7/wftk/timer.h
+include/wftk-0.7/wftk/poll.h
+include/wftk-0.7/wftk/sdlhandler.h
+include/wftk-0.7/wftk/eventqueue.h
+include/wftk-0.7/wftk/messagebox.h
+include/wftk-0.7/wftk/questionbox.h
+include/wftk-0.7/wftk/fullscreendialog.h
+include/wftk-0.7/wftk/fixeddialog.h
+include/wftk-0.7/wftk/marshal.h
+include/wftk-0.7/wftk/mapinit.h
+include/wftk-0.7/wftk/string_hash_map.h
+include/wftk-0.7/wftk/version.h
+lib/libwftk-0.7.so.2
+lib/libwftk-0.7.so
+lib/libwftk-0.7.a
+libdata/pkgconfig/wftk-0.7.pc
+@dirrm include/wftk-0.7/wftk
+@dirrm include/wftk-0.7
+@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true