aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-funionfs/Makefile37
-rw-r--r--sysutils/fusefs-funionfs/distinfo3
-rw-r--r--sysutils/fusefs-funionfs/pkg-descr6
4 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9b9798942bff..cd811bad746f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -186,6 +186,7 @@
SUBDIR += fsbackup
SUBDIR += ftrace
SUBDIR += fusefs-curlftpfs
+ SUBDIR += fusefs-funionfs
SUBDIR += fusefs-kmod
SUBDIR += fusefs-libs
SUBDIR += fusefs-sshfs
diff --git a/sysutils/fusefs-funionfs/Makefile b/sysutils/fusefs-funionfs/Makefile
new file mode 100644
index 000000000000..e93a14fad5c2
--- /dev/null
+++ b/sysutils/fusefs-funionfs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fusefs-funionfs
+# Date created: 2006-07-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= funionfs
+PORTVERSION= 0.4.1
+CATEGORIES= sysutils
+MASTER_SITES= http://funionfs.apiou.org/file/
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Union filesystem for the FUSE driver
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+
+PLIST_FILES= bin/funionfs
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -DFUSE_USE_VERSION=25 \
+ -D_FILE_OFFSET_BITS=64 -I${LOCALBASE}/include/fuse \
+ -o funionfs main.c \
+ -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/funionfs ${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 # Inherited from fusefs-kmod
+IGNORE= requires FreeBSD 6.x or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-funionfs/distinfo b/sysutils/fusefs-funionfs/distinfo
new file mode 100644
index 000000000000..5e16d69960c9
--- /dev/null
+++ b/sysutils/fusefs-funionfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (funionfs-0.4.1.tar.gz) = 373b74fdf280f2dcd646e79f7ac84ca0
+SHA256 (funionfs-0.4.1.tar.gz) = 6192c14b6ab34e8dac331f93997c4ea27f4705276aab0230363a4e83536b967a
+SIZE (funionfs-0.4.1.tar.gz) = 23698
diff --git a/sysutils/fusefs-funionfs/pkg-descr b/sysutils/fusefs-funionfs/pkg-descr
new file mode 100644
index 000000000000..6b4b8bdf2ca9
--- /dev/null
+++ b/sysutils/fusefs-funionfs/pkg-descr
@@ -0,0 +1,6 @@
+FunionFS means an Union filesystem for the FUSE driver.
+
+This program works only with the Fuse driver which is natively
+included since the 2.6.14 Linux kernel.
+
+WWW: http://funionfs.apiou.org/