aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/gpass/Makefile35
-rw-r--r--security/gpass/distinfo3
-rw-r--r--security/gpass/pkg-descr19
-rw-r--r--security/gpass/pkg-plist17
5 files changed, 75 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 00c6369357b1..19c73dc42cf3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -150,6 +150,7 @@
SUBDIR += gorilla
SUBDIR += gpa
SUBDIR += gpasman
+ SUBDIR += gpass
SUBDIR += gpgme
SUBDIR += gpgme03
SUBDIR += gringotts
diff --git a/security/gpass/Makefile b/security/gpass/Makefile
new file mode 100644
index 000000000000..bc7763cf2407
--- /dev/null
+++ b/security/gpass/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gpass
+# Date created: 2006-07-24
+# Whom: ports@c0decafe.net <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpass
+PORTVERSION= 0.5.1
+CATEGORIES= security gnome
+MASTER_SITES= http://projects.netlab.jp/gpass/release/
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= A password manager for GNOME2
+
+LIB_DEPENDS= mcrypt:${PORTSDIR}/security/mcrypt \
+ mhash:${PORTSDIR}/security/mhash
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -export-dynamic"
+USE_GMAKE= yes
+
+MAN1= gpass.1 gpass.ja.1 gpass-convert.1 gpass-convert.ja.1
+
+USE_GNOME= gtk20 libgnomeui intltool libglade2
+GCONF_SCHEMAS= gpass.schemas
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/gpass/distinfo b/security/gpass/distinfo
new file mode 100644
index 000000000000..636d239c9eb4
--- /dev/null
+++ b/security/gpass/distinfo
@@ -0,0 +1,3 @@
+MD5 (gpass-0.5.1.tar.gz) = f7144c5b3b2056d6f33d8dbf1011a211
+SHA256 (gpass-0.5.1.tar.gz) = 0a8216538144e34188e07bcc9f0415c36702fcb90890ddfbf75a594e5864a881
+SIZE (gpass-0.5.1.tar.gz) = 512614
diff --git a/security/gpass/pkg-descr b/security/gpass/pkg-descr
new file mode 100644
index 000000000000..8286a1124862
--- /dev/null
+++ b/security/gpass/pkg-descr
@@ -0,0 +1,19 @@
+The GNOME Password Manager - GPass for short - is a simple
+application, written for the GNOME 2 desktop, that lets you manage a
+collection of passwords. The password collection is stored in an
+encrypted file, protected by a master-password.
+
+GPass is released under the GNU GPL2 licence.
+
+Features:
+
+ * Clean and easy-to-use user interface.
+ * Quick-search facility.
+ * Username and password may easily be copied to the clipboard.
+ * Encryption is done using the OpenSSL cryptographics library.
+ * The built-in password generator helps you generate secure passwords.
+ * You can launch a website and the associated username/passwords
+ direct from GPass
+
+Author: Kouji TAKAO <kouji -at- netlab.jp>
+WWW: http://projects.netlab.jp/gpass/
diff --git a/security/gpass/pkg-plist b/security/gpass/pkg-plist
new file mode 100644
index 000000000000..b7ea851f88e6
--- /dev/null
+++ b/security/gpass/pkg-plist
@@ -0,0 +1,17 @@
+bin/gpass
+bin/gpass-convert
+share/applications/gpass.desktop
+%%DATADIR%%/welcome.glade
+%%DATADIR%%/intergradation.glade
+%%DATADIR%%/authentication.glade
+%%DATADIR%%/window.glade
+%%DATADIR%%/attribute-editor.glade
+%%DATADIR%%/confirm-quit.glade
+%%DATADIR%%/change-master-password.glade
+%%DATADIR%%/password-generator.glade
+%%DATADIR%%/preferences.glade
+%%DATADIR%%/lock.glade
+share/pixmaps/gpass-icon.png
+@dirrmtry share/pixmaps
+@dirrmtry share/applications
+@dirrm %%DATADIR%%