aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-API-Hooks/Makefile32
-rw-r--r--devel/p5-POE-API-Hooks/distinfo2
-rw-r--r--devel/p5-POE-API-Hooks/pkg-descr9
-rw-r--r--devel/p5-POE-API-Hooks/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index feb22d389a2f..8ceea8ec6435 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -896,6 +896,7 @@
SUBDIR += p5-PAR-Dist
SUBDIR += p5-PCSC-Card
SUBDIR += p5-POE
+ SUBDIR += p5-POE-API-Hooks
SUBDIR += p5-POE-API-Peek
SUBDIR += p5-POE-Component-Child
SUBDIR += p5-POE-Component-Client-HTTP
diff --git a/devel/p5-POE-API-Hooks/Makefile b/devel/p5-POE-API-Hooks/Makefile
new file mode 100644
index 000000000000..9f9805752aa4
--- /dev/null
+++ b/devel/p5-POE-API-Hooks/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: POE-API-Hooks
+# Date created: 17 October 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-API-Hooks
+PORTVERSION= 1.0404
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/SU/SUNGO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Implement lightweight hooks into POE
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::API::Hooks.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= "Perl 5.6.1 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-POE-API-Hooks/distinfo b/devel/p5-POE-API-Hooks/distinfo
new file mode 100644
index 000000000000..d661e05fc4cf
--- /dev/null
+++ b/devel/p5-POE-API-Hooks/distinfo
@@ -0,0 +1,2 @@
+MD5 (POE-API-Hooks-1.0404.tar.gz) = d4ef098ae48d15c5695efb2422c265e5
+SIZE (POE-API-Hooks-1.0404.tar.gz) = 4321
diff --git a/devel/p5-POE-API-Hooks/pkg-descr b/devel/p5-POE-API-Hooks/pkg-descr
new file mode 100644
index 000000000000..5a5f6ed65054
--- /dev/null
+++ b/devel/p5-POE-API-Hooks/pkg-descr
@@ -0,0 +1,9 @@
+This module adds lightweight hooks into the inner workings of POE.
+Currently, one can add hooks into POE that get called before/after an
+event is dispatched and/or before/after a Session is created. These
+callbacks receive the exact same argument list as their Kernel/Session
+counterpart. For event dispatch related callbacks, see _dispatch_event
+in POE::Kernel. For session related callbacks, see create in
+POE::Session.
+
+WWW: http://search.cpan.org/dist/POE-API-Hooks/
diff --git a/devel/p5-POE-API-Hooks/pkg-plist b/devel/p5-POE-API-Hooks/pkg-plist
new file mode 100644
index 000000000000..1afe4b66eb0d
--- /dev/null
+++ b/devel/p5-POE-API-Hooks/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/API/Hooks/.packlist
+%%SITE_PERL%%/POE/API/Hooks.pm
+@unexec rmdir %D/%%SITE_PERL%%/POE/API 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/API/Hooks
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/API 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true