aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/pure-ftpd/Makefile4
-rw-r--r--mail/courier-imap/Makefile4
-rw-r--r--security/pam-pgsql/Makefile6
-rw-r--r--www/nspostgres/Makefile4
-rw-r--r--www/pgdriver/Makefile5
-rw-r--r--www/udmsearch/Makefile4
6 files changed, 20 insertions, 7 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index 73e7cb2e74e8..fc7b5a9268da 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pure-ftpd
PORTVERSION= 1.0.13a
+PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/ \
ftp://ftp2.fr.pureftpd.org/pub/mirrors/ftp.fr.pureftpd.org/pub/pure-ftpd/releases/ \
@@ -30,7 +31,8 @@ LIB_DEPENDS+= mysqlclient:${PORTSDIR}/databases/mysql323-client
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.endif
GNU_CONFIGURE= yes
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 7a6c14effb87..9b09d7793676 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= courier-imap
PORTVERSION= 1.6.1
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
@@ -91,7 +92,8 @@ PLIST_SUB+= MYSQLFLAG=""
CONFIGURE_ARGS+= --without-authpgsql
PLIST_SUB+= PGSQLFLAG="@comment "
.else
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
PLIST_SUB+= PGSQLFLAG=""
.endif
diff --git a/security/pam-pgsql/Makefile b/security/pam-pgsql/Makefile
index bc441b275876..f240f826b9c6 100644
--- a/security/pam-pgsql/Makefile
+++ b/security/pam-pgsql/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pam-pgsql
PORTVERSION= 0.5.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security databases
MASTER_SITES= ${MASTER_SITE_DEBIAN} \
http://libpam-pgsql.codecastle.com/${PORTNAME}-${PORTVERSION}-${PORTREVISION}/
@@ -19,7 +19,9 @@ PATCH_SITES= ${MASTER_SITES}
MAINTAINER= m@absolight.fr
-LIB_DEPENDS= pq:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
PATCH_DIST_STRIP= -p1
# When the family of Debian mirrors is added to bsd.port.mk,
diff --git a/www/nspostgres/Makefile b/www/nspostgres/Makefile
index 42fc1ae1d54b..23428f5d7db3 100644
--- a/www/nspostgres/Makefile
+++ b/www/nspostgres/Makefile
@@ -15,9 +15,11 @@ DISTNAME= nspostgres3_0
MAINTAINER= jkoshy@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver \
- ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql7
+ ${LOCALBASE}/bin/postmaster:${PORTSDIR}/${POSTGRESQL_PORT}
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
WRKSRC= ${WRKDIR}/nspostgres
USE_GMAKE= yes
diff --git a/www/pgdriver/Makefile b/www/pgdriver/Makefile
index 3da44edd817b..827147becad9 100644
--- a/www/pgdriver/Makefile
+++ b/www/pgdriver/Makefile
@@ -7,16 +7,19 @@
PORTNAME= pgdriver
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://openacs.org/sdm/download-package/2/38/
EXTRACT_SUFX= .tgz
MAINTAINER= jkoshy@freebsd.org
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
BUILD_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
MAKEFILE= makefile
MAKE_ENV+= PREFIX=${PREFIX}
diff --git a/www/udmsearch/Makefile b/www/udmsearch/Makefile
index 0434c90e78c3..b76d31cdf681 100644
--- a/www/udmsearch/Makefile
+++ b/www/udmsearch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= udmsearch
PORTVERSION= 3.0.23
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://mysearch.udm.net/Download/ \
ftp://ftp.izhcom.ru/pub/unix/UdmSearch/ \
@@ -25,7 +26,8 @@ CONFIGURE_ARGS= --enable-charset-guesser \
--localstatedir=/var/udmsearch
.if defined(WITH_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql
.elif defined(WITH_MSQL)