aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Event-NameDay/Makefile35
-rw-r--r--devel/p5-DateTime-Event-NameDay/distinfo1
-rw-r--r--devel/p5-DateTime-Event-NameDay/pkg-descr5
-rw-r--r--devel/p5-DateTime-Event-NameDay/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9fe698697736..2e6f4c9adefe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -551,6 +551,7 @@
SUBDIR += p5-DateTime-Event-Cron
SUBDIR += p5-DateTime-Event-Easter
SUBDIR += p5-DateTime-Event-ICal
+ SUBDIR += p5-DateTime-Event-NameDay
SUBDIR += p5-DateTime-Event-Recurrence
SUBDIR += p5-DateTime-LeapSecond
SUBDIR += p5-DateTime-Precise
diff --git a/devel/p5-DateTime-Event-NameDay/Makefile b/devel/p5-DateTime-Event-NameDay/Makefile
new file mode 100644
index 000000000000..b9bd7034e44f
--- /dev/null
+++ b/devel/p5-DateTime-Event-NameDay/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-DateTime-Event-NameDay
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Event-NameDay
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Perl DateTime extension to work with namedays from various countries
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set \
+ ${SITE_PERL}/DateTime/Calendar/Christian.pm:${PORTSDIR}/devel/p5-DateTime-Calendar-Christian \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+# Depends on p5-DateTime-Set which requires perl >= 5.6
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Event-NameDay/distinfo b/devel/p5-DateTime-Event-NameDay/distinfo
new file mode 100644
index 000000000000..e91c42e98a60
--- /dev/null
+++ b/devel/p5-DateTime-Event-NameDay/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Event-NameDay-0.02.tar.gz) = e7f8d68163c6a0a8fd3fae866a36deae
diff --git a/devel/p5-DateTime-Event-NameDay/pkg-descr b/devel/p5-DateTime-Event-NameDay/pkg-descr
new file mode 100644
index 000000000000..fb70f11867a1
--- /dev/null
+++ b/devel/p5-DateTime-Event-NameDay/pkg-descr
@@ -0,0 +1,5 @@
+DateTime::Event::NameDay is a class that knows the name days for various
+countries. In some countries a person's nameday is more important than their
+birthday and gifts may be exchanged.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Event-NameDay/pkg-plist b/devel/p5-DateTime-Event-NameDay/pkg-plist
new file mode 100644
index 000000000000..b7c8893a2cc7
--- /dev/null
+++ b/devel/p5-DateTime-Event-NameDay/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/DateTime/Event/NameDay.pm
+%%SITE_PERL%%/DateTime/Event/NameDay/sweden.pm
+%%SITE_PERL%%/DateTime/Event/NameDay/slovakia.pm
+%%SITE_PERL%%/DateTime/Event/NameDay/france.pm
+%%SITE_PERL%%/DateTime/Event/NameDay/greece.pm
+@dirrm %%SITE_PERL%%/DateTime/Event/NameDay
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Event 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true