aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/mame-devel/Makefile3
-rw-r--r--emulators/mame/Makefile3
-rw-r--r--emulators/mess/Makefile3
-rw-r--r--emulators/sdlmame-devel/Makefile3
-rw-r--r--emulators/sdlmame/Makefile3
-rw-r--r--emulators/sdlmess/Makefile3
6 files changed, 18 insertions, 0 deletions
diff --git a/emulators/mame-devel/Makefile b/emulators/mame-devel/Makefile
index ac3befc2d47e..9850695402b3 100644
--- a/emulators/mame-devel/Makefile
+++ b/emulators/mame-devel/Makefile
@@ -42,6 +42,9 @@ EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
.if ${ARCH} == "amd64"
MAKE_ENV+= PTR64=1
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index ac3befc2d47e..9850695402b3 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -42,6 +42,9 @@ EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
.if ${ARCH} == "amd64"
MAKE_ENV+= PTR64=1
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 35844a03e9b8..0cc12ced66b7 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -41,6 +41,9 @@ EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
.if ${ARCH} == "amd64"
MAKE_ENV+= PTR64=1
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
diff --git a/emulators/sdlmame-devel/Makefile b/emulators/sdlmame-devel/Makefile
index ac3befc2d47e..9850695402b3 100644
--- a/emulators/sdlmame-devel/Makefile
+++ b/emulators/sdlmame-devel/Makefile
@@ -42,6 +42,9 @@ EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
.if ${ARCH} == "amd64"
MAKE_ENV+= PTR64=1
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
diff --git a/emulators/sdlmame/Makefile b/emulators/sdlmame/Makefile
index ac3befc2d47e..9850695402b3 100644
--- a/emulators/sdlmame/Makefile
+++ b/emulators/sdlmame/Makefile
@@ -42,6 +42,9 @@ EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
.if ${ARCH} == "amd64"
MAKE_ENV+= PTR64=1
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index 35844a03e9b8..0cc12ced66b7 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -41,6 +41,9 @@ EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
.if ${ARCH} == "amd64"
MAKE_ENV+= PTR64=1
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c