aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--shells/bash/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 7676ba0a9206..f390fc18e339 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -56,6 +56,16 @@ CONFIGURE_ARGS= --without-bash-malloc \
--disable-rpath \
--enable-disabled-builtins
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ${NOSHARED:L} != "no")
+.if !defined(WITHOUT_NLS)
+WITHOUT_NLS=yes
+.endif
+CONFIGURE_ARGS+= --enable-static-link
+PKGNAMESUFFIX= -static
+.else
+CONFIGURE_ARGS+= --enable-static-link=no
+.endif
+
.if defined(WITHOUT_HELP)
CONFIGURE_ARGS+= --disable-help-builtin
PLIST_SUB+= HELP="@comment "