aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/forth/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/forth/Makefile b/lang/forth/Makefile
index 020fa2c2d194..9f7200ef81d6 100644
--- a/lang/forth/Makefile
+++ b/lang/forth/Makefile
@@ -24,6 +24,12 @@ CONFIGURE_ARGS= --disable-float
MAN1= pfe.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "sparc64"
+BROKEN= "Does not compile on !i386 and !sparc64"
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/../doc/pfe.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@@ -31,4 +37,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/../doc/*.html ${PREFIX}/share/doc/pfe
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>