aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/ruby-search-namazu/Makefile8
-rw-r--r--devel/ruby-bsearch/Makefile6
-rw-r--r--devel/ruby-cvs/Makefile10
-rw-r--r--devel/ruby-gemfinder/Makefile7
-rw-r--r--devel/ruby-mmap/Makefile6
-rw-r--r--devel/ruby-sdl/Makefile6
-rw-r--r--devel/ruby-sysvipc/Makefile6
-rw-r--r--devel/ruby-tzfile/Makefile6
-rw-r--r--devel/ruby-unit/Makefile4
-rw-r--r--graphics/ruby-evas/Makefile4
-rw-r--r--graphics/ruby-gd/Makefile4
-rw-r--r--graphics/ruby-image_size/Makefile8
-rw-r--r--graphics/ruby-libpng/Makefile6
-rw-r--r--japanese/rbnamazu/Makefile6
-rw-r--r--japanese/ruby-romkan/Makefile6
-rw-r--r--net/ruby-drb/Makefile8
-rw-r--r--print/ruby-pdflib/Makefile6
-rw-r--r--security/ruby-acl/Makefile7
-rw-r--r--textproc/eruby/Makefile6
-rw-r--r--www/mod_ruby/Makefile4
20 files changed, 41 insertions, 83 deletions
diff --git a/databases/ruby-search-namazu/Makefile b/databases/ruby-search-namazu/Makefile
index 454dd79d4e4b..b95a8bc828ed 100644
--- a/databases/ruby-search-namazu/Makefile
+++ b/databases/ruby-search-namazu/Makefile
@@ -19,16 +19,14 @@ LIB_DEPENDS= nmz.6:${PORTSDIR}/japanese/namazu2
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} search-namazu.en.rd > search-namazu.en.html
- cd ${WRKSRC}; ${RUBY_RD} search-namazu.ja.rd > search-namazu.ja.html
+ cd ${WRKSRC}; ${RUBY_RD2} search-namazu.en.rd > search-namazu.en.html
+ cd ${WRKSRC}; ${RUBY_RD2} search-namazu.ja.rd > search-namazu.ja.html
.endif
post-install:
diff --git a/devel/ruby-bsearch/Makefile b/devel/ruby-bsearch/Makefile
index 44dcbe8536f6..e84e89abaee2 100644
--- a/devel/ruby-bsearch/Makefile
+++ b/devel/ruby-bsearch/Makefile
@@ -16,9 +16,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
DOCS_EN= ChangeLog bsearch.en.html bsearch.en.rd
DOCS_JA= bsearch.ja.html bsearch.ja.rd
@@ -27,7 +25,7 @@ do-build:
.if !defined(NOPORTDOCS)
.for f in bsearch.en.rd bsearch.ja.rd
@cd ${WRKSRC}; \
- ${RUBY_RD} ${f} > ${f:R}.html
+ ${RUBY_RD2} ${f} > ${f:R}.html
.endfor
.endif
diff --git a/devel/ruby-cvs/Makefile b/devel/ruby-cvs/Makefile
index 467e6c6585f2..115c0e6f6ef2 100644
--- a/devel/ruby-cvs/Makefile
+++ b/devel/ruby-cvs/Makefile
@@ -19,9 +19,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/flex.so:${PORTSDIR}/devel/ruby-flex_rb
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_SHEBANG_FILES= ${WRKSRC}/viztree ${WRKSRC}/reviz/reviz
@@ -31,9 +29,9 @@ DOCS= README TODO cvs.html diff.html tempdir.html
do-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} lib/cvs.rb > cvs.html
- cd ${WRKSRC}; ${RUBY_RD} lib/diff.rb > diff.html
- cd ${WRKSRC}; ${RUBY_RD} lib/tempdir.rb > tempdir.html
+ cd ${WRKSRC}; ${RUBY_RD2} lib/cvs.rb > cvs.html
+ cd ${WRKSRC}; ${RUBY_RD2} lib/diff.rb > diff.html
+ cd ${WRKSRC}; ${RUBY_RD2} lib/tempdir.rb > tempdir.html
.endif
do-install:
diff --git a/devel/ruby-gemfinder/Makefile b/devel/ruby-gemfinder/Makefile
index 9ee995543ca8..08413b078a8e 100644
--- a/devel/ruby-gemfinder/Makefile
+++ b/devel/ruby-gemfinder/Makefile
@@ -18,10 +18,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_LIBDIR}/tk.rb:${PORTSDIR}/x11-toolkits/ruby-tk
USE_RUBY= yes
-
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_SHEBANG_FILES= ${WRKSRC}/gemfinder
@@ -29,7 +26,7 @@ DOCS= README gemfinder.html gemfinder.rd
do-build:
.if !defined(NOPORTDOCS)
- ${RUBY_RD} < ${WRKSRC}/gemfinder.rd \
+ ${RUBY_RD2} < ${WRKSRC}/gemfinder.rd \
| ${SED} -e 's/<BODY>/<body bgcolor="#ffffff">/' \
> ${WRKSRC}/gemfinder.html
.endif
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
index 53f2591cdc03..7dac75fc7e1f 100644
--- a/devel/ruby-mmap/Makefile
+++ b/devel/ruby-mmap/Makefile
@@ -20,9 +20,7 @@ BUILD_DEPENDS= rdoc:${PORTSDIR}/textproc/ruby-rdoc
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
@@ -32,7 +30,7 @@ EXAMPLES= b.rb
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} mmap.rd > mmap.html
+ cd ${WRKSRC}; ${RUBY_RD2} mmap.rd > mmap.html
cd ${WRKSRC}/docs; ${RUBY} b.rb mmap; rdoc mmap.rb
.endif
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index d9a8ba42bc6c..17467a043588 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -26,9 +26,7 @@ RUBY_OPENGL_WRKSRC_CMD= cd ${RUBY_OPENGL_PORTDIR}; ${MAKE} -V WRKSRC
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_WITH_PTHREAD= yes
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
@@ -57,7 +55,7 @@ post-patch:
post-build:
.if !defined(NOPORTDOCS)
.for f in ${RD_DOCS_EN} ${RD_DOCS_JA}
- @cd ${WRKSRC}; ${RUBY_RD} ${f} > ${f:S/.rd$/.html/}
+ @cd ${WRKSRC}; ${RUBY_RD2} ${f} > ${f:S/.rd$/.html/}
.endfor
.endif
diff --git a/devel/ruby-sysvipc/Makefile b/devel/ruby-sysvipc/Makefile
index 4265f8a2a2c8..2c637ec8ec0a 100644
--- a/devel/ruby-sysvipc/Makefile
+++ b/devel/ruby-sysvipc/Makefile
@@ -17,9 +17,7 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
@@ -27,7 +25,7 @@ DOCS= sysvipc.html sysvipc.rd
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} sysvipc.rd > sysvipc.html
+ cd ${WRKSRC}; ${RUBY_RD2} sysvipc.rd > sysvipc.html
.endif
post-install:
diff --git a/devel/ruby-tzfile/Makefile b/devel/ruby-tzfile/Makefile
index 41b7cbd4bd6c..3bc4748c992b 100644
--- a/devel/ruby-tzfile/Makefile
+++ b/devel/ruby-tzfile/Makefile
@@ -16,15 +16,13 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
do-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} tzfile.rb > tzfile.html
+ cd ${WRKSRC}; ${RUBY_RD2} tzfile.rb > tzfile.html
.endif
do-install:
diff --git a/devel/ruby-unit/Makefile b/devel/ruby-unit/Makefile
index a12717f5dd5c..d2cbfa805b5c 100644
--- a/devel/ruby-unit/Makefile
+++ b/devel/ruby-unit/Makefile
@@ -16,9 +16,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_SHEBANG_FILES= ${WRKSRC}/bin/c2t.rb \
${WRKSRC}/bin/runtest.rb
diff --git a/graphics/ruby-evas/Makefile b/graphics/ruby-evas/Makefile
index a99418cc80d3..609329b83de8 100644
--- a/graphics/ruby-evas/Makefile
+++ b/graphics/ruby-evas/Makefile
@@ -18,10 +18,8 @@ MAINTAINER= knu@FreeBSD.org
LIB_DEPENDS= evas.6:${PORTSDIR}/graphics/evas
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
USE_RUBY_EXTCONF= yes
+USE_RUBY_RDTOOL= yes
CONFIGURE_WRKSRC= ${WRKSRC}/src
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index 76f2fb822f1d..8b329b5fd347 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -22,9 +22,7 @@ LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
CONFIGURE_ARGS= --with-gd-include="${LOCALBASE}/include/gd" \
--with-gd-lib="${LOCALBASE}/lib" \
diff --git a/graphics/ruby-image_size/Makefile b/graphics/ruby-image_size/Makefile
index f5101a099a35..90c8094d0ff0 100644
--- a/graphics/ruby-image_size/Makefile
+++ b/graphics/ruby-image_size/Makefile
@@ -17,9 +17,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -29,9 +27,9 @@ DOCS_JA= readme.ja.rd readme.ja.html
do-build:
.if !defined(NOPORTDOCS)
@cd ${WRKSRC}; \
- ${RUBY_RD} image_size.rb > readme.en.html
+ ${RUBY_RD2} image_size.rb > readme.en.html
@cd ${WRKSRC}; \
- ${RUBY_RD} readme.ja.rd > readme.ja.html
+ ${RUBY_RD2} readme.ja.rd > readme.ja.html
.endif
do-install:
diff --git a/graphics/ruby-libpng/Makefile b/graphics/ruby-libpng/Makefile
index 824bf0d2155c..38e134b7c41d 100644
--- a/graphics/ruby-libpng/Makefile
+++ b/graphics/ruby-libpng/Makefile
@@ -22,9 +22,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
@@ -37,7 +35,7 @@ EXAMPLES_EN= es.png png.rb pngtest.rb pngtest.sh \
.if !defined(NOPORTDOCS)
post-build:
@cd ${WRKSRC}; \
- ${RUBY_RD} readme.ja.rd > readme.ja.html
+ ${RUBY_RD2} readme.ja.rd > readme.ja.html
.endif
post-install:
diff --git a/japanese/rbnamazu/Makefile b/japanese/rbnamazu/Makefile
index fb861eaa08e5..faf8cb04d8b8 100644
--- a/japanese/rbnamazu/Makefile
+++ b/japanese/rbnamazu/Makefile
@@ -15,9 +15,7 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_FEATURES= optparse
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
NO_BUILD= yes
@@ -33,7 +31,7 @@ do-install:
.if !defined(NOPORTDOCS)
.for f in ${RD_DOCS}
cd ${WRKSRC}; \
- ${RUBY_RD} ${f} > ${f:S/.rd/.html/}
+ ${RUBY_RD2} ${f} > ${f:S/.rd/.html/}
.endfor
${MKDIR} ${RUBY_DOCDIR}/rbnamazu/ja
.for f in ${RD_DOCS:S/.rd/.html/:M*.en}
diff --git a/japanese/ruby-romkan/Makefile b/japanese/ruby-romkan/Makefile
index bdf3abd1e11a..ba62d7fc36c0 100644
--- a/japanese/ruby-romkan/Makefile
+++ b/japanese/ruby-romkan/Makefile
@@ -15,9 +15,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
EXAMPLES_JA= test.rb test.sh
DOCS_EN= ChangeLog romkan.en.html romkan.en.rd
@@ -31,7 +29,7 @@ do-build:
.if !defined(NOPORTDOCS)
.for f in romkan.en.rd romkan.ja.rd
@cd ${WRKSRC}; \
- ${RUBY_RD} ${f} > ${f:R}.html
+ ${RUBY_RD2} ${f} > ${f:R}.html
.endfor
.endif
diff --git a/net/ruby-drb/Makefile b/net/ruby-drb/Makefile
index 6aab0fc6ff10..a9b2fa8a87e4 100644
--- a/net/ruby-drb/Makefile
+++ b/net/ruby-drb/Makefile
@@ -18,9 +18,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITELIBDIR}/acl.rb:${PORTSDIR}/security/ruby-acl
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
post-extract:
${MKDIR} ${WRKSRC}/acl/doc ${WRKSRC}/acl/lib ${WRKSRC}/acl/runit
@@ -40,10 +38,10 @@ post-patch:
do-build:
.if !defined(NOPORTDOCS)
cd ${WRKSRC}/doc; for f in *.rd; do \
- ${RUBY_RD} $$f > `${ECHO_CMD} $$f | ${SED} 's/\.rd$$/.html/'`; \
+ ${RUBY_RD2} $$f > `${ECHO_CMD} $$f | ${SED} 's/\.rd$$/.html/'`; \
done
cd ${WRKSRC}/doc; for f in *.rd.ja; do \
- ${RUBY_RD} $$f > `${ECHO_CMD} $$f | ${SED} 's/\.rd.ja$$/.ja.html/'`; \
+ ${RUBY_RD2} $$f > `${ECHO_CMD} $$f | ${SED} 's/\.rd.ja$$/.ja.html/'`; \
done
${MKDIR} ${WRKSRC}/doc/ja
cd ${WRKSRC}/doc; ${MV} *.rd.ja *.ja.html ja/
diff --git a/print/ruby-pdflib/Makefile b/print/ruby-pdflib/Makefile
index 6880c766d070..679386fd4ab5 100644
--- a/print/ruby-pdflib/Makefile
+++ b/print/ruby-pdflib/Makefile
@@ -22,9 +22,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALL_TARGET= site-install
@@ -43,7 +41,7 @@ post-build:
.if !defined(NOPORTDOCS)
.for f in ${RD_DOCS_EN} ${RD_DOCS_JA}
cd ${WRKSRC}; \
- ${RUBY_RD} ${f} > ${f:S/.rd/.html/}
+ ${RUBY_RD2} ${f} > ${f:S/.rd/.html/}
.endfor
.endif
diff --git a/security/ruby-acl/Makefile b/security/ruby-acl/Makefile
index c4091c761189..5afba8fa5053 100644
--- a/security/ruby-acl/Makefile
+++ b/security/ruby-acl/Makefile
@@ -15,16 +15,13 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
do-build:
.if !defined(NOPORTDOCS)
.for f in acl.rd acl.rd.ja
@cd ${WRKSRC}/doc; \
- ${RUBY_RD} ${f} > ${f:S/.rd/.html/}
+ ${RUBY_RD2} ${f} > ${f:S/.rd/.html/}
.endfor
.endif
diff --git a/textproc/eruby/Makefile b/textproc/eruby/Makefile
index f765a8198348..3c3aedbc9124 100644
--- a/textproc/eruby/Makefile
+++ b/textproc/eruby/Makefile
@@ -14,9 +14,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
CONFIGURE_ARGS= --enable-shared --with-charset="${DEFAULT_CHARSET}"
INSTALL_TARGET= site-install
@@ -34,7 +32,7 @@ do-configure:
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} eruby.rd > eruby.html
+ cd ${WRKSRC}; ${RUBY_RD2} eruby.rd > eruby.html
.endif
post-install:
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index 24872b47d25e..3d1cd21936a5 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -18,9 +18,7 @@ LIB_DEPENDS= eruby.09:${PORTSDIR}/textproc/eruby
RUN_DEPENDS= ${APXS}:${APACHE_PORT}
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
APXS?= ${LOCALBASE}/sbin/apxs
APACHE_PORT?= ${PORTSDIR}/www/apache13