aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/gtkmathview/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-toolkits/gtkmathview/Makefile b/x11-toolkits/gtkmathview/Makefile
index c08c456a4dea..96615a631a59 100644
--- a/x11-toolkits/gtkmathview/Makefile
+++ b/x11-toolkits/gtkmathview/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gtkmathview
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= http://helm.cs.unibo.it/mml-widget/sources/
@@ -15,19 +16,20 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A GTK Widget to Render MathML Documents
LIB_DEPENDS= iconv:${PORTSDIR}/converters/libiconv \
- gnugetopt:${PORTSDIR}/devel/libgnugetopt \
t1:${PORTSDIR}/devel/t1lib \
xml2:${PORTSDIR}/textproc/libxml2 \
gmetadom_gdome_cpp_smart:${PORTSDIR}/textproc/gmetadom
-BROKEN= "Configure fails"
+BROKEN= "Configure fails"
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= glib12 gtk12
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-D__GNU_LIBRARY__ -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lm"
+CPPFLAGS= -D__GNU_LIBRARY__ -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -lm
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_GMAKE= yes
INSTALLS_SHLIB= yes