aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/v4l_compat/Makefile1
-rw-r--r--multimedia/v4l_compat/files/patch-videodev2.h35
2 files changed, 36 insertions, 0 deletions
diff --git a/multimedia/v4l_compat/Makefile b/multimedia/v4l_compat/Makefile
index 17f6227f1580..5152cda34ce5 100644
--- a/multimedia/v4l_compat/Makefile
+++ b/multimedia/v4l_compat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= v4l_compat
PORTVERSION= 1.0.${DUMMYDATE}
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= LOCAL/kwm
DUMMYDATE= 20101027
diff --git a/multimedia/v4l_compat/files/patch-videodev2.h b/multimedia/v4l_compat/files/patch-videodev2.h
new file mode 100644
index 000000000000..0fc1fa6ae0ce
--- /dev/null
+++ b/multimedia/v4l_compat/files/patch-videodev2.h
@@ -0,0 +1,35 @@
+--- videodev2.h.orig 2011-01-07 14:10:29.000000000 +0100
++++ videodev2.h 2011-01-07 14:11:23.000000000 +0100
+@@ -62,16 +62,32 @@
+
+ #ifndef HAVE_LINUX_INTEGER_TYPES
+ /* XXX remove when depending software has been updated */
++#ifndef __u64
+ typedef uint64_t __u64;
++#endif
++#ifndef __u32
+ typedef uint32_t __u32;
++#endif
++#ifndef __u16
+ typedef uint16_t __u16;
++#endif
++#ifndef __u8
+ typedef uint8_t __u8;
++#endif
+
++#ifndef __s64
+ typedef int64_t __s64;
++#endif
++#ifndef __s32
+ typedef int32_t __s32;
++#endif
++#ifndef __s16
+ typedef int16_t __s16;
++#endif
++#ifndef __s8
+ typedef int8_t __s8;
+ #endif
++#endif
+
+ /*
+ * Common stuff for both V4L1 and V4L2