aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/kompmgr/Makefile46
-rw-r--r--x11-wm/kompmgr/distinfo2
-rw-r--r--x11-wm/kompmgr/pkg-descr1
4 files changed, 50 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 10ed4e3a1a99..aa0788b6a1c2 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -57,6 +57,7 @@
SUBDIR += jewel
SUBDIR += kahakai
SUBDIR += kappdock
+ SUBDIR += kompmgr
SUBDIR += larswm
SUBDIR += libdockapp
SUBDIR += libepplet
diff --git a/x11-wm/kompmgr/Makefile b/x11-wm/kompmgr/Makefile
new file mode 100644
index 000000000000..85594924f9ed
--- /dev/null
+++ b/x11-wm/kompmgr/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: mpeglib_artsplug
+# Date created: July 09 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kompmgr
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= x11-wm kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+PKGNAMEPREFIX= kdebase-
+DISTNAME= kdebase-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Utility needed to enable XComposite support in KDE
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/kdebase-${PORTVERSION}
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS+=--without-java
+
+PLIST_FILES= bin/kompmgr
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xorg
+IGNORE= Requires the composite extension, which is unavailable with XFree86
+.endif
+
+do-build:
+ cd ${WRKSRC}/kwin/kompmgr && ${GMAKE}
+
+do-install:
+ cd ${WRKSRC}/kwin/kompmgr && ${GMAKE} install
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.post.mk>
diff --git a/x11-wm/kompmgr/distinfo b/x11-wm/kompmgr/distinfo
new file mode 100644
index 000000000000..7a5b5d02fcce
--- /dev/null
+++ b/x11-wm/kompmgr/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdebase-3.4.0.tar.bz2) = c88659e558ca98dc45377bf8ddfc26c9
+SIZE (KDE/kdebase-3.4.0.tar.bz2) = 22670772
diff --git a/x11-wm/kompmgr/pkg-descr b/x11-wm/kompmgr/pkg-descr
new file mode 100644
index 000000000000..ee85188c21cf
--- /dev/null
+++ b/x11-wm/kompmgr/pkg-descr
@@ -0,0 +1 @@
+Utility needed to enable XComposite support in KDE.