aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/wmweather/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/misc/wmweather/Makefile b/misc/wmweather/Makefile
index 18c8d47ae65d..8ee6b76320e8 100644
--- a/misc/wmweather/Makefile
+++ b/misc/wmweather/Makefile
@@ -16,9 +16,9 @@ LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= xmessage:${X_CLIENTS_PORT}
RUN_DEPENDS= xmessage:${X_CLIENTS_PORT}
-LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_GMAKE= yes
USE_GETOPT_LONG=yes