aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/ruby-drb/Makefile10
-rw-r--r--net/ruby-xmlrpc/Makefile2
-rw-r--r--print/ruby-panda/Makefile2
-rw-r--r--textproc/ruby-nqxml/Makefile2
-rw-r--r--textproc/ruby-rdtool/Makefile2
-rw-r--r--textproc/ruby-rexml/Makefile2
6 files changed, 10 insertions, 10 deletions
diff --git a/net/ruby-drb/Makefile b/net/ruby-drb/Makefile
index 82c0dfbf2774..426e65db00da 100644
--- a/net/ruby-drb/Makefile
+++ b/net/ruby-drb/Makefile
@@ -24,13 +24,13 @@ USE_RUBY_RD= yes
post-extract:
${MKDIR} ${WRKSRC}/acl/doc ${WRKSRC}/acl/lib ${WRKSRC}/acl/runit
- cd ${WRKSRC} && for f in */acl*; do ${MV} $$f ${WRKSRC}/acl/$$f; done
+ cd ${WRKSRC}; for f in */acl*; do ${MV} $$f ${WRKSRC}/acl/$$f; done
${MKDIR} ${WRKSRC}/sample/ja
${MV} ${WRKSRC}/sample/*.ja ${WRKSRC}/sample/ja/
post-patch:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}/doc && for f in drb-ref.rd*; do \
+ cd ${WRKSRC}/doc; for f in drb-ref.rd*; do \
${MV} $$f $$f.orig; \
( ${ECHO_CMD} '=begin'; ${CAT} $$f.orig; ${ECHO_CMD} '=end' ) > $$f; \
${RM} $$f.orig; \
@@ -39,14 +39,14 @@ post-patch:
do-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}/doc && for f in *.rd; do \
+ cd ${WRKSRC}/doc; for f in *.rd; do \
${RUBY_RD} $$f > `${ECHO_CMD} $$f | ${SED} 's/\.rd$$/.html/'`; \
done
- cd ${WRKSRC}/doc && for f in *.rd.ja; do \
+ cd ${WRKSRC}/doc; for f in *.rd.ja; do \
${RUBY_RD} $$f > `${ECHO_CMD} $$f | ${SED} 's/\.rd.ja$$/.ja.html/'`; \
done
${MKDIR} ${WRKSRC}/doc/ja
- cd ${WRKSRC}/doc && ${MV} *.rd.ja *.ja.html ja/
+ cd ${WRKSRC}/doc; ${MV} *.rd.ja *.ja.html ja/
.endif
do-install:
diff --git a/net/ruby-xmlrpc/Makefile b/net/ruby-xmlrpc/Makefile
index 305007dd82a4..07d16d5a7ccb 100644
--- a/net/ruby-xmlrpc/Makefile
+++ b/net/ruby-xmlrpc/Makefile
@@ -34,7 +34,7 @@ post-patch:
${RUBY} -i -pe '$$_ = "FILES2 = []\n" if /^FILES2\s*=/' ${WRKSRC}/install.rb
do-install:
- cd ${WRKSRC} && ${RUBY} install.rb
+ cd ${WRKSRC}; ${RUBY} install.rb
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
${CP} -R ${WRKSRC}/samples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
diff --git a/print/ruby-panda/Makefile b/print/ruby-panda/Makefile
index 1692c325d0b4..8e9e3b9a7973 100644
--- a/print/ruby-panda/Makefile
+++ b/print/ruby-panda/Makefile
@@ -40,7 +40,7 @@ post-install:
.for f in ${EXAMPLES_EN}
${INSTALL_DATA} ${WRKSRC}/examples/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
.endfor
- cd ${RUBY_EXAMPLESDIR}/${PORTNAME} && ${LN} -sf ../../panda/*.jpg ../../panda/*.png ../../panda/*.tif .
+ cd ${RUBY_EXAMPLESDIR}/${PORTNAME}; ${LN} -sf ../../panda/*.jpg ../../panda/*.png ../../panda/*.tif .
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
diff --git a/textproc/ruby-nqxml/Makefile b/textproc/ruby-nqxml/Makefile
index dbe75f3113d9..fbfa490a7905 100644
--- a/textproc/ruby-nqxml/Makefile
+++ b/textproc/ruby-nqxml/Makefile
@@ -22,7 +22,7 @@ NO_BUILD= yes
DOCS= ChangeLog README Credits TODO
do-install:
- cd ${WRKSRC} && ${RUBY} install.rb
+ cd ${WRKSRC}; ${RUBY} install.rb
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/dispatcher
${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
diff --git a/textproc/ruby-rdtool/Makefile b/textproc/ruby-rdtool/Makefile
index 225fbcd69bf0..36d17062f4ba 100644
--- a/textproc/ruby-rdtool/Makefile
+++ b/textproc/ruby-rdtool/Makefile
@@ -46,7 +46,7 @@ pre-build:
.if !defined(NOPORTDOCS)
post-build:
.for f in README.rd.ja doc/rd-draft.rd doc/rd-draft.rd.ja
- cd ${WRKSRC} && ${RUBY} -I. rd2 -r rd/rd2html-lib.rb ${f} \
+ cd ${WRKSRC}; ${RUBY} -I. rd2 -r rd/rd2html-lib.rb ${f} \
> ${f:S/.rd.ja$/.ja.html/:S/.rd$/.html/}
.endfor
.endif
diff --git a/textproc/ruby-rexml/Makefile b/textproc/ruby-rexml/Makefile
index bcaec8832d7e..0d7d607beb75 100644
--- a/textproc/ruby-rexml/Makefile
+++ b/textproc/ruby-rexml/Makefile
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
DOCS= README index.html docs/tutorial.html doc img
do-install:
- cd ${WRKSRC} && ${RUBY} bin/install.rb
+ cd ${WRKSRC}; ${RUBY} bin/install.rb
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
.for f in ${DOCS}