aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/sdom/Makefile37
-rw-r--r--textproc/sdom/distinfo3
-rw-r--r--textproc/sdom/pkg-descr6
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 881955d625f7..83c95c1693db 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -863,6 +863,7 @@
SUBDIR += sdcv
SUBDIR += sdf
SUBDIR += sdocbook-xml
+ SUBDIR += sdom
SUBDIR += senna
SUBDIR += sgmlformat
SUBDIR += sgmls
diff --git a/textproc/sdom/Makefile b/textproc/sdom/Makefile
new file mode 100644
index 000000000000..b76417ff42cc
--- /dev/null
+++ b/textproc/sdom/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: SDOM
+# Date created: Mar 22, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdom
+PORTVERSION= 0.4.1
+CATEGORIES= textproc scheme
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= An implementation of the W3C DOM recommendation in Scheme
+
+RUN_DEPENDS= ${LOCALBASE}/share/guile/site/config/load.scm:${PORTSDIR}/devel/guile-lib
+
+NO_BUILD= yes
+
+FILES= core.scm events.scm ls.scm
+PLIST_FILES= share/guile/sdom/core.scm \
+ share/guile/sdom/events.scm \
+ share/guile/sdom/ls.scm
+PLIST_DIRS= share/guile/sdom
+
+INFO= sdom
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/guile/sdom
+.for f in ${FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/guile/sdom
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/sdom.info ${PREFIX}/info
+
+.include <bsd.port.mk>
diff --git a/textproc/sdom/distinfo b/textproc/sdom/distinfo
new file mode 100644
index 000000000000..fe96b8ba1fb6
--- /dev/null
+++ b/textproc/sdom/distinfo
@@ -0,0 +1,3 @@
+MD5 (sdom-0.4.1.tar.gz) = 45217e5ff65d0de73a6fa021e56ea36a
+SHA256 (sdom-0.4.1.tar.gz) = e4b2ba09bae4f1003766d78998ff69a038216bd9a6fa7d17bf78b6ba1e4cd49b
+SIZE (sdom-0.4.1.tar.gz) = 81499
diff --git a/textproc/sdom/pkg-descr b/textproc/sdom/pkg-descr
new file mode 100644
index 000000000000..04fdd0691bb3
--- /dev/null
+++ b/textproc/sdom/pkg-descr
@@ -0,0 +1,6 @@
+SDOM is an implementation of the W3C DOM recommendation (Level 3), including
+support for event handling, in the Scheme programming language. SDOM builds
+upon the work of Oleg Kiselyov's SXML project and aims to be fully compatible
+with the SXML API.
+
+WWW: http://www.nongnu.org/sdom/