aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/openoffice-3-devel/Makefile4
-rw-r--r--editors/openoffice-3-devel/files/Makefile.knobs12
-rw-r--r--editors/openoffice-3/Makefile4
-rw-r--r--editors/openoffice-3/files/Makefile.knobs12
-rw-r--r--editors/openoffice.org-2-RC/Makefile4
-rw-r--r--editors/openoffice.org-2-RC/files/Makefile.knobs12
-rw-r--r--editors/openoffice.org-2-devel/Makefile4
-rw-r--r--editors/openoffice.org-2-devel/files/Makefile.knobs12
-rw-r--r--editors/openoffice.org-2/Makefile4
-rw-r--r--editors/openoffice.org-2/files/Makefile.knobs12
-rw-r--r--editors/openoffice.org-3-RC/Makefile4
-rw-r--r--editors/openoffice.org-3-RC/files/Makefile.knobs12
-rw-r--r--editors/openoffice.org-3-devel/Makefile4
-rw-r--r--editors/openoffice.org-3-devel/files/Makefile.knobs12
-rw-r--r--editors/openoffice.org-3/Makefile4
-rw-r--r--editors/openoffice.org-3/files/Makefile.knobs12
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile4
-rw-r--r--editors/openoffice.org-vcltesttool/files/Makefile.knobs12
18 files changed, 144 insertions, 0 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index cf2a95783797..993d0c2caa62 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -55,7 +55,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice-3-devel/files/Makefile.knobs b/editors/openoffice-3-devel/files/Makefile.knobs
index 31759389815f..b20b1f848303 100644
--- a/editors/openoffice-3-devel/files/Makefile.knobs
+++ b/editors/openoffice-3-devel/files/Makefile.knobs
@@ -57,6 +57,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -89,6 +96,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 6e558c607331..547bc9ee306b 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -56,7 +56,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice-3/files/Makefile.knobs b/editors/openoffice-3/files/Makefile.knobs
index 2d429399cee3..686099bd3274 100644
--- a/editors/openoffice-3/files/Makefile.knobs
+++ b/editors/openoffice-3/files/Makefile.knobs
@@ -54,6 +54,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -86,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index acbe05df80dc..538bc9a6e450 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -55,7 +55,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice.org-2-RC/files/Makefile.knobs b/editors/openoffice.org-2-RC/files/Makefile.knobs
index 2d429399cee3..686099bd3274 100644
--- a/editors/openoffice.org-2-RC/files/Makefile.knobs
+++ b/editors/openoffice.org-2-RC/files/Makefile.knobs
@@ -54,6 +54,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -86,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 67cf1b0541ac..d8b5088dd10d 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -57,7 +57,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice.org-2-devel/files/Makefile.knobs b/editors/openoffice.org-2-devel/files/Makefile.knobs
index 2d429399cee3..686099bd3274 100644
--- a/editors/openoffice.org-2-devel/files/Makefile.knobs
+++ b/editors/openoffice.org-2-devel/files/Makefile.knobs
@@ -54,6 +54,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -86,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 6e558c607331..547bc9ee306b 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -56,7 +56,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice.org-2/files/Makefile.knobs b/editors/openoffice.org-2/files/Makefile.knobs
index 2d429399cee3..686099bd3274 100644
--- a/editors/openoffice.org-2/files/Makefile.knobs
+++ b/editors/openoffice.org-2/files/Makefile.knobs
@@ -54,6 +54,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -86,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index acbe05df80dc..538bc9a6e450 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -55,7 +55,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice.org-3-RC/files/Makefile.knobs b/editors/openoffice.org-3-RC/files/Makefile.knobs
index 2d429399cee3..686099bd3274 100644
--- a/editors/openoffice.org-3-RC/files/Makefile.knobs
+++ b/editors/openoffice.org-3-RC/files/Makefile.knobs
@@ -54,6 +54,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -86,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index cf2a95783797..993d0c2caa62 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -55,7 +55,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice.org-3-devel/files/Makefile.knobs b/editors/openoffice.org-3-devel/files/Makefile.knobs
index 31759389815f..b20b1f848303 100644
--- a/editors/openoffice.org-3-devel/files/Makefile.knobs
+++ b/editors/openoffice.org-3-devel/files/Makefile.knobs
@@ -57,6 +57,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -89,6 +96,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 6e558c607331..547bc9ee306b 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -56,7 +56,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice.org-3/files/Makefile.knobs b/editors/openoffice.org-3/files/Makefile.knobs
index 2d429399cee3..686099bd3274 100644
--- a/editors/openoffice.org-3/files/Makefile.knobs
+++ b/editors/openoffice.org-3/files/Makefile.knobs
@@ -54,6 +54,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -86,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 67cf1b0541ac..d8b5088dd10d 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -57,7 +57,11 @@ WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
JAVA_BUILD= jdk
+.if (${OSVERSION} >= 800000)
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
+.endif
.if (${OSVERSION} >= 700000)
JAVA_VERSION= 1.5
.else
diff --git a/editors/openoffice.org-vcltesttool/files/Makefile.knobs b/editors/openoffice.org-vcltesttool/files/Makefile.knobs
index 2d429399cee3..686099bd3274 100644
--- a/editors/openoffice.org-vcltesttool/files/Makefile.knobs
+++ b/editors/openoffice.org-vcltesttool/files/Makefile.knobs
@@ -54,6 +54,13 @@ CONFIGURE_ARGS+= --enable-debug --enable-symbols=TRUE --enable-dbgutil
CONFIGURE_ARGS+= --enable-symbols=SMALL
.endif
+.if defined(WITH_SYSTEM_ICU)
+LIB_DEPENDS+= icule:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-system-icu=yes
+.else
+CONFIGURE_ARGS+= --with-system-icu=no
+.endif
+
pre-fetch:
.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
@${ECHO}
@@ -86,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_SYSTEM_ICU)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with devel/icu from ports with"
+ @${ECHO} "make -DWITH_SYSTEM_ICU"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"