aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/Makefile1
-rw-r--r--converters/php52-iconv/Makefile14
-rw-r--r--converters/php52-mbstring/Makefile14
-rw-r--r--converters/php52-mbstring/files/patch-config.m410
-rw-r--r--converters/php52-mbstring/files/patch-oniguruma_regerror.c10
-rw-r--r--devel/Makefile1
-rw-r--r--devel/php52-json/Makefile14
-rw-r--r--mail/Makefile1
-rw-r--r--mail/php52-imap/Makefile14
-rw-r--r--net/Makefile1
-rw-r--r--net/php52-ldap/Makefile14
-rw-r--r--security/Makefile1
12 files changed, 95 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 39e835f5ef98..103ca5a29160 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -111,6 +111,7 @@
SUBDIR += php5-mbstring
SUBDIR += php5-recode
SUBDIR += php52-iconv
+ SUBDIR += php52-mbstring
SUBDIR += psiconv
SUBDIR += py-bsdconv
SUBDIR += py-cjkcodecs
diff --git a/converters/php52-iconv/Makefile b/converters/php52-iconv/Makefile
new file mode 100644
index 000000000000..3ec86f5d58ce
--- /dev/null
+++ b/converters/php52-iconv/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-iconv
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -iconv
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php52-mbstring/Makefile b/converters/php52-mbstring/Makefile
new file mode 100644
index 000000000000..5dfb09658087
--- /dev/null
+++ b/converters/php52-mbstring/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-mbstring
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -mbstring
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php52-mbstring/files/patch-config.m4 b/converters/php52-mbstring/files/patch-config.m4
new file mode 100644
index 000000000000..619440601c7a
--- /dev/null
+++ b/converters/php52-mbstring/files/patch-config.m4
@@ -0,0 +1,10 @@
+--- config.m4.orig Fri Sep 8 07:42:50 2006
++++ config.m4 Fri Sep 8 07:43:00 2006
+@@ -66,7 +66,6 @@
+ int foo(int x, ...) {
+ va_list va;
+ va_start(va, x);
+- va_arg(va, int);
+ va_arg(va, char *);
+ va_arg(va, double);
+ return 0;
diff --git a/converters/php52-mbstring/files/patch-oniguruma_regerror.c b/converters/php52-mbstring/files/patch-oniguruma_regerror.c
new file mode 100644
index 000000000000..969b57625924
--- /dev/null
+++ b/converters/php52-mbstring/files/patch-oniguruma_regerror.c
@@ -0,0 +1,10 @@
+--- oniguruma/regerror.c.orig Sat Jan 28 09:53:54 2006
++++ oniguruma/regerror.c Sat Jan 28 09:56:58 2006
+@@ -27,6 +27,7 @@
+ * SUCH DAMAGE.
+ */
+
++#include "config.h"
+ #include "regint.h"
+ #include <stdio.h> /* for vsnprintf() */
+
diff --git a/devel/Makefile b/devel/Makefile
index e43e303dfe72..296abba4a222 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2470,6 +2470,7 @@
SUBDIR += php5-sysvshm
SUBDIR += php5-tokenizer
SUBDIR += php52-gettext
+ SUBDIR += php52-json
SUBDIR += php52-pcre
SUBDIR += phpbt
SUBDIR += phptags
diff --git a/devel/php52-json/Makefile b/devel/php52-json/Makefile
new file mode 100644
index 000000000000..522ce68faf35
--- /dev/null
+++ b/devel/php52-json/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-json
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -json
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/Makefile b/mail/Makefile
index 2831128dc10d..c137ea1067af 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -474,6 +474,7 @@
SUBDIR += pgpsendmail
SUBDIR += php4-imap
SUBDIR += php5-imap
+ SUBDIR += php52-imap
SUBDIR += phplist
SUBDIR += phpmailer
SUBDIR += phpmailer2
diff --git a/mail/php52-imap/Makefile b/mail/php52-imap/Makefile
new file mode 100644
index 000000000000..083ff37346f5
--- /dev/null
+++ b/mail/php52-imap/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-imap
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= mail
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -imap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/Makefile b/net/Makefile
index 5ca10d751dc7..c92bf7a61e9f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -770,6 +770,7 @@
SUBDIR += php5-soap
SUBDIR += php5-sockets
SUBDIR += php5-xmlrpc
+ SUBDIR += php52-ldap
SUBDIR += phpldapadmin
SUBDIR += phpldapadmin098
SUBDIR += pimdd
diff --git a/net/php52-ldap/Makefile b/net/php52-ldap/Makefile
new file mode 100644
index 000000000000..42bef023fe49
--- /dev/null
+++ b/net/php52-ldap/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-ldap
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -ldap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/Makefile b/security/Makefile
index 74c5161ff19e..5a7fcbf72f96 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -631,6 +631,7 @@
SUBDIR += php5-openssl
SUBDIR += php52-filter
SUBDIR += php52-hash
+ SUBDIR += php52-mcrypt
SUBDIR += phpdeadlock
SUBDIR += phpmyid
SUBDIR += phpsecinfo