aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/asterisk/Makefile7
-rw-r--r--net/asterisk/distinfo12
-rw-r--r--net/asterisk/pkg-plist3
-rw-r--r--net/asterisk10/Makefile7
-rw-r--r--net/asterisk10/distinfo12
-rw-r--r--net/asterisk10/pkg-plist3
-rw-r--r--net/asterisk14/Makefile7
-rw-r--r--net/asterisk14/distinfo12
-rw-r--r--net/asterisk14/pkg-plist3
-rw-r--r--net/asterisk16/Makefile7
-rw-r--r--net/asterisk16/distinfo12
-rw-r--r--net/asterisk16/pkg-plist3
12 files changed, 44 insertions, 44 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index dc47218ab4b2..ed0b160f73f5 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.4.11
-PORTREVISION= 3
+PORTVERSION= 1.4.13
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -18,6 +17,7 @@ COMMENT= An Open Source PBX and telephony toolkit
BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
newt.51:${PORTSDIR}/devel/newt \
+ gsm.1:${PORTSDIR}/audio/gsm \
curl.4:${PORTSDIR}/ftp/curl
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
@@ -26,6 +26,7 @@ ONLY_FOR_ARCHS= i386 sparc64 amd64
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/openh323" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
USE_GMAKE= yes
USE_BISON= build
@@ -157,7 +158,7 @@ LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
.endif
.if defined(WITH_CODEC_PATCH)
-PATCHFILES= asterisk-1.4.11-codec-negotiation-20070831.diff.gz
+PATCHFILES= asterisk-1.4.13-codec-negotiation-20071112.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
EXTRA_PATCHES+= ${PATCHDIR}/codecnego-patch-Makefile
.else
diff --git a/net/asterisk/distinfo b/net/asterisk/distinfo
index 8318d980f2aa..0cdd77966303 100644
--- a/net/asterisk/distinfo
+++ b/net/asterisk/distinfo
@@ -1,6 +1,6 @@
-MD5 (asterisk-1.4.11.tar.gz) = 3ba9b399fedc68de4845b1c5603d167c
-SHA256 (asterisk-1.4.11.tar.gz) = 99928f8aab62e532e71fdecbd18d5af2d211f1bbce27cf9cf2efc34e57a20101
-SIZE (asterisk-1.4.11.tar.gz) = 11218944
-MD5 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = cf2385047d55ffffcff7197480e54c79
-SHA256 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 9d6b6efcbf20b35f407aa53320b649c0d884cce9b519435c7ea3aa8a51b2b42f
-SIZE (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 37651
+MD5 (asterisk-1.4.13.tar.gz) = 49b73114831c21cc9784d3b3f4fb5bec
+SHA256 (asterisk-1.4.13.tar.gz) = 0bea2f612c7b6ebcfb97c77d473a45018a3e112e5610ff7fab83561be7b19449
+SIZE (asterisk-1.4.13.tar.gz) = 11257579
+MD5 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = d8a6096ef5141bad3047460fad8da4bc
+SHA256 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = cedd6054c9ef389601edd6ce0541ad057d51ea652506a365a00bd3a9b88d55ee
+SIZE (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = 38103
diff --git a/net/asterisk/pkg-plist b/net/asterisk/pkg-plist
index edbe0b3759ba..91aa354189a9 100644
--- a/net/asterisk/pkg-plist
+++ b/net/asterisk/pkg-plist
@@ -58,8 +58,6 @@ etc/asterisk/meetme.conf-dist
etc/asterisk/mgcp.conf-dist
@unexec if cmp -s %D/etc/asterisk/misdn.conf %D/etc/asterisk/misdn.conf-dist; then rm -f %D/etc/asterisk/misdn.conf; fi
etc/asterisk/misdn.conf-dist
-@unexec if cmp -s %D/etc/asterisk/modem.conf %D/etc/asterisk/modem.conf-dist; then rm -f %D/etc/asterisk/modem.conf; fi
-etc/asterisk/modem.conf-dist
@unexec if cmp -s %D/etc/asterisk/modules.conf %D/etc/asterisk/modules.conf-dist; then rm -f %D/etc/asterisk/modules.conf; fi
etc/asterisk/modules.conf-dist
@unexec if cmp -s %D/etc/asterisk/musiconhold.conf %D/etc/asterisk/musiconhold.conf-dist; then rm -f %D/etc/asterisk/musiconhold.conf; fi
@@ -137,6 +135,7 @@ include/asterisk/ast_expr.h
include/asterisk/astdb.h
include/asterisk/astmm.h
include/asterisk/astobj.h
+include/asterisk/astobj2.h
include/asterisk/astosp.h
include/asterisk/autoconfig.h
include/asterisk/build.h
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index dc47218ab4b2..ed0b160f73f5 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.4.11
-PORTREVISION= 3
+PORTVERSION= 1.4.13
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -18,6 +17,7 @@ COMMENT= An Open Source PBX and telephony toolkit
BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
newt.51:${PORTSDIR}/devel/newt \
+ gsm.1:${PORTSDIR}/audio/gsm \
curl.4:${PORTSDIR}/ftp/curl
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
@@ -26,6 +26,7 @@ ONLY_FOR_ARCHS= i386 sparc64 amd64
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/openh323" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
USE_GMAKE= yes
USE_BISON= build
@@ -157,7 +158,7 @@ LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
.endif
.if defined(WITH_CODEC_PATCH)
-PATCHFILES= asterisk-1.4.11-codec-negotiation-20070831.diff.gz
+PATCHFILES= asterisk-1.4.13-codec-negotiation-20071112.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
EXTRA_PATCHES+= ${PATCHDIR}/codecnego-patch-Makefile
.else
diff --git a/net/asterisk10/distinfo b/net/asterisk10/distinfo
index 8318d980f2aa..0cdd77966303 100644
--- a/net/asterisk10/distinfo
+++ b/net/asterisk10/distinfo
@@ -1,6 +1,6 @@
-MD5 (asterisk-1.4.11.tar.gz) = 3ba9b399fedc68de4845b1c5603d167c
-SHA256 (asterisk-1.4.11.tar.gz) = 99928f8aab62e532e71fdecbd18d5af2d211f1bbce27cf9cf2efc34e57a20101
-SIZE (asterisk-1.4.11.tar.gz) = 11218944
-MD5 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = cf2385047d55ffffcff7197480e54c79
-SHA256 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 9d6b6efcbf20b35f407aa53320b649c0d884cce9b519435c7ea3aa8a51b2b42f
-SIZE (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 37651
+MD5 (asterisk-1.4.13.tar.gz) = 49b73114831c21cc9784d3b3f4fb5bec
+SHA256 (asterisk-1.4.13.tar.gz) = 0bea2f612c7b6ebcfb97c77d473a45018a3e112e5610ff7fab83561be7b19449
+SIZE (asterisk-1.4.13.tar.gz) = 11257579
+MD5 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = d8a6096ef5141bad3047460fad8da4bc
+SHA256 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = cedd6054c9ef389601edd6ce0541ad057d51ea652506a365a00bd3a9b88d55ee
+SIZE (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = 38103
diff --git a/net/asterisk10/pkg-plist b/net/asterisk10/pkg-plist
index edbe0b3759ba..91aa354189a9 100644
--- a/net/asterisk10/pkg-plist
+++ b/net/asterisk10/pkg-plist
@@ -58,8 +58,6 @@ etc/asterisk/meetme.conf-dist
etc/asterisk/mgcp.conf-dist
@unexec if cmp -s %D/etc/asterisk/misdn.conf %D/etc/asterisk/misdn.conf-dist; then rm -f %D/etc/asterisk/misdn.conf; fi
etc/asterisk/misdn.conf-dist
-@unexec if cmp -s %D/etc/asterisk/modem.conf %D/etc/asterisk/modem.conf-dist; then rm -f %D/etc/asterisk/modem.conf; fi
-etc/asterisk/modem.conf-dist
@unexec if cmp -s %D/etc/asterisk/modules.conf %D/etc/asterisk/modules.conf-dist; then rm -f %D/etc/asterisk/modules.conf; fi
etc/asterisk/modules.conf-dist
@unexec if cmp -s %D/etc/asterisk/musiconhold.conf %D/etc/asterisk/musiconhold.conf-dist; then rm -f %D/etc/asterisk/musiconhold.conf; fi
@@ -137,6 +135,7 @@ include/asterisk/ast_expr.h
include/asterisk/astdb.h
include/asterisk/astmm.h
include/asterisk/astobj.h
+include/asterisk/astobj2.h
include/asterisk/astosp.h
include/asterisk/autoconfig.h
include/asterisk/build.h
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index dc47218ab4b2..ed0b160f73f5 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.4.11
-PORTREVISION= 3
+PORTVERSION= 1.4.13
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -18,6 +17,7 @@ COMMENT= An Open Source PBX and telephony toolkit
BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
newt.51:${PORTSDIR}/devel/newt \
+ gsm.1:${PORTSDIR}/audio/gsm \
curl.4:${PORTSDIR}/ftp/curl
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
@@ -26,6 +26,7 @@ ONLY_FOR_ARCHS= i386 sparc64 amd64
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/openh323" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
USE_GMAKE= yes
USE_BISON= build
@@ -157,7 +158,7 @@ LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
.endif
.if defined(WITH_CODEC_PATCH)
-PATCHFILES= asterisk-1.4.11-codec-negotiation-20070831.diff.gz
+PATCHFILES= asterisk-1.4.13-codec-negotiation-20071112.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
EXTRA_PATCHES+= ${PATCHDIR}/codecnego-patch-Makefile
.else
diff --git a/net/asterisk14/distinfo b/net/asterisk14/distinfo
index 8318d980f2aa..0cdd77966303 100644
--- a/net/asterisk14/distinfo
+++ b/net/asterisk14/distinfo
@@ -1,6 +1,6 @@
-MD5 (asterisk-1.4.11.tar.gz) = 3ba9b399fedc68de4845b1c5603d167c
-SHA256 (asterisk-1.4.11.tar.gz) = 99928f8aab62e532e71fdecbd18d5af2d211f1bbce27cf9cf2efc34e57a20101
-SIZE (asterisk-1.4.11.tar.gz) = 11218944
-MD5 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = cf2385047d55ffffcff7197480e54c79
-SHA256 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 9d6b6efcbf20b35f407aa53320b649c0d884cce9b519435c7ea3aa8a51b2b42f
-SIZE (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 37651
+MD5 (asterisk-1.4.13.tar.gz) = 49b73114831c21cc9784d3b3f4fb5bec
+SHA256 (asterisk-1.4.13.tar.gz) = 0bea2f612c7b6ebcfb97c77d473a45018a3e112e5610ff7fab83561be7b19449
+SIZE (asterisk-1.4.13.tar.gz) = 11257579
+MD5 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = d8a6096ef5141bad3047460fad8da4bc
+SHA256 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = cedd6054c9ef389601edd6ce0541ad057d51ea652506a365a00bd3a9b88d55ee
+SIZE (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = 38103
diff --git a/net/asterisk14/pkg-plist b/net/asterisk14/pkg-plist
index edbe0b3759ba..91aa354189a9 100644
--- a/net/asterisk14/pkg-plist
+++ b/net/asterisk14/pkg-plist
@@ -58,8 +58,6 @@ etc/asterisk/meetme.conf-dist
etc/asterisk/mgcp.conf-dist
@unexec if cmp -s %D/etc/asterisk/misdn.conf %D/etc/asterisk/misdn.conf-dist; then rm -f %D/etc/asterisk/misdn.conf; fi
etc/asterisk/misdn.conf-dist
-@unexec if cmp -s %D/etc/asterisk/modem.conf %D/etc/asterisk/modem.conf-dist; then rm -f %D/etc/asterisk/modem.conf; fi
-etc/asterisk/modem.conf-dist
@unexec if cmp -s %D/etc/asterisk/modules.conf %D/etc/asterisk/modules.conf-dist; then rm -f %D/etc/asterisk/modules.conf; fi
etc/asterisk/modules.conf-dist
@unexec if cmp -s %D/etc/asterisk/musiconhold.conf %D/etc/asterisk/musiconhold.conf-dist; then rm -f %D/etc/asterisk/musiconhold.conf; fi
@@ -137,6 +135,7 @@ include/asterisk/ast_expr.h
include/asterisk/astdb.h
include/asterisk/astmm.h
include/asterisk/astobj.h
+include/asterisk/astobj2.h
include/asterisk/astosp.h
include/asterisk/autoconfig.h
include/asterisk/build.h
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index dc47218ab4b2..ed0b160f73f5 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.4.11
-PORTREVISION= 3
+PORTVERSION= 1.4.13
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -18,6 +17,7 @@ COMMENT= An Open Source PBX and telephony toolkit
BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
newt.51:${PORTSDIR}/devel/newt \
+ gsm.1:${PORTSDIR}/audio/gsm \
curl.4:${PORTSDIR}/ftp/curl
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
@@ -26,6 +26,7 @@ ONLY_FOR_ARCHS= i386 sparc64 amd64
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/openh323" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
USE_GMAKE= yes
USE_BISON= build
@@ -157,7 +158,7 @@ LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
.endif
.if defined(WITH_CODEC_PATCH)
-PATCHFILES= asterisk-1.4.11-codec-negotiation-20070831.diff.gz
+PATCHFILES= asterisk-1.4.13-codec-negotiation-20071112.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
EXTRA_PATCHES+= ${PATCHDIR}/codecnego-patch-Makefile
.else
diff --git a/net/asterisk16/distinfo b/net/asterisk16/distinfo
index 8318d980f2aa..0cdd77966303 100644
--- a/net/asterisk16/distinfo
+++ b/net/asterisk16/distinfo
@@ -1,6 +1,6 @@
-MD5 (asterisk-1.4.11.tar.gz) = 3ba9b399fedc68de4845b1c5603d167c
-SHA256 (asterisk-1.4.11.tar.gz) = 99928f8aab62e532e71fdecbd18d5af2d211f1bbce27cf9cf2efc34e57a20101
-SIZE (asterisk-1.4.11.tar.gz) = 11218944
-MD5 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = cf2385047d55ffffcff7197480e54c79
-SHA256 (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 9d6b6efcbf20b35f407aa53320b649c0d884cce9b519435c7ea3aa8a51b2b42f
-SIZE (asterisk-1.4.11-codec-negotiation-20070831.diff.gz) = 37651
+MD5 (asterisk-1.4.13.tar.gz) = 49b73114831c21cc9784d3b3f4fb5bec
+SHA256 (asterisk-1.4.13.tar.gz) = 0bea2f612c7b6ebcfb97c77d473a45018a3e112e5610ff7fab83561be7b19449
+SIZE (asterisk-1.4.13.tar.gz) = 11257579
+MD5 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = d8a6096ef5141bad3047460fad8da4bc
+SHA256 (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = cedd6054c9ef389601edd6ce0541ad057d51ea652506a365a00bd3a9b88d55ee
+SIZE (asterisk-1.4.13-codec-negotiation-20071112.diff.gz) = 38103
diff --git a/net/asterisk16/pkg-plist b/net/asterisk16/pkg-plist
index edbe0b3759ba..91aa354189a9 100644
--- a/net/asterisk16/pkg-plist
+++ b/net/asterisk16/pkg-plist
@@ -58,8 +58,6 @@ etc/asterisk/meetme.conf-dist
etc/asterisk/mgcp.conf-dist
@unexec if cmp -s %D/etc/asterisk/misdn.conf %D/etc/asterisk/misdn.conf-dist; then rm -f %D/etc/asterisk/misdn.conf; fi
etc/asterisk/misdn.conf-dist
-@unexec if cmp -s %D/etc/asterisk/modem.conf %D/etc/asterisk/modem.conf-dist; then rm -f %D/etc/asterisk/modem.conf; fi
-etc/asterisk/modem.conf-dist
@unexec if cmp -s %D/etc/asterisk/modules.conf %D/etc/asterisk/modules.conf-dist; then rm -f %D/etc/asterisk/modules.conf; fi
etc/asterisk/modules.conf-dist
@unexec if cmp -s %D/etc/asterisk/musiconhold.conf %D/etc/asterisk/musiconhold.conf-dist; then rm -f %D/etc/asterisk/musiconhold.conf; fi
@@ -137,6 +135,7 @@ include/asterisk/ast_expr.h
include/asterisk/astdb.h
include/asterisk/astmm.h
include/asterisk/astobj.h
+include/asterisk/astobj2.h
include/asterisk/astosp.h
include/asterisk/autoconfig.h
include/asterisk/build.h