aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile30
-rw-r--r--www/p5-CGI-Application-Plugin-HTMLPrototype/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-descr9
-rw-r--r--www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-plist4
5 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bbaf2e04eca4..616ef052d710 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -518,6 +518,7 @@
SUBDIR += p5-CGI-Application-Plugin-DevPopup
SUBDIR += p5-CGI-Application-Plugin-Forward
SUBDIR += p5-CGI-Application-Plugin-HTDot
+ SUBDIR += p5-CGI-Application-Plugin-HTMLPrototype
SUBDIR += p5-CGI-Application-Plugin-Redirect
SUBDIR += p5-CGI-Application-Plugin-ValidateRM
SUBDIR += p5-CGI-Application-Server
diff --git a/www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile b/www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile
new file mode 100644
index 000000000000..c0f631683b9e
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-HTMLPrototype
+# Date created: 15 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-HTMLPrototype
+PORTVERSION= 0.20
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Access to the prototype JavaScript library using HTML::Prototype
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/HTML/Prototype.pm:${PORTSDIR}/www/p5-HTML-Prototype
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::HTMLPrototype.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-HTMLPrototype/distinfo b/www/p5-CGI-Application-Plugin-HTMLPrototype/distinfo
new file mode 100644
index 000000000000..5693d3bf688a
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HTMLPrototype/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-HTMLPrototype-0.20.tar.gz) = 99b8dd4180b37e292e4a6ff45ee35fda
+SHA256 (CGI-Application-Plugin-HTMLPrototype-0.20.tar.gz) = 4bc9a19bb69401f65fa60e7eda7465b4af186540efb0c4c0105e46520db776d3
+SIZE (CGI-Application-Plugin-HTMLPrototype-0.20.tar.gz) = 5366
diff --git a/www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-descr b/www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-descr
new file mode 100644
index 000000000000..9a5895eb8d8d
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-descr
@@ -0,0 +1,9 @@
+CGI::Application::Plugin::HTMLPrototype - Give easy access to the
+prototype JavaScript library using HTML::Prototype
+
+HTML::Prototype is a JavaScript code generator for the prototype.js
+JavaScript library, and the script.aculo.us extensions to
+prototype.js. It allows you to easily add AJAX calls and dynamic
+elements to your website.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-HTMLPrototype/
diff --git a/www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-plist b/www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-plist
new file mode 100644
index 000000000000..780eaeee1c02
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HTMLPrototype/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/CGI/Application/Plugin/HTMLPrototype.pm
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application
+@dirrmtry %%SITE_PERL%%/CGI