aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-YAPE-Regex/Makefile25
-rw-r--r--textproc/p5-YAPE-Regex/distinfo1
-rw-r--r--textproc/p5-YAPE-Regex/pkg-descr6
-rw-r--r--textproc/p5-YAPE-Regex/pkg-plist9
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 59553a2c1751..3aef29e82a6f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -301,6 +301,7 @@
SUBDIR += p5-XML-XUpdate-LibXML
SUBDIR += p5-YAML
SUBDIR += p5-YAPE-HTML
+ SUBDIR += p5-YAPE-Regex
SUBDIR += p5-dTemplate
SUBDIR += p5-libxml
SUBDIR += p5-podlators
diff --git a/textproc/p5-YAPE-Regex/Makefile b/textproc/p5-YAPE-Regex/Makefile
new file mode 100644
index 000000000000..e216644a00e4
--- /dev/null
+++ b/textproc/p5-YAPE-Regex/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-YAPE-Regex
+# Date created: 3 juin 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= YAPE-Regex
+PORTVERSION= 3.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/P/PI/PINYAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Yet Another Parser/Extractor for Regular Expressions
+
+BUILD_DEPENDS= ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= YAPE::Regex.3 YAPE::Regex::Element.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-YAPE-Regex/distinfo b/textproc/p5-YAPE-Regex/distinfo
new file mode 100644
index 000000000000..148f90ee5cd7
--- /dev/null
+++ b/textproc/p5-YAPE-Regex/distinfo
@@ -0,0 +1 @@
+MD5 (YAPE-Regex-3.01.tar.gz) = 44f86788dfdf11fd74b58e1bedabb0fe
diff --git a/textproc/p5-YAPE-Regex/pkg-descr b/textproc/p5-YAPE-Regex/pkg-descr
new file mode 100644
index 000000000000..40623807e90c
--- /dev/null
+++ b/textproc/p5-YAPE-Regex/pkg-descr
@@ -0,0 +1,6 @@
+This module is yet another (?) parser and tree-builder for Perl regular
+expressions. It builds a tree out of a regex, but at the moment, the extent of
+the extraction tool for the tree is quite limited. However, the tree can be
+useful to extension modules.
+
+WWW: http://search.cpan.org/dist/YAPE-Regex/
diff --git a/textproc/p5-YAPE-Regex/pkg-plist b/textproc/p5-YAPE-Regex/pkg-plist
new file mode 100644
index 000000000000..3852da4757c9
--- /dev/null
+++ b/textproc/p5-YAPE-Regex/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/YAPE/Regex.pm
+%%SITE_PERL%%/YAPE/Regex/Element.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE/Regex/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE/Regex
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE 2>/dev/null || true
+@dirrm %%SITE_PERL%%/YAPE/Regex
+@unexec rmdir %D/%%SITE_PERL%%/YAPE 2>/dev/null || true
+@unexec rmdir %D%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE 2>/dev/null || true
+@unexec rmdir %D%%SITE_PERL%%/YAPE 2>/dev/null || true