aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateConvert/Makefile25
-rw-r--r--devel/p5-DateConvert/distinfo1
-rw-r--r--devel/p5-DateConvert/pkg-comment1
-rw-r--r--devel/p5-DateConvert/pkg-descr5
-rw-r--r--devel/p5-DateConvert/pkg-plist5
6 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a1fcabded905..972f50cd54f8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -191,6 +191,7 @@
SUBDIR += p5-Data-Flow
SUBDIR += p5-Data-ShowTable
SUBDIR += p5-Date-Calc
+ SUBDIR += p5-Date-Convert
SUBDIR += p5-Date-Manip
SUBDIR += p5-Devel-DProf
SUBDIR += p5-Devel-Peek
diff --git a/devel/p5-DateConvert/Makefile b/devel/p5-DateConvert/Makefile
new file mode 100644
index 000000000000..eafd28ae3a97
--- /dev/null
+++ b/devel/p5-DateConvert/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-DateConvert
+# Date created: 13th September 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateConvert
+PORTVERSION= 0.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Date
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ade@FreeBSD.org
+
+USE_PERL5= YES
+
+MAN3= Date::Convert.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateConvert/distinfo b/devel/p5-DateConvert/distinfo
new file mode 100644
index 000000000000..30c44840a0b6
--- /dev/null
+++ b/devel/p5-DateConvert/distinfo
@@ -0,0 +1 @@
+MD5 (DateConvert-0.16.tar.gz) = 80a83c8cf1f113cfe4ca743d912094fc
diff --git a/devel/p5-DateConvert/pkg-comment b/devel/p5-DateConvert/pkg-comment
new file mode 100644
index 000000000000..7d6bc43340ca
--- /dev/null
+++ b/devel/p5-DateConvert/pkg-comment
@@ -0,0 +1 @@
+Perl5 module to convert dates between any two calendrical formats
diff --git a/devel/p5-DateConvert/pkg-descr b/devel/p5-DateConvert/pkg-descr
new file mode 100644
index 000000000000..6899933e9040
--- /dev/null
+++ b/devel/p5-DateConvert/pkg-descr
@@ -0,0 +1,5 @@
+Date::Convert allows you to convert date formats using an OO mechanism
+that lets you easily choose any two formats and add in new ones.
+
+If you have suggestions, bug reports, or if you want to add a new date
+format, feel free to contact me: morty@sanctuary.arbutus.md.us
diff --git a/devel/p5-DateConvert/pkg-plist b/devel/p5-DateConvert/pkg-plist
new file mode 100644
index 000000000000..6d11a277433c
--- /dev/null
+++ b/devel/p5-DateConvert/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Date/Convert.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Convert/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Convert
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Date 2>/dev/null || true