aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/libemf/Makefile4
-rw-r--r--japanese/tcl76/Makefile4
-rw-r--r--lang/klone/Makefile8
3 files changed, 15 insertions, 1 deletions
diff --git a/graphics/libemf/Makefile b/graphics/libemf/Makefile
index 4283b07f1944..34733edcd629 100644
--- a/graphics/libemf/Makefile
+++ b/graphics/libemf/Makefile
@@ -17,6 +17,10 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/japanese/tcl76/Makefile b/japanese/tcl76/Makefile
index 09fa9e274846..12e28b7b779c 100644
--- a/japanese/tcl76/Makefile
+++ b/japanese/tcl76/Makefile
@@ -37,6 +37,10 @@ NO_LATEST_LINK= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-extract:
@${MV} ${WRKDIR}/${PORTNAME}${PORTVERSION} ${WRKDIR}/${DISTNAME}
diff --git a/lang/klone/Makefile b/lang/klone/Makefile
index 7904277ce2c9..010dc47ae1b8 100644
--- a/lang/klone/Makefile
+++ b/lang/klone/Makefile
@@ -17,6 +17,12 @@ COMMENT= Small, Lisp-like interpreted language
WRKSRC= ${WRKDIR}/Klone
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
do-configure:
@${SED} -e 's:%%PREFIX%%:${PREFIX}:' \
-e 's:%%CC%%:${CC}:' \
@@ -37,4 +43,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>