aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/gnomebreakout/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index d89434be4d55..d7d117305a10 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -28,5 +28,7 @@ post-patch:
's|-Werror||g' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e \
's|@GETTEXT_PACKAGE@|@PACKAGE@|g' ${WRKSRC}/po/Makefile.in.in
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-DGNOME_DISABLE_DEPRECATED||g ; s|-DGTK_DISABLE_DEPRECATED||g'
.include <bsd.port.mk>