aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/asterisk/Makefile11
-rw-r--r--net/asterisk/pkg-plist1
-rw-r--r--net/asterisk10/Makefile11
-rw-r--r--net/asterisk10/pkg-plist1
-rw-r--r--net/asterisk14/Makefile11
-rw-r--r--net/asterisk14/pkg-plist1
-rw-r--r--net/asterisk16/Makefile11
-rw-r--r--net/asterisk16/pkg-plist1
8 files changed, 48 insertions, 0 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index c036d53fda6a..c9024c4cd57d 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.4.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -44,6 +45,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
H323 "Enable H.323 support" on \
+ FREETDS "Enable FreeTDS support" on \
JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -88,6 +90,15 @@ CONFIGURE_ARGS+= --with-odbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.endif
+.if defined(WITHOUT_FREETDS)
+PLIST_SUB+= WITH_FREETDS="@comment "
+CONFIGURE_ARGS+= --without-tds
+.else
+PLIST_SUB+= WITH_FREETDS=""
+CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
+LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
+.endif
+
.if defined(WITHOUT_POSTGRES)
PLIST_SUB+= WITH_POSTGRES="@comment "
CONFIGURE_ARGS+= --without-postgres
diff --git a/net/asterisk/pkg-plist b/net/asterisk/pkg-plist
index 5f0ce4ba28d5..9fc1bf7e3501 100644
--- a/net/asterisk/pkg-plist
+++ b/net/asterisk/pkg-plist
@@ -761,6 +761,7 @@ share/asterisk/static-http/prototype.js
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapras.so
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapscan.so
%%WITH_ODBC%%lib/asterisk/modules/cdr_odbc.so
+%%WITH_FREETDS%%lib/asterisk/modules/cdr_tds.so
%%WITH_H323%%lib/asterisk/modules/chan_h323.so
%%WITH_ZAPTEL%%lib/asterisk/modules/chan_zap.so
%%WITH_ZAPTEL%%lib/asterisk/modules/codec_zap.so
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index c036d53fda6a..c9024c4cd57d 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.4.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -44,6 +45,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
H323 "Enable H.323 support" on \
+ FREETDS "Enable FreeTDS support" on \
JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -88,6 +90,15 @@ CONFIGURE_ARGS+= --with-odbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.endif
+.if defined(WITHOUT_FREETDS)
+PLIST_SUB+= WITH_FREETDS="@comment "
+CONFIGURE_ARGS+= --without-tds
+.else
+PLIST_SUB+= WITH_FREETDS=""
+CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
+LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
+.endif
+
.if defined(WITHOUT_POSTGRES)
PLIST_SUB+= WITH_POSTGRES="@comment "
CONFIGURE_ARGS+= --without-postgres
diff --git a/net/asterisk10/pkg-plist b/net/asterisk10/pkg-plist
index 5f0ce4ba28d5..9fc1bf7e3501 100644
--- a/net/asterisk10/pkg-plist
+++ b/net/asterisk10/pkg-plist
@@ -761,6 +761,7 @@ share/asterisk/static-http/prototype.js
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapras.so
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapscan.so
%%WITH_ODBC%%lib/asterisk/modules/cdr_odbc.so
+%%WITH_FREETDS%%lib/asterisk/modules/cdr_tds.so
%%WITH_H323%%lib/asterisk/modules/chan_h323.so
%%WITH_ZAPTEL%%lib/asterisk/modules/chan_zap.so
%%WITH_ZAPTEL%%lib/asterisk/modules/codec_zap.so
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index c036d53fda6a..c9024c4cd57d 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.4.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -44,6 +45,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
H323 "Enable H.323 support" on \
+ FREETDS "Enable FreeTDS support" on \
JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -88,6 +90,15 @@ CONFIGURE_ARGS+= --with-odbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.endif
+.if defined(WITHOUT_FREETDS)
+PLIST_SUB+= WITH_FREETDS="@comment "
+CONFIGURE_ARGS+= --without-tds
+.else
+PLIST_SUB+= WITH_FREETDS=""
+CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
+LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
+.endif
+
.if defined(WITHOUT_POSTGRES)
PLIST_SUB+= WITH_POSTGRES="@comment "
CONFIGURE_ARGS+= --without-postgres
diff --git a/net/asterisk14/pkg-plist b/net/asterisk14/pkg-plist
index 5f0ce4ba28d5..9fc1bf7e3501 100644
--- a/net/asterisk14/pkg-plist
+++ b/net/asterisk14/pkg-plist
@@ -761,6 +761,7 @@ share/asterisk/static-http/prototype.js
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapras.so
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapscan.so
%%WITH_ODBC%%lib/asterisk/modules/cdr_odbc.so
+%%WITH_FREETDS%%lib/asterisk/modules/cdr_tds.so
%%WITH_H323%%lib/asterisk/modules/chan_h323.so
%%WITH_ZAPTEL%%lib/asterisk/modules/chan_zap.so
%%WITH_ZAPTEL%%lib/asterisk/modules/codec_zap.so
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index c036d53fda6a..c9024c4cd57d 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.4.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -44,6 +45,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
H323 "Enable H.323 support" on \
+ FREETDS "Enable FreeTDS support" on \
JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -88,6 +90,15 @@ CONFIGURE_ARGS+= --with-odbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.endif
+.if defined(WITHOUT_FREETDS)
+PLIST_SUB+= WITH_FREETDS="@comment "
+CONFIGURE_ARGS+= --without-tds
+.else
+PLIST_SUB+= WITH_FREETDS=""
+CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
+LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
+.endif
+
.if defined(WITHOUT_POSTGRES)
PLIST_SUB+= WITH_POSTGRES="@comment "
CONFIGURE_ARGS+= --without-postgres
diff --git a/net/asterisk16/pkg-plist b/net/asterisk16/pkg-plist
index 5f0ce4ba28d5..9fc1bf7e3501 100644
--- a/net/asterisk16/pkg-plist
+++ b/net/asterisk16/pkg-plist
@@ -761,6 +761,7 @@ share/asterisk/static-http/prototype.js
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapras.so
%%WITH_ZAPTEL%%lib/asterisk/modules/app_zapscan.so
%%WITH_ODBC%%lib/asterisk/modules/cdr_odbc.so
+%%WITH_FREETDS%%lib/asterisk/modules/cdr_tds.so
%%WITH_H323%%lib/asterisk/modules/chan_h323.so
%%WITH_ZAPTEL%%lib/asterisk/modules/chan_zap.so
%%WITH_ZAPTEL%%lib/asterisk/modules/codec_zap.so