aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/libofa/Makefile6
-rw-r--r--audio/libofa/files/patch-examples__protocol.cpp7
2 files changed, 9 insertions, 4 deletions
diff --git a/audio/libofa/Makefile b/audio/libofa/Makefile
index d234a29c5bfe..5f414356be5c 100644
--- a/audio/libofa/Makefile
+++ b/audio/libofa/Makefile
@@ -14,6 +14,9 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= bsdkaffee@gmail.com
COMMENT= The Open Fingerprint Architecture Library
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
expat.6:${PORTSDIR}/textproc/expat2 \
curl.6:${PORTSDIR}/ftp/curl
@@ -28,7 +31,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
.include <bsd.port.mk>
diff --git a/audio/libofa/files/patch-examples__protocol.cpp b/audio/libofa/files/patch-examples__protocol.cpp
index cf239a1e164d..a8716757c050 100644
--- a/audio/libofa/files/patch-examples__protocol.cpp
+++ b/audio/libofa/files/patch-examples__protocol.cpp
@@ -1,6 +1,6 @@
--- ./examples/protocol.cpp.orig 2011-03-18 11:01:22.000000000 -0400
+++ ./examples/protocol.cpp 2011-03-18 11:01:22.000000000 -0400
-@@ -8,6 +8,7 @@
+@@ -8,11 +8,11 @@
-------------------------------------------------------------------*/
#include <stdio.h>
#include <stdlib.h>
@@ -8,3 +8,8 @@
#include <string>
#include <map>
#include <expat.h>
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ using namespace std;