aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/curl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index cffbe28ad47b..8ec19b6b1f27 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -44,11 +44,13 @@ PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GNU_CONFIGURE= yes
USE_BZIP2= yes
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+.endif
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_SSL)
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
.else
CONFIGURE_ARGS= --without-ssl