aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/gnustep-make/Makefile3
-rw-r--r--devel/gnustep-make/distinfo4
-rw-r--r--devel/gnustep-make/pkg-plist4
-rw-r--r--devel/gnustep/Makefile2
-rw-r--r--lang/gnustep-base/Makefile20
-rw-r--r--lang/gnustep-base/distinfo4
-rw-r--r--lang/gnustep-base/files/NSFileManager.m.patch (renamed from lang/gnustep-base/files/patch-NSFileManager.m)0
-rw-r--r--lang/gnustep-base/pkg-plist13
8 files changed, 31 insertions, 19 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index a530462176e7..043c2657b6e5 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -7,8 +7,7 @@
PORTNAME= gnustep-make
.if defined(WITH_GNUSTEP_DEVEL)
-PORTVERSION= 1.9.1
-PORTREVISION= 1
+PORTVERSION= 1.9.2
.else
PORTVERSION= 1.8.0
PORTREVISION= 2
diff --git a/devel/gnustep-make/distinfo b/devel/gnustep-make/distinfo
index 2e047998b28a..bda7365fe496 100644
--- a/devel/gnustep-make/distinfo
+++ b/devel/gnustep-make/distinfo
@@ -1,4 +1,4 @@
-MD5 (gnustep-make-1.9.1.tar.gz) = 0d1e5e0d8e57662b6c2cf969d9a09750
-SIZE (gnustep-make-1.9.1.tar.gz) = 370625
+MD5 (gnustep-make-1.9.2.tar.gz) = 80acfa3ccaaae94f467f913d7cfedd8d
+SIZE (gnustep-make-1.9.2.tar.gz) = 366822
MD5 (gnustep-make-1.8.0.tar.gz) = 3d8de1ed93c45b2cbfa32fe9fd0396dd
SIZE (gnustep-make-1.8.0.tar.gz) = 359394
diff --git a/devel/gnustep-make/pkg-plist b/devel/gnustep-make/pkg-plist
index aac570df7b29..9438b14d81c4 100644
--- a/devel/gnustep-make/pkg-plist
+++ b/devel/gnustep-make/pkg-plist
@@ -153,11 +153,11 @@ System/share/config.site
@dirrm System/Library
@dirrm System/Applications
@dirrm System
-@dirrm Network
+%%GNUSTEP_STABLE%%@dirrm Network
@dirrm Local
@unexec rmdir %D
@exec mkdir -p %D/Local
-@exec mkdir -p %D/Network
+%%GNUSTEP_STABLE%%@exec mkdir -p %D/Network
@exec mkdir -p %D/System/Applications
@exec mkdir -p %D/System/Library/ApplicationSupport
@exec mkdir -p %D/System/Library/Bundles
diff --git a/devel/gnustep/Makefile b/devel/gnustep/Makefile
index d4bd574b3d63..7733908b6a40 100644
--- a/devel/gnustep/Makefile
+++ b/devel/gnustep/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnustep
.if defined(WITH_GNUSTEP_DEVEL)
-PORTVERSION= 1.9.1
+PORTVERSION= 1.9.2
.else
PORTVERSION= 1.8.0
.endif
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 3a53a2618306..f2b97c45027f 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -7,8 +7,7 @@
PORTNAME= gnustep-base
.if defined(WITH_GNUSTEP_DEVEL)
-PORTVERSION= 1.9.1
-PORTREVISION= 1
+PORTVERSION= 1.9.2
.else
PORTVERSION= 1.8.0
PORTREVISION= 2
@@ -46,15 +45,20 @@ CONFIGURE_ARGS+= --disable-openssl
PLIST_SUB+= OPENSSL="@comment "
.else
USE_OPENSSL= yes
-.if defined(WITH_GNUSTEP_DEVEL)
-PLIST_SUB+= OPENSSL="@comment "
-.else
PLIST_SUB+= OPENSSL=""
-.endif
MAKE_APPS= SSL
INSTALL_APPS= SSL
.endif
+.if defined(WITH_GNUSTEP_DEVEL)
+LIBS+= -lkvm
+CONFIGURE_ENV+= LIBS="${LIBS}"
+.endif
+
+.if !defined(WITH_GNUSTEP_DEVEL)
+EXTRA_PATCHES+= ${FILESDIR}/NSFileManager.m.patch
+.endif
+
.include <bsd.port.pre.mk>
TARGLIB!= (cd ${PORTSDIR}/${GNUSTEP_OBJC_PORT} && make -V TARGLIB)
@@ -88,5 +92,5 @@ test:
.include <bsd.port.post.mk>
-# bsd.port.post.mk clobbers MAKE_ENV
-MAKE_ENV+= PATH=${autotools_path}:$(PREFIX)/System/Tools:${PATH}
+# bsd.autotools.mk clobbers MAKE_ENV
+MAKE_ENV+= PATH=${AUTOTOOLS_PATH}:${PREFIX}/System/Tools:${PATH}
diff --git a/lang/gnustep-base/distinfo b/lang/gnustep-base/distinfo
index 3318bd4cfebe..e393cc790355 100644
--- a/lang/gnustep-base/distinfo
+++ b/lang/gnustep-base/distinfo
@@ -1,4 +1,4 @@
-MD5 (gnustep-base-1.9.1.tar.gz) = ae5a29e32a392c78ea2e93a639487817
-SIZE (gnustep-base-1.9.1.tar.gz) = 1689980
+MD5 (gnustep-base-1.9.2.tar.gz) = b1fe102145f32aa05ebff41ffd7b9fd0
+SIZE (gnustep-base-1.9.2.tar.gz) = 1735363
MD5 (gnustep-base-1.8.0.tar.gz) = 3ce14c1f8384d3e3837f28e6a5155bc9
SIZE (gnustep-base-1.8.0.tar.gz) = 1629498
diff --git a/lang/gnustep-base/files/patch-NSFileManager.m b/lang/gnustep-base/files/NSFileManager.m.patch
index 1325f4466629..1325f4466629 100644
--- a/lang/gnustep-base/files/patch-NSFileManager.m
+++ b/lang/gnustep-base/files/NSFileManager.m.patch
diff --git a/lang/gnustep-base/pkg-plist b/lang/gnustep-base/pkg-plist
index bf8181c495b3..b7b57496faaa 100644
--- a/lang/gnustep-base/pkg-plist
+++ b/lang/gnustep-base/pkg-plist
@@ -5,10 +5,17 @@ System/Library/DTDs/gsdoc-0_6_5.dtd
System/Library/DTDs/gsdoc-0_6_6.dtd
System/Library/DTDs/gsdoc-0_6_7.dtd
System/Library/DTDs/gsdoc-1_0_0.dtd
+%%GNUSTEP_DEVEL%%System/Library/DTDs/gsdoc-1_0_1.dtd
System/Library/DTDs/plist-0_9.dtd
-System/Library/DocTemplates/AutoDocTemplate.gsdoc
-System/Library/DocTemplates/indextemplate.gsdoc
+%%GNUSTEP_STABLE%%System/Library/DocTemplates/AutoDocTemplate.gsdoc
+%%GNUSTEP_STABLE%%System/Library/DocTemplates/indextemplate.gsdoc
+%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/autogsdoc.1.gz
+%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/cvtenc.1.gz
+%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/defaults.1.gz
System/Library/Documentation/man/man1/gdnc.1.gz
+%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/pldes.1.gz
+%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/sfparse.1.gz
+%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/xmlparse.1.gz
System/Library/Documentation/man/man8/gdomap.8.gz
System/Library/Headers/Foundation/Foundation.h
System/Library/Headers/Foundation/GSMime.h
@@ -37,6 +44,7 @@ System/Library/Headers/Foundation/NSDistantObject.h
System/Library/Headers/Foundation/NSDistributedLock.h
System/Library/Headers/Foundation/NSDistributedNotificationCenter.h
System/Library/Headers/Foundation/NSEnumerator.h
+%%GNUSTEP_DEVEL%%System/Library/Headers/Foundation/NSError.h
System/Library/Headers/Foundation/NSException.h
System/Library/Headers/Foundation/NSFileHandle.h
System/Library/Headers/Foundation/NSFileManager.h
@@ -136,6 +144,7 @@ System/Library/Libraries/Resources/gnustep-base/Languages/Dutch
System/Library/Libraries/Resources/gnustep-base/Languages/English
System/Library/Libraries/Resources/gnustep-base/Languages/French
System/Library/Libraries/Resources/gnustep-base/Languages/German
+%%GNUSTEP_DEVEL%%System/Library/Libraries/Resources/gnustep-base/Languages/Hungarian
System/Library/Libraries/Resources/gnustep-base/Languages/Italian
System/Library/Libraries/Resources/gnustep-base/Languages/Locale.aliases
System/Library/Libraries/Resources/gnustep-base/Languages/Locale.encodings