aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/gnut/Makefile27
-rw-r--r--net/gnut/distinfo1
-rw-r--r--net/gnut/pkg-comment1
-rw-r--r--net/gnut/pkg-descr18
-rw-r--r--net/gnut/pkg-plist6
6 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ffdf15a9e400..83c08d8349c1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -73,6 +73,7 @@
SUBDIR += gnome-vnc
SUBDIR += gnomenetwork
SUBDIR += gnu-finger
+ SUBDIR += gnut
SUBDIR += gopher
SUBDIR += gtic
SUBDIR += gtksamba
diff --git a/net/gnut/Makefile b/net/gnut/Makefile
new file mode 100644
index 000000000000..af2358c64ce5
--- /dev/null
+++ b/net/gnut/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gnut
+# Date created: 19 April 2000
+# Whom: kris@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnut
+PORTVERSION= 0.3.24
+CATEGORIES= net audio
+MASTER_SITES= http://www.umr.edu/~jjp/
+
+MAINTAINER= kris@FreeBSD.org
+
+USE_AUTOCONF= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/gnut ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/gnut
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gnut
+ ${INSTALL_DATA} ${WRKSRC}/TUTORIAL ${PREFIX}/share/doc/gnut
+.endif
+ ${MKDIR} ${PREFIX}/share/gnut
+ ${INSTALL_DATA} ${WRKSRC}/gnutrc.sample ${PREFIX}/share/gnut
+
+.include <bsd.port.mk>
diff --git a/net/gnut/distinfo b/net/gnut/distinfo
new file mode 100644
index 000000000000..45b524b8bfcc
--- /dev/null
+++ b/net/gnut/distinfo
@@ -0,0 +1 @@
+MD5 (gnut-0.3.24.tar.gz) = 9b08bbe2b47165363889efcbe70f1a44
diff --git a/net/gnut/pkg-comment b/net/gnut/pkg-comment
new file mode 100644
index 000000000000..cc36d573615a
--- /dev/null
+++ b/net/gnut/pkg-comment
@@ -0,0 +1 @@
+Text-mode client for connecting to the Gnutella distributed network
diff --git a/net/gnut/pkg-descr b/net/gnut/pkg-descr
new file mode 100644
index 000000000000..432ffd4c43fe
--- /dev/null
+++ b/net/gnut/pkg-descr
@@ -0,0 +1,18 @@
+Gnut is a text-mode client for the Gnutella distributed network. Gnutella
+is a global file-sharing network similar in many ways to Napster, except
+it has a truly distributed design which does not rely on centralized
+servers. Additionally, all types of file may be shared via gnutella, not
+just MP3 audio files as with Napster.
+
+When you connect to the Gnutella network, your local machine becomes
+a server as well as a client on the network and will start receiving
+queries and traffic from other hosts. This imposes a moderate bandwidth
+penalty on usage, but the impact can be configured.
+
+Users should be aware that Gnutella does not attempt to provide
+anonymity or confidentiality of search requests or transfers, so use for
+illegal purposes is not recommended.
+
+Gnutella homepage: http://gnutella.wego.com/
+
+WWW: http://www.umr.edu/~jjp/
diff --git a/net/gnut/pkg-plist b/net/gnut/pkg-plist
new file mode 100644
index 000000000000..6263e6c3417f
--- /dev/null
+++ b/net/gnut/pkg-plist
@@ -0,0 +1,6 @@
+bin/gnut
+share/doc/gnut/README
+share/doc/gnut/TUTORIAL
+share/gnut/gnutrc.sample
+@dirrm share/doc/gnut/
+@dirrm share/gnut/