aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/autoconf/Makefile1
-rw-r--r--devel/autoconf/files/patch-ad27
-rw-r--r--devel/autoconf213/Makefile1
-rw-r--r--devel/autoconf213/files/patch-ad27
-rw-r--r--devel/autoconf253/Makefile1
-rw-r--r--devel/autoconf253/files/patch-ad27
-rw-r--r--devel/autoconf254/Makefile1
-rw-r--r--devel/autoconf254/files/patch-ad27
-rw-r--r--devel/autoconf257/Makefile1
-rw-r--r--devel/autoconf257/files/patch-ad27
-rw-r--r--devel/autoconf259/Makefile1
-rw-r--r--devel/autoconf259/files/patch-ad27
-rw-r--r--devel/autoconf26/Makefile1
-rw-r--r--devel/autoconf26/files/patch-ad27
-rw-r--r--devel/autoconf261/Makefile1
-rw-r--r--devel/autoconf261/files/patch-ad27
-rw-r--r--devel/autoconf262/Makefile1
-rw-r--r--devel/autoconf262/files/patch-ad27
-rw-r--r--devel/autoconf267/Makefile1
-rw-r--r--devel/autoconf267/files/patch-ad27
-rw-r--r--devel/autoconf268/Makefile1
-rw-r--r--devel/autoconf268/files/patch-ad27
-rw-r--r--devel/gnu-autoconf/Makefile1
-rw-r--r--devel/gnu-autoconf/files/patch-ad27
24 files changed, 204 insertions, 132 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf/files/patch-ad b/devel/autoconf/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf/files/patch-ad
+++ b/devel/autoconf/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf213/Makefile b/devel/autoconf213/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf213/Makefile
+++ b/devel/autoconf213/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf213/files/patch-ad b/devel/autoconf213/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf213/files/patch-ad
+++ b/devel/autoconf213/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf253/Makefile b/devel/autoconf253/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf253/Makefile
+++ b/devel/autoconf253/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf253/files/patch-ad b/devel/autoconf253/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf253/files/patch-ad
+++ b/devel/autoconf253/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf254/Makefile b/devel/autoconf254/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf254/Makefile
+++ b/devel/autoconf254/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf254/files/patch-ad b/devel/autoconf254/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf254/files/patch-ad
+++ b/devel/autoconf254/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf257/Makefile b/devel/autoconf257/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf257/Makefile
+++ b/devel/autoconf257/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf257/files/patch-ad b/devel/autoconf257/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf257/files/patch-ad
+++ b/devel/autoconf257/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf259/Makefile b/devel/autoconf259/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf259/Makefile
+++ b/devel/autoconf259/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf259/files/patch-ad b/devel/autoconf259/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf259/files/patch-ad
+++ b/devel/autoconf259/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf26/Makefile b/devel/autoconf26/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf26/Makefile
+++ b/devel/autoconf26/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf26/files/patch-ad b/devel/autoconf26/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf26/files/patch-ad
+++ b/devel/autoconf26/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf261/Makefile b/devel/autoconf261/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf261/Makefile
+++ b/devel/autoconf261/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf261/files/patch-ad b/devel/autoconf261/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf261/files/patch-ad
+++ b/devel/autoconf261/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf262/Makefile b/devel/autoconf262/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf262/Makefile
+++ b/devel/autoconf262/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf262/files/patch-ad b/devel/autoconf262/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf262/files/patch-ad
+++ b/devel/autoconf262/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf267/Makefile b/devel/autoconf267/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf267/Makefile
+++ b/devel/autoconf267/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf267/files/patch-ad b/devel/autoconf267/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf267/files/patch-ad
+++ b/devel/autoconf267/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/autoconf268/Makefile b/devel/autoconf268/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf268/Makefile
+++ b/devel/autoconf268/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf268/files/patch-ad b/devel/autoconf268/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf268/files/patch-ad
+++ b/devel/autoconf268/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+
diff --git a/devel/gnu-autoconf/Makefile b/devel/gnu-autoconf/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/gnu-autoconf/Makefile
+++ b/devel/gnu-autoconf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/gnu-autoconf/files/patch-ad b/devel/gnu-autoconf/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/gnu-autoconf/files/patch-ad
+++ b/devel/gnu-autoconf/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+