aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/subversion/Makefile.common8
-rw-r--r--devel/subversion16/Makefile.common8
2 files changed, 10 insertions, 6 deletions
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index 8f1f53c36432..85d74367cd1c 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.5.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.4/:book
@@ -31,7 +31,8 @@ OPTIONS=
CONFIGURE_ARGS+= --without-swig
-.if defined(WITH_NEON)
+# Default is "on"
+.if !defined(WITHOUT_NEON)
LIB_DEPENDS+= neon.28:${PORTSDIR}/www/neon28
CONFIGURE_ARGS+= --with-neon=${LOCALBASE}
PLIST_SUB+= NEON=""
@@ -57,7 +58,8 @@ CONFIGURE_ARGS+= --without-sasl
PLIST_SUB+= SASL="@comment "
.endif
-.if defined(WITH_BDB)
+# Default us "on"
+.if !defined(WITHOUT_BDB)
PLIST_SUB+= BDB=""
.else
CONFIGURE_ARGS+= --without-berkeley-db
diff --git a/devel/subversion16/Makefile.common b/devel/subversion16/Makefile.common
index 8f1f53c36432..85d74367cd1c 100644
--- a/devel/subversion16/Makefile.common
+++ b/devel/subversion16/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.5.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.4/:book
@@ -31,7 +31,8 @@ OPTIONS=
CONFIGURE_ARGS+= --without-swig
-.if defined(WITH_NEON)
+# Default is "on"
+.if !defined(WITHOUT_NEON)
LIB_DEPENDS+= neon.28:${PORTSDIR}/www/neon28
CONFIGURE_ARGS+= --with-neon=${LOCALBASE}
PLIST_SUB+= NEON=""
@@ -57,7 +58,8 @@ CONFIGURE_ARGS+= --without-sasl
PLIST_SUB+= SASL="@comment "
.endif
-.if defined(WITH_BDB)
+# Default us "on"
+.if !defined(WITHOUT_BDB)
PLIST_SUB+= BDB=""
.else
CONFIGURE_ARGS+= --without-berkeley-db