aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/xine/Makefile7
-rw-r--r--multimedia/xine/files/extra-patch-src:xitk:common.h11
2 files changed, 17 insertions, 1 deletions
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index eecc19d48e97..7e57960b28f8 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xine
PORTVERSION= 0.9.18
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}-ui-${PORTVERSION}
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= An X11 multimedia player
-LIB_DEPENDS= xine.3:${PORTSDIR}/multimedia/libxine \
+LIB_DEPENDS= xine.4:${PORTSDIR}/multimedia/libxine \
aa.1:${PORTSDIR}/graphics/aalib \
png.5:${PORTSDIR}/graphics/png \
intl.4:${PORTSDIR}/devel/gettext
@@ -45,6 +46,10 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif
.endif
+.if (${OSVERSION} == 500043)
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src:xitk:common.h
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|THREAD_LIBS=.*$$|THREAD_LIBS="\$$THREAD_LIBS"|g ; \
diff --git a/multimedia/xine/files/extra-patch-src:xitk:common.h b/multimedia/xine/files/extra-patch-src:xitk:common.h
new file mode 100644
index 000000000000..55a644b31ff2
--- /dev/null
+++ b/multimedia/xine/files/extra-patch-src:xitk:common.h
@@ -0,0 +1,11 @@
+--- src/xitk/common.h.orig Mon Feb 24 22:39:16 2003
++++ src/xitk/common.h Mon Feb 24 22:39:46 2003
+@@ -31,6 +31,8 @@
+ #include <xine.h>
+ #include <xine/xineutils.h>
+
++#define ushort unsigned short
++
+ #include "Imlib-light/Imlib.h"
+
+ #include "xitk.h"