aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/xmms2-scrobbler/Makefile31
-rw-r--r--audio/xmms2-scrobbler/distinfo5
-rw-r--r--audio/xmms2-scrobbler/files/pkg-message.in24
3 files changed, 35 insertions, 25 deletions
diff --git a/audio/xmms2-scrobbler/Makefile b/audio/xmms2-scrobbler/Makefile
index 70e9b9125959..a7a9da1682b9 100644
--- a/audio/xmms2-scrobbler/Makefile
+++ b/audio/xmms2-scrobbler/Makefile
@@ -5,36 +5,31 @@
# $FreeBSD$
PORTNAME= xmms2-scrobbler
-PORTVERSION= 0.1.3
-PORTREVISION= 2
-CATEGORIES= audio ruby
-MASTER_SITES= http://exodus.xmms.se/~tilman/
+PORTVERSION= 0.4.0
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.code-monkey.de/pub/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= A last.fm submission client for XMMS2
-BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/xmmsclient_ext.so:${PORTSDIR}/audio/ruby-xmms2 \
- ${RUBY_SITELIBDIR}/event-loop.rb:${PORTSDIR}/devel/ruby-event-loop
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/xmmsclient_ext.so:${PORTSDIR}/audio/ruby-xmms2 \
- ${RUBY_SITELIBDIR}/event-loop.rb:${PORTSDIR}/devel/ruby-event-loop
+LIB_DEPENDS= xmmsclient.5:${PORTSDIR}/audio/xmms2 \
+ curl.6:${PORTSDIR}/ftp/curl
-USE_RUBY= yes
-USE_RAKE= yes
-NO_BUILD= yes
+USE_GMAKE= yes
+MAKE_ENV= LDFLAGS="${PTHREAD_LIBS}"
-PLIST_FILES= bin/xmms2-scrobbler \
- %%DATADIR%%/filters/britney.rb \
- %%DATADIR%%/filters/musicbrainz.rb
-PLIST_DIRS= %%DATADIR%%/filters %%DATADIR%%
+PLIST_FILES= bin/xmms2-scrobbler
+PORTDOCS= README
SUB_FILES= pkg-message
-do-install:
- @cd ${WRKSRC} && ${RAKE_BIN} PREFIX=${PREFIX}/ ${INSTALL_TARGET}
-
post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}; \
+ cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/audio/xmms2-scrobbler/distinfo b/audio/xmms2-scrobbler/distinfo
index beb66c7ae96d..f33f29a58a89 100644
--- a/audio/xmms2-scrobbler/distinfo
+++ b/audio/xmms2-scrobbler/distinfo
@@ -1,3 +1,2 @@
-MD5 (xmms2-scrobbler-0.1.3.tar.gz) = 4d7fde80a5a6c963cf46864f2747d773
-SHA256 (xmms2-scrobbler-0.1.3.tar.gz) = 2c2306eedab88f3b8ee4b8ab07b84405349d35e0ce4a57e300f491f70049cf26
-SIZE (xmms2-scrobbler-0.1.3.tar.gz) = 6466
+SHA256 (xmms2-scrobbler-0.4.0.tar.gz) = 7aed1670f381463e44466083f2e49119636e96005b9b93899edf79d613a2d2bc
+SIZE (xmms2-scrobbler-0.4.0.tar.gz) = 19831
diff --git a/audio/xmms2-scrobbler/files/pkg-message.in b/audio/xmms2-scrobbler/files/pkg-message.in
index da2b416309d3..af7b5a0bc7a2 100644
--- a/audio/xmms2-scrobbler/files/pkg-message.in
+++ b/audio/xmms2-scrobbler/files/pkg-message.in
@@ -1,8 +1,24 @@
-To use XMMS2Scrobbler write your username and password to the config file
-like this:
+You need to set up XMMS2-Scrobbler's config files.
+Config values that are specific to the AudioScrobbler server go in
+ ~/.config/xmms2/clients/xmms2-scrobbler/$SERVER_NAME/config.
+You will usually have
+ ~/.config/xmms2/clients/xmms2-scrobbler/lastfm/config
+and maybe
+ ~/.config/xmms2/clients/xmms2-scrobbler/librefm/config.
- printf "user: foo\npassword: bar" > \
- ~/.config/xmms2/clients/xmms2-scrobbler/config
+These server-specific config files contain your username and password
+and the URL to use:
+ mkdir ~/.config/xmms2/clients/xmms2-scrobbler/librefm/config
+ echo -e "user: foo\npassword: bar\nhandshake_url: http://post.audioscrobbler.com\n" > \
+ ~/.config/xmms2/clients/xmms2-scrobbler/lastfm/config
+For libre.fm, use
+ handshake_url: http://turtle.libre.fm.
+
+Optionally, if you're behind a proxy, you'll need to tell XMMS2-Scrobbler
+about that proxy. This information applies to all servers and so goes in
+~/.config/xmms2/clients/xmms2-scrobbler/config:
+ echo -e "proxy: my.proxynproxy_port: 8080\n" >> \
+ ~/.config/xmms2/clients/xmms2-scrobbler/config
~/.config is actually $XDG_CONFIG_HOME whose default value is ~/.config.